A nouveau plus de prévisualisation avec la dernière version

Pour les retours sur la v5 uniquement ...

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar phyllox » Mer 02 Jan, 2019 15:12

Hello Pepsi, tout le monde

Bonne année à tous, tout d'abord, je crois que vu l'heure, j'ai oubolié complètement hier soir !

Depuis mon poste d'hier soir, j'ai réinstallé la 5.1 et j'ai pu réencoder sans souci jusqu'à maintenant. Mais le problème s'est reproduit.Je viens de créer 2 tâches de réencodage, à partir de mon preset habituel (1440x812 x264 + aac 128 + mp4).

J'ai lancé l'exécution et m4ng s'est planté sans message (juste sorti du programme sans avertissement).

Rouvrant m4ng, je charge la première tâche (depuis la liste sauvegardée), puis la seconde. Et c'est sur le chargement de la seconde, pourtant choisie dans la liste, que m4ng m'affiche une fenêtre sans titre avec le message : INTROUVABLE.

C'est exactement les soucis que j'avais eu durant mon premier essai. Les vidéos ne se lançaient pas (ça me revient maintenant), je pense parce que m4ng ne trouvait pas la tâche pourtant juste sauvegardée.

Je précise que je sauvegarde systématiquement les tâches créées, en cliquant sur la disquette à côté de la tâche créée dans "Conversions à effectuer"

La tâche que j'essaye de rappeler avec l'option Tâche (Charger une tâche de conversion) est la tâche sauvegardée manuellement, celle qui apparaît en majuscules (je pense que la sauvegarde automatique est celle qui apparaît en minuscule).

Je viens d'essayer de choisir plutôt la tâche sauvegardée automatiquement (en minuscule). Celle ci s'est chargée normalement et j'ai pu lancer le réencodage.

Je ne sais pas ce que la vidéo concernée peut avoir de différent pour que la sauvegarde n'ait pas été trouvée. Pas de caractères spéciaux dans le titre, même chemin d'origine et de destination pour le film.

je sauvegarde systématiquement comme je viens de l'écrire, et c'est seulement quelques vidéos qui sont concernées (une seule depuis hier, et 2 ou 3 dans mon premier essai).

A noter que j'ai désinstallé AviSynth et M4ng v5 avant installation de la 5.1 et supprimé complètement le répertoire appdata\roaming\m4ng avanlt la nouvelle install.
La tâche qui fonctionne (en minuscule) et celle qui ne fonctionne pas (en majuscules) apparaissent toutes les deux dans le répertoire Tasks, toutes les deux à 89k.

J'ai laissé cette info dans le même post, puisque je réponds à ta dernière question, mais peut être faut-il un nouveau sujet ?

Merci, bonne journée
phyllox
 
Messages: 269
Inscription: 02 Fév 2009

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar pepsilite » Mer 02 Jan, 2019 16:16

Peut être qu'il y a un bug qui traîne dans m4ng quelque part quand on crée une 2ème tâche alors que la première est toujours en mémoire. Essaye de faire tes tâches une par une en fermant m4ng entre chaque puis recharge-les pour voir si le plantage y est toujours...
Pas besoin de nouveau sujet.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23064
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar phyllox » Mer 02 Jan, 2019 18:41

Ben pas facile de recréer un bug aléatoire
N'ayant jamais eu ça avec la 5.0, je suppose que c'est une modification de la 5.1 qui le génère. Les tâches et les presets de la 5.0 ne fonctionnent plus en 5.1, donc il y a forcément des modifications ?

J'ai le souci aussi avec une seule tâche chargée, le problème c'est que ne vois pas ce qui la différencie des autres. Il doit bien y avoir des conditions qui génèrent ce message "Introuvable" dans le programme, non ? Quelles sont elles ?

Merci
phyllox
 
Messages: 269
Inscription: 02 Fév 2009

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar pepsilite » Mer 02 Jan, 2019 18:47

1. Oui il y a eu des modifs entre la 5 et la 5.1 pour les tâches.
2. As-tu essayé de créer les tâches une par une comme je t'ai demandé ?
3. Le message "introuvable" arrive comment à l'écran exactement ?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23064
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar Ducke » Mer 02 Jan, 2019 19:56

pepsilite a écrit:En fait, j'ai la prévisualisation là encore en lançant 2 sessions de m4ng en parallèle, ça commence à être pénible, mais en tout cas, l'autocrop ne génère pas ces bandes de "vides" chez moi.


:mdr chez moi ça fonctionne très bien :d:
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8576
Inscription: 08 Fév 2007

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar phyllox » Mer 02 Jan, 2019 23:56

@Pepsi
Oui, je crée les tâches une par une, ça ne change rien.
De temps en temps, je tombe sur une tâche qui n'est pas reconnue. Si je lance l'encodage, m4ng se "plante", et je suis obligé de le relancer. Au démarrage, je vais dans "tâches", et je sélectionne la tâche que j'ai sauvegardée juste avant et qui apparaît normalement dans le répertoire task. Dès que je l'ai sélectionné, j'ai le message : Introuvable. m4ng ne peut pas la charger.

Je viens d'essayer de "refaire" une tâche qui avait bogué cette après midi (après l'avoir supprimée du répertoire tasks) et cette fois, la tâche a été acceptée.

Voici un lien vers le message :
Image

Pas facile de tester ça, parce que la plupart du temps les tâches sont sauvegardées normalement et fonctionne.

Je pense que l'analyse du "qu'est ce qui peut générer le message Introuvable" que je reçois te renseignera plus efficacement que mes tests à l'aveugle et au petit bonheur.
phyllox
 
Messages: 269
Inscription: 02 Fév 2009

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar phyllox » Mer 02 Jan, 2019 23:57

Les images ne fonctionnant pas et ne connaissant pas la méthode pour les insérer dans ce forum, voici le lien :

https://drive.google.com/file/d/1OHrSvy ... sp=sharing

Merci, bonne soirée
phyllox
 
Messages: 269
Inscription: 02 Fév 2009

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar pepsilite » Jeu 03 Jan, 2019 12:46

Ok, je vois mieux avec l'image, le hic c'est que ce message est utilise 81 fois dans m4ng... J'ai du mal à identifier celui qui apparaît chez toi, je pense l'avoir mais ça ne m'éclaire guère plus en fait.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23064
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar pepsilite » Jeu 03 Jan, 2019 12:48

Ce sont des tâches de RIP de DVD ou de réencodages de vidéos ?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23064
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar pepsilite » Jeu 03 Jan, 2019 12:52

Ok, j'ai identifié la raison du message, il apparait quand la source vidéo de la tâche est "introuvable", comme si elle avait été effacée ou déplacée. Ce qui, je suppose, n'est pas le cas chez toi ?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23064
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar phyllox » Jeu 03 Jan, 2019 15:14

Hello
Oui, je pensais l'avoir expliqué longuement. La tâche non seulement n'a pas disparue, mais elle est sélectionnée par M4ng dans la liste des tâches donnée par M4ng lui même en cliquant sur le bouton "tâche".

Comme je l'ai dit dans un poste précédent, non seulement elle existe (du moins un fichier de ce nom existe), mais ce fichier a la même taille physique que les autres tâches qui fonctionnent. J'ai édité toutes les tâches avec Notepad++, mais à part le nom du fichier source, elles ne sont pas lisibles (fichier rempli de [nul])...

Après ça dépend de ce que M4ng contrôle avant d'envoyer le message, si c'est la présence du fichier tâche ou aussi son contenu.
Je pourrais aussi penser à un problème de droits, mais si c'était le cas, pourquoi M4ng aurait-il pu créer la tâche, pour ne plus pouvoir l'ouvrir juste après. Et pourquoi seulement sur quelques unes d'entre elles et pas toutes.

J'ai vu que la plupart des tâches sauvegardées que j'ai commencent par 000 quelque chose, et quelques autres par 001... J'en ai même une en 002_. Ca pourrait être un numéro d'ordre d'exécution, mais pourquoi sur les tâches sauvegardées manuellement et pas sur les sauvegardes automatiques ? Et puis, j'en ai une avec le même unom, une fois en 000 et une autre en 001...Pourtant, je sauvegarde toujours sans changer le nom, et si je re-sauvegarde une tâche, M4ng me demande s'il doit écraser l'ancienne ce que je valide. Du coup, je ne pige pas pourquoi j'ai du 000_ et du 001_... Est-ce qu'il ne pourrait pas "se perdre" avec ça ?

A notre par ailleurs que c'est assez perturbant quand on "rappelle" une tâche d'avoir à la fois la sauvegarde automatique et la sauvegarde manuelle. On se demande laquelle il faut choisir. Enfin, depuis le temps, ça n'est plus vraiment un souci, mais quand beaucoup de fichiers ont le même nom les épisodes de série par exemple) c'est parfois un peu gênant.

Merci de tes recherches.
Bon après-midi.
phyllox
 
Messages: 269
Inscription: 02 Fév 2009

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar Subbat » Jeu 03 Jan, 2019 15:38

phyllox a écrit:Hello
Oui, je pensais l'avoir expliqué longuement. La tâche non seulement n'a pas disparue, mais elle est sélectionnée par M4ng dans la liste des tâches donnée par M4ng lui même en cliquant sur le bouton "tâche".


Ca n'était pas la question de pepsi de savoir si la tache avait disparu... mais la vidéo source à laquelle fait référence la tache...
Ce que pepsi te disait c'est que ton message -[INTROUVABLE] veut normalement dire que la vidéo source n'est pas trouvable...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8471
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar phyllox » Jeu 03 Jan, 2019 16:06

hello
Oui, désolé, mauvaise lecture...
Bien entendu, la vidéo source n'a pas disparu non plus. En fait je prépare la tâche à partir de la vidéo source, la sauvegarde, et lance l'encodage dans la foulée...
Et par ailleurs, j'ai dit qu'en appelant la sauvegarde automatique, la tâche se lançait, du moins dans l'exemple sur lequel je suis tombé.

Par contre, en éditant les tasks avec Notepad++, j'en ai trouvé une ou le nom de la vidé source n'apparaissait pas. Je me suis dit que le problème devait venir de là...
Mais j'ai essayé de charger cette tâche, et elle s'est chargée normalement, avec la bonne source. Du coup je n'en ai pas parlé dans mon message prédédent.
Et comme maintenant cettetâche a été remplacée, je ne peux pas l'envoyer en exemple.

A+
phyllox
 
Messages: 269
Inscription: 02 Fév 2009

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar Subbat » Jeu 03 Jan, 2019 16:19

Pour tout ça seul pepsi pourra te répondre...
En revanche, je ne comprend pas le but d'enregistrer une tache si c'est pour la lancer de suite... autant cliquer sur convertir plutôt que sur enregistrer la tache...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8471
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar pepsilite » Jeu 03 Jan, 2019 16:28

Ce fichier de tâches sans le nom de la vidéo source, il est certain que ça vient forcément de là. Reste à découvrir pourquoi le nom disparait. Surement un cas spécial non référencé.

Sinon, bonne nouvelle quand même, après y avoir passé 2h à me creuser la tête pour essayer de comprendre pourquoi la prévisualisation marchait uniquement quand on lançait à coté une autre vidéo, soit dans un player soit dans un autre m4ng, j'ai fini par trouver le pourquoi du comment et ça (re)marche... Ce n'est pas un bug à proprement parler, c'est une modif dans la gestion de la transparence des fenêtres dans le code de windows directement et en fait la vidéo était bien là mais totalement transparente, donc invisible. ça fait quand même plus propre comme ça... Je fournirai le correctif le plus vite possible mais j'attends de voir si je peux aussi trouver ce qui cloche chez notre ami avec ses tâches.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23064
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar pepsilite » Jeu 03 Jan, 2019 16:30

Une chose encore, il ne FAUT PAS (jamais) charger ce que tu appelles une "tâche automatique" en 000, 001 etc, ce sont des fichiers de travail de m4ng et pas des sauvegardes à part entière.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23064
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar pepsilite » Jeu 03 Jan, 2019 16:35

Subbat a écrit:Ce que pepsi te disait c'est que ton message -[INTROUVABLE] veut normalement dire que la vidéo source n'est pas trouvable...

En fait, devant le -[INTROUVABLE] se trouve le nom de la vidéo mais s'il est blanc, il n'y a rien devant ...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23064
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar phyllox » Jeu 03 Jan, 2019 18:11

Rebonsoir

@Subbat
En revanche, je ne comprend pas le but d'enregistrer une tache si c'est pour la lancer de suite... autant cliquer sur convertir plutôt que sur enregistrer la tache...

C'est parce que je lance souvent plusieurs encodages durant la nuit. Comme de temps à autre la machien ne va pas au bout des tâches, en général parce que Windows a décidé de redémarrer la machine pour une MAJ malgré le fait qu'elle travaille, je peux les relancer le matin sans avoir à les re-créer.

@Pepsi
Une chose encore, il ne FAUT PAS (jamais) charger ce que tu appelles une "tâche automatique" en 000, 001 etc, ce sont des fichiers de travail de m4ng et pas des sauvegardes à part entière.

Le problème vient peut être de là. Comme je ne sais jamais quelles sont les tâches sauvegardées automatiquement et celles que je fais manuellement, je me fie à la date et heure de sauvegarde en triant les tâches par dates descendantes. Il me semble que ces derniers temps, pas mal de tâches 000 et 001 en majuscule avaient un horodatage plus récent que les tâches manuelles, et il est possible que je les aie sélectionnées en lieu et place des manuelles...

Quoique... Ca pourrait expliquer le message lorsque je les charge, mais ça n'expliquerait pas pourquoi M4ng se plante quand je lance l'encodage directement après la sauvegarde des tâches à lancer,...

Pour l'instant, je n'ai plus d'exemple de tâche qui se plantent. Je vais essayer à nouveau de reproduire le problème avec mon stock de vidéos sources pas encore effacées.

Pour autant, pourquoi mettre dans le même répertoire les tâches de travail de M4ng et les sauvegardes manuelles ? Je crois me souvenir qu'autrefois, on pouvait choisir le répertoire pour stocker les tâches et les profils, plus pratique par ailleurs que \appdata\roaming, surtout pour les effacer ensuite. Un répertoire séparé permettrait d'éviter les erreurs surtout s'il ne faut pas toucher aux tâches créées par le système. Enfin...

Si j'arrive a recréer une fois de plus le problème d'ici demain, je reviens dans ce post.

Merci, bonne soirée
phyllox
 
Messages: 269
Inscription: 02 Fév 2009

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar pepsilite » Jeu 03 Jan, 2019 18:42

C'est pourtant simple, les tâches de m4ng sont les seules à commencer par des chiffres 000 sauf si tu utilises le même code que lui, il suffit de ne pas en tenir compte.
Il n'a jamais été possible de choisir le dossier de stockage des tâches mais personne n'a jamais eu de souci avec non plus. La seule alternative est de basculer en mode "chainless" dans les paramètres et en installant m4ng ailleurs que sur le disque de windows, le dossier de travail sera m4ng_work à la racine de l'installation mais là encore toutes les tâches seront dans le même dossier. Cela dit, il est tout à fait possible d'effacer les tâches même dans roaming, dès que m4ng est fermé, il n'a plus besoin des tâches 000 et c°, il ne les efface pas parce que j'avoue n'y avoir jamais pensé...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23064
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar phyllox » Sam 05 Jan, 2019 18:36

Bonsoir à tour
Depuis jeudi, je n'ai pas réussi à reprosuire le problème, bien qu'ayant essayé pas mal de trucs,e ntre sauvegarder les unes et pas les autres.
Il doit se produire un truc tordu dans des cas tordus dans l'autre sens auxquels je ne pense pas ; ça se reproduira quand je ne m'y attendrai plus.

Je suis a peu près certain d'avoir édité l'autre jour des tasks dans lesquels la vidéo source n'apparaissait pas dans Notepad++ (il y avait des [Nul] à la place). Mais comme j'avais réussi à ouvrir ce task avec m4ng, et que par la suite j'ai tout viré pour faire d'autres tests...

Si ça se reproduit - ce dont hélas je ne doute pas - je referai un post...

Pepsi, tu dis qu'il ne faut pas utiliser les sauvegardes 000 ou 001 quelque chose, mais si on ne sauvegarde pas manuellement et qu'on a besoin de relancer le task, il n'y a bien que celui là qui est disponible ?

Je vais donc attendre la MAJ de M4ng pour la prévisualisation et voir si elle résout le problème d'origine. Il me semble que ça pourrait être différent car j'avais essayé de lancer une vidéo par derrière... Enfin on verra bien.

Bonne soirée
phyllox
 
Messages: 269
Inscription: 02 Fév 2009

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar pepsilite » Sam 05 Jan, 2019 19:11

Les fichiers 000 et c° ne SONT PAS des sauvegardes automatiques, mais des fichiers de travail temporaires de m4ng... Il ne faut pas les utiliser, il faut faire comme s'ils n'existaient pas, au risque de tout planter, ce qui peut expliquer tes problèmes.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23064
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Re: A nouveau plus de prévisualisation avec la dernière vers

Messagepar phyllox » Mer 16 Jan, 2019 12:27

Hello, bonjour tout le monde

Je viens d'avoir un nouveau plantage au lancement de l'encodage.

J'ai mis 4 tâches dans le batch d'encodage et c'est la 4e qui a provoqué le plantage.
Je précise que ça n'est pas lié au chargement manuel d'une tâche de travail m4ng, puisque j'ai préparé les 4 tâches comme à l'accoutumé, à la suite les unes des autres, en les sauvegardant à chaque fois à la fin, et qu'ensuite, j'ai lancé l'encodage directement derrière, sans fermer quoi que ce soit.

Au lieu de démarrer l'encodage, m4ng s'est fermé.

Après avoir rouvert m4ng, je peux recharger les 4 tâches que j'ai sauvegardées (qui commencent par $$), et je peux les lancer les tâches normalement.

Pour essayer d'analyser le problème, j'ai également rechargé les tâches de travail de m4ng (qu'il ne faut pas utiliser, j'ai bien noté) et qui commencent ici par 000, 001, 002 et 003. La 003 provoque le message [introuvable].

J'en conclus que c'est la tâche de travail de m4ng qui provoque le plantage du logiciel, puisque la sauvegarde manuelle fonctionne, mais que le logiciel se plante au démarrage de l'encodage, sans qu'on ait touché au tâches sauvegardées.

La tâche de travail de m4ng provoque le message [introuvable] parce que - en tous cas dans cet exemple - la lettre de lecteur n'existe pas dans le chemin du fichier. Il u a [Nul] à la place : [NUL]:\Ciné\Arte - Nom du film.m2ts. (Il me semble que dans les plantages précédents, il pouvait y avoir davantage de bouts de titre manquants).

Quoi qu'il en soit, le plantage, je le redis, n'est pas provoqué par le chargement volontaire d'une tâche de travail. Mais à mon avis par l'utilisation par m4ng de cette tâche de travail incorrectement créée.

Merci d'avance
Bonne journée
phyllox
 
Messages: 269
Inscription: 02 Fév 2009

Précédente

Retourner vers m4ng v5

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités