Couper une vidéo TS. Gros soucis

Un soucis avec vos appareils multimédia ? Besoin d'aide ?

Modérateur: Modérateurs

Couper une vidéo TS. Gros soucis

Messagepar qwertz » Lun 21 Oct, 2013 11:11

Bonjour.

J’effectue des enregistrements HDTV 720p ou 1080i.

Après avoir transféré les enregistrements sur mon PC je doit encore coupé les scène pour supprimer les pubs par exemple.

Le problème, c'est que une fois les fichiers rassemblé après la coupe. J'ai des artefacts de deux secondes qui apparaissent la ou la coupe à eu lieu. Les images ce chevauches.

J'ai tenté la coupe avec plusieurs logiciel. Videoredo TV Suite H264, TS-Doctor, Avidemux, TSMuxer, MKVmerge (MKVMerge est celui qui s'en sort le mieux, mais n'est pas du tout précis, même à la milliseconde près

Par contre, je n'est aucun problème de coupe avec des vidéos TS qui ont des trames IDR


Une idée

Merci
qwertz
 
Messages: 3
Inscription: 21 Oct 2013

Messagepar Subbat » Lun 21 Oct, 2013 11:43

Salut,

Le problème des coupes sans ré-encodage, c'est que soit elle se font sur des images clés, et du coup, la coupe ne peut pas être là où on le veut vraiment... soit on force à couper là où on veut, mais si ça tombe sur une image qui n'est pas sur une image clé, alors effectivement, l'image n'est pas complète donc ça fait les artefacts dont tu parles...

Il faut ajouter à ça que sur les enregistrements TV, il peut y avoir des manque d'images... ce qui n'aide pas non plus...

Ce que je te conseillerais, c'est de ré-encoder tes enregistrements avec m4ng, en mode autonome exclusivement pour le cas d'enregistrement TV, et d'utiliser le module m4mbo accessible depuis la prévisualisation...

Tu pourras ainsi faire tes coupes à l'image près... Et s'il y a des images manquantes à quelque endroit que ce soit sur la vidéo, ffmpeg, qui est utilisé avec le mode autonome, a la faculté de lui même dupliquer l'image précédent celle manquante pour ainsi ne pas créer de décalage audio sur la vidéo finale...

Et même si un ré-encodage est toujours un peu destructeur par rapport à la source, en choisissant un bon débit vidéo et le codec x264, tu ne verras même pas la différence avec ton originale... Et personnellement je te conseille même d'utiliser le mode crf plutôt que le mode débit fixe pour la vidéo...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar qwertz » Lun 21 Oct, 2013 12:05

Merci pour le conseil.

Je vais tester.
qwertz
 
Messages: 3
Inscription: 21 Oct 2013

Messagepar Subbat » Lun 21 Oct, 2013 13:26

Alors bons tests... ;)
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...


Retourner vers Assistance

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités