[Résolu] Dédoublement des sous-titres à l'encodage

Modérateur: Modérateurs

Dédoublement des sous-titres à l'encodage

Messagepar Kwayde » Mar 24 Avr, 2012 23:39

Bonjour,
Cela fait quelques temps que j'encode avec m4ng, et ce petit désagrément arrive de plus en plus : lorsque j'encode des sous-titres à une vidéo, il se voit dédoublé sur le fichier final , voilà un exemple -> http://nsa22.casimages.com/img/2012/04/ ... 751273.png
Je précise que le fichier final ne porte pas le même nom que le fichier de sous-titres, ce qui aurait pu causer ce défaut. J'encode aussi dans un dossier directement dans C:/ .
Pourriez-vous m'aiguiller ?

J'ai m4ng V3.2.0.0 et XP SP3
Kwayde
 
Messages: 20
Inscription: 07 Jan 2010

Messagepar Ducke » Mer 25 Avr, 2012 16:30

salut, ils sont dans quel format les sous-titres ? srt ssa?
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8548
Inscription: 08 Fév 2007

Messagepar misterd » Mer 25 Avr, 2012 17:26

Salut,
Peut-être qu' il y a plusieurs logiciels (ou filtres) qui lisent les sous-titres en même temps (filtre interne du lecteur + vobsub, ffdshow,...)
Avatar de l’utilisateur
misterd
 
Messages: 483
Inscription: 24 Oct 2007

Messagepar Kwayde » Mer 25 Avr, 2012 18:12

J'encode des fichiers en .avi avec des fichiers .srt , tout ce qu'il y a de plus basique !
Kwayde
 
Messages: 20
Inscription: 07 Jan 2010

Messagepar Ducke » Mer 25 Avr, 2012 20:30

Dans la prévisualisation de m4ng tu as déjà le problème?
Je pense comme misterd tu dois avoir plusieurs lecteurs de sous-titres, il faudrait que tu en désactive un.
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8548
Inscription: 08 Fév 2007

Messagepar Kwayde » Mer 25 Avr, 2012 20:53

Je viens de tester, et non je n'ai pas ce problème à la prévisualisation dans m4ng
Kwayde
 
Messages: 20
Inscription: 07 Jan 2010

Messagepar Underground78 » Mer 25 Avr, 2012 22:27

Mais tu vois déjà des sous-titres à ce moment là ?

Tu as procédé comment exactement ? Tu es allé dans la prévisualisation à quel moment ?
Avatar de l’utilisateur
Underground78
Administrateur
Administrateur
 
Messages: 11267
Inscription: 06 Fév 2007
Localisation: France

Messagepar Kwayde » Mer 25 Avr, 2012 23:34

1 - Je sélectionne mon film
2 - je sélectionne mon fichier .srt
3 - je coche "incruster les sous-titres"
4 - Prévisualisation , et là mes sous-titres apparaissent et sont corrects, pas dédoublés

Ce n'est qu'une fois l'encodage fini qu'ils sont dédoublés
Kwayde
 
Messages: 20
Inscription: 07 Jan 2010

Messagepar Ducke » Jeu 26 Avr, 2012 5:56

ton fichier de sortie ne se trouverais pas le même dossier que ton fichier srt? ce qui voudrais dire que ton lecteur lit ton film avec tes sous-titres incruster et lit aussi le fichier de srt?
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8548
Inscription: 08 Fév 2007

Messagepar Kwayde » Jeu 26 Avr, 2012 8:16

Oui il se trouve dans le même dossier, mais comme le fichier final ne porte pas le même nom, cela ne se peut.

Au départ : film.avi + fichier.srt -> out_film.avi

Et en déplaçant le fichier final sur le bureau par exemple, le résultat est le même. En supprimant le sous-titre aussi. J'ai déjà regardé dans les processus pour voir si un lecteur de sous-titres n'était pas encore actif, mais rien, j'ai même redémarré mon ordi, puis relu mon fichier final mais là encore ce dédoublement :(
Kwayde
 
Messages: 20
Inscription: 07 Jan 2010

Messagepar Underground78 » Jeu 26 Avr, 2012 17:37

Kwayde a écrit:1 - Je sélectionne mon film
2 - je sélectionne mon fichier .srt
3 - je coche "incruster les sous-titres"
4 - Prévisualisation , et là mes sous-titres apparaissent et sont corrects, pas dédoublés

Ce n'est qu'une fois l'encodage fini qu'ils sont dédoublés


Si tu ne fais pas l'étape 3, il n'y a pas bien pas de sous-titres ?
Avatar de l’utilisateur
Underground78
Administrateur
Administrateur
 
Messages: 11267
Inscription: 06 Fév 2007
Localisation: France

Messagepar Kwayde » Jeu 26 Avr, 2012 19:54

Oui, si je zappe l'étape 3, les sous-titres n'apparaissent pas à la prévisualisation
Kwayde
 
Messages: 20
Inscription: 07 Jan 2010

Messagepar Kwayde » Jeu 26 Avr, 2012 23:55

En attendant de trouver une solution à ce problème, n'y-a-t-il pas moyen de me resservir de la V2 , avec laquelle je n'ai pas eu ce souci, sans que cela me mette "version périmée faites une maj" ?
Kwayde
 
Messages: 20
Inscription: 07 Jan 2010

Messagepar Subbat » Ven 27 Avr, 2012 9:53

Comme déjà dit précédemment, tu dois avoir quelque chose qui lit tes sous-titre en dehors de m4ng... Et passer à m4ng V2 ne changera rien...

C'est déjà arrivé, et la personne avait son ffdshow de régler pour un lecture systématique des sous-titres... en désactivant cette fonction ça avait ensuite marché...

Si ton fichier de sous-titre a le même nom que ta video source, tu peux peut-être essayé de lui donner un autre nom pour voir...

Sinon, ta vidéo source c'est quoi ? un dvd, un avi, un mkv ?
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8417
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Kwayde » Ven 27 Avr, 2012 10:27

- J'ai demandé ça car je n'ai jamais eu ce souci avec la V2.
- Comment désactiver ffdshow de la lecture systématique des sous-titres ? Aurais-tu le lien sur ce forum ? Ca vaut le coup que j'essaie, si cela se trouve c'est ca mon problème. Par contre je devrais peut-être essayer de lire un de mes fichiers "dédoublés" sur un autre ordi pour être sûr
- Changer de nom de sous-titre ou même de l'avi ne change strictement rien, déjà testé plusieurs fois
Kwayde
 
Messages: 20
Inscription: 07 Jan 2010

Messagepar Subbat » Ven 27 Avr, 2012 11:10

Kwayde a écrit:- J'ai demandé ça car je n'ai jamais eu ce souci avec la V2.
- Comment désactiver ffdshow de la lecture systématique des sous-titres ? Aurais-tu le lien sur ce forum ? Ca vaut le coup que j'essaie, si cela se trouve c'est ca mon problème. Par contre je devrais peut-être essayer de lire un de mes fichiers "dédoublés" sur un autre ordi pour être sûr

Bah si tu n'as jamais configurer pour, il y a peu de chances que ce soit ça... mais sinon, tu vas dans la configuration vidéo de ffdshow (accéssible depuis ta barre démarrer - programmes) et tu regardes si "sous-titres" est coché ou non... Il faut qu'il soit décoché...

- Changer de nom de sous-titre ou même de l'avi ne change strictement rien, déjà testé plusieurs fois

Là je parle avant ré-encodage hein...


Et sinon, c'est pourquoi je te demande de quoi tu pars comme vidéo... car si tu pars d'un mkv, il se peut que les sous-titres soient dedans et paramétré pour être forcés à la lecture...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8417
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Kwayde » Ven 27 Avr, 2012 11:46

J'encode des fichiers en .avi avec des fichiers .srt , tout ce qu'il y a de plus basique !

Il s'agit de fichiers .avi

J'ai regardé sur ffdshow, et oui, sous-titres est coché
Kwayde
 
Messages: 20
Inscription: 07 Jan 2010

Messagepar Subbat » Ven 27 Avr, 2012 13:09

Kwayde a écrit:
J'encode des fichiers en .avi avec des fichiers .srt , tout ce qu'il y a de plus basique !

Il s'agit de fichiers .avi

Ah... pardon, j'avais pas fait attention...


J'ai regardé sur ffdshow, et oui, sous-titres est coché

Alors je pense que si tu décoches, ça ne devrait plus être dédoublé...

Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8417
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Kwayde » Ven 27 Avr, 2012 13:31

Pas grave, on peut pas avoir des yeux partout :)

Je viens de tester cocher et décocher, et c'est toujours pareil :(
Le mieux c'est que j'essaie sur un autre ordi pour voir s'il s'agit vraiment de mon fichier final qui a ce problème, ou s'il s'agit de mon ordi. Je vous tiendrai au courant, je dois passer voir un ami ce week-end je regarderai le fichier final chez lui.

Comme cela on pourrait peut-être voir un peu plus clair !

Merci quand même, @très vite
Kwayde
 
Messages: 20
Inscription: 07 Jan 2010

Messagepar Subbat » Ven 27 Avr, 2012 13:47

Je suis pas sur qu'on se soit compris...

Si l'option ffdshow était cochée, il est probable que les sous-titres aient été incrustés 2 fois...

Pour savoir si ça venait de ça, ce n'est pas ton fichier final qu'il faut lire avec ou sans l'option cochée de ffdshow... ce qu'il faut que tu testes, c'est un nouvel encodage (1 min à un endroit où il y a des sous-titres suffit) pour voir si tu as toujours un dédoublement ou non...

[Edit] Je déplacerais ton sujet en section sous-titres quand tu auras lu de message...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8417
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Kwayde » Sam 28 Avr, 2012 16:51

Rebonjour !

Donc voilà :
1- je suis allé lire le fichier final chez un ami, et les sous-titres étaient aussi dédoublé
2- j'ai refait un encodage comme tu me l'as recommandé sur ton post précédent, en décochant les sous-titres dans ffdshow, et cela fonctionne !!!
J'ai tout comme il faut maintenant ! Plus de dédoublage... Mais c'est bizarre que ça ne me le fait pas tout le temps ! enfin pas grave, maintenant que je sais d'où vient ce problème, je saurai comment y remédier !

Merci à vous tous pour l'aide apportée
@bientôt :)
Kwayde
 
Messages: 20
Inscription: 07 Jan 2010

Messagepar Underground78 » Sam 28 Avr, 2012 18:14

Cool ! :)
Avatar de l’utilisateur
Underground78
Administrateur
Administrateur
 
Messages: 11267
Inscription: 06 Fév 2007
Localisation: France

Messagepar Subbat » Sam 28 Avr, 2012 18:15

Cool...

je passe en résolu et je deplace le sujet en section sous-titres...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8417
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...


Retourner vers Sous-titres

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités