Encodage vob et nettoyage d un DVD JAP Maison Ikkoku

Modérateur: Modérateurs

Messagepar leon1789 » Ven 16 Déc, 2011 15:33

ce n'est pas un plugin comme les autres : il faut le charger via Load_Stdcall_plugin("yadif.dll") ou LoadCplugin("yadif.dll")
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar leon1789 » Ven 16 Déc, 2011 15:36

je me suis fait grillé pour quelques secondes ;)
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Subbat » Ven 16 Déc, 2011 15:37

leon1789 a écrit:ce n'est pas un plugin comme les autres : il faut le charger via Load_Stdcall_plugin("yadif.dll") ou LoadCplugin("yadif.dll")


Ah bon... inutile d'indiquer le chemin de la dll ?
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Subbat » Ven 16 Déc, 2011 15:44

leon1789 a écrit:je me suis fait grillé pour quelques secondes ;)


Pas complètement... il avait bien noté le Load_Stdcall_plugin... la question est pour ce qu'il y a entre les parenthèses...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar leon1789 » Ven 16 Déc, 2011 15:45

Subbat a écrit:
leon1789 a écrit:ce n'est pas un plugin comme les autres : il faut le charger via Load_Stdcall_plugin("yadif.dll") ou LoadCplugin("yadif.dll")


Ah bon... inutile d'indiquer le chemin de la dll ?


si si
(je n'ai pris soin de le dire car je n'avais pas penser à ce problème)
Dernière édition par leon1789 le Ven 16 Déc, 2011 15:50, édité 1 fois.
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar leon1789 » Ven 16 Déc, 2011 15:46

Subbat a écrit:
leon1789 a écrit:je me suis fait grillé pour quelques secondes ;)


Pas complètement... il avait bien noté le Load_Stdcall_plugin... la question est pour ce qu'il y a entre les parenthèses...

ok, effectivement, je n'ai pas suivi (lecture trop rapide)
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar godai61 » Ven 16 Déc, 2011 16:37

Voila mon script

LoadPlugin("C:\Documents and Settings\GODAI\Bureau\MeGUI_2050_x86\tools\dgindex\DGDecode.dll")
DGDecode_mpeg2source("D:\vob 18-19-20 ripp\mi17\petit essai\petit essai.d2v", info=3)


LoadPlugin("C:\Documents and Settings\GODAI\Bureau\MeGUI_2050_x86\tools\avisynth_plugin\TIVTC.dll")


Load_Stdcall_Plugin("C:\Documents and Settings\GODAI\Bureau\MeGUI_2050_x86\tools\avisynth_plugin\yadif.dll")Video=Yadif(Video,order=1)"

yadif(mode=3).srestore(frate=23.976)


crop( 4, 0, -12, 0)

Tweak(sat=1.3)

SoftSharpen(preset="anim", width=640,height=480, gain=3, sharp=30, denois=40, denoisT=10.3)


Mais une erreur est tjrs presente
godai61
 
Messages: 53
Inscription: 29 Nov 2011

Messagepar godai61 » Ven 16 Déc, 2011 16:41

message d 'erreur :

parse error: string missing closing quotation mark
(( null),line 17,column 24 )
godai61
 
Messages: 53
Inscription: 29 Nov 2011

Messagepar godai61 » Ven 16 Déc, 2011 16:44

Par contre :lorsque je supprime

Load_Stdcall_Plugin("C:\Documents and Settings\GODAI\Bureau\MeGUI_2050_x86\tools\avisynth_plugin\yadif.dll")Video=Yadif(Video,order=1)"


Cela fonctionne

Faut il virer ou garder cet element

Video=Yadif(Video,order=1)"
Dernière édition par godai61 le Ven 16 Déc, 2011 16:52, édité 1 fois.
godai61
 
Messages: 53
Inscription: 29 Nov 2011

Messagepar Subbat » Ven 16 Déc, 2011 16:46

Sur ta ligne faisant appel à la dll, tu as laissé Video=Yadif(video,order=1)" le " ne serait-il pas en trop...

Et ce Video=Yadif(video,order=1), s'il doit apparaitre, ne serait-il pas à placer après le yadif(mode=3).srestore(frate=23.976)?

Tout cela en sachant que je n'y connais que dalle en script... donc à prendre comme une simple hypothèse...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Subbat » Ven 16 Déc, 2011 16:48

Oups, trop long à répondre la godasse...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar godai61 » Ven 16 Déc, 2011 16:51

bah avec Video=Yadif(Video,order=1)" ca passe pas et en le retirant ca passe donc je ne sais pas si il doit etre la en fait

J essai juste après en plaçant comme tu dis : Video=Yadif(video,order=1)" apres le srestore

mais bizarre aussi qu 'il n 'y ai qu 1 seul " a la fin
godai61
 
Messages: 53
Inscription: 29 Nov 2011

Messagepar leon1789 » Ven 16 Déc, 2011 16:59

godai61 a écrit:mais bizarre aussi qu 'il n 'y ai qu 1 seul " a la fin

oui, comme c'est bizarre ! :glups: et si tu l'enlèves ??

pour yadif , n'oublie pas le paramètre mode !
et mets le srestore après ...
Dernière édition par leon1789 le Ven 16 Déc, 2011 17:00, édité 1 fois.
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar godai61 » Ven 16 Déc, 2011 16:59

Et en fait, ca fonctionne avec ce scrypt, j'ai remis l element a sa place et j ai rajoute un guillemet

LoadPlugin("C:\Documents and Settings\GODAI\Bureau\MeGUI_2050_x86\tools\dgindex\DGDecode.dll")

DGDecode_mpeg2source("D:\vob 18-19-20 ripp\mi17\petit essai\petit essai.d2v", info=3)


LoadPlugin("C:\Documents and Settings\GODAI\Bureau\MeGUI_2050_x86\tools\avisynth_plugin\TIVTC.dll")


Load_Stdcall_Plugin("C:\Documents and Settings\GODAI\Bureau\MeGUI_2050_x86\tools\yadif\yadif.dll")"Video=Yadif(video,order=1)"

yadif(mode=3).srestore(frate=23.976)


crop( 4, 0, -12, 0)

Tweak(sat=1.3)

SoftSharpen(preset="anim", width=640,height=480, gain=3, sharp=30, denois=40, denoisT=10.3)
godai61
 
Messages: 53
Inscription: 29 Nov 2011

Messagepar leon1789 » Ven 16 Déc, 2011 17:01

godai61 a écrit:Et en fait, ca fonctionne avec ce scrypt, j'ai remis l element a sa place et j ai rajoute un guillemet

LoadPlugin("C:\Documents and Settings\GODAI\Bureau\MeGUI_2050_x86\tools\dgindex\DGDecode.dll")

DGDecode_mpeg2source("D:\vob 18-19-20 ripp\mi17\petit essai\petit essai.d2v", info=3)


LoadPlugin("C:\Documents and Settings\GODAI\Bureau\MeGUI_2050_x86\tools\avisynth_plugin\TIVTC.dll")


Load_Stdcall_Plugin("C:\Documents and Settings\GODAI\Bureau\MeGUI_2050_x86\tools\yadif\yadif.dll")"Video=Yadif(video,order=1)" c'est quoi ça ???

yadif(mode=3).srestore(frate=23.976)


crop( 4, 0, -12, 0)

Tweak(sat=1.3)

SoftSharpen(preset="anim", width=640,height=480, gain=3, sharp=30, denois=40, denoisT=10.3)
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar godai61 » Ven 16 Déc, 2011 17:05

oui il apparait la

Load_Stdcall_Plugin("C:\Documents and Settings\GODAI\Bureau\MeGUI_2050_x86\tools\yadif\yadif.dll")"Video=Yadif(video,order=1)"

yadif(mode=3).srestore(frate=23.976)
godai61
 
Messages: 53
Inscription: 29 Nov 2011

Messagepar godai61 » Ven 16 Déc, 2011 17:07

Subbat a écrit:
godai61 a écrit:Pour yadif, c est bizarre car je l ai bien installe mais j'ai le message d erreur suivant :

Avysynth script error:
there is no function named yadif


Sans doute à cause de ça :

Load_Stdcall_Plugin("<Le>\yadif.dll")
Video=Yadif(Video,order=1)"


A la place de ce qui est en rouge, c'est le chemin menant à \yadif.dll qu'il faut mettre...


ca vient de là


:whi:
godai61
 
Messages: 53
Inscription: 29 Nov 2011

Messagepar godai61 » Ven 16 Déc, 2011 17:10

par contre avec yadif la qualite est superbe, il y aune vrai difference.
godai61
 
Messages: 53
Inscription: 29 Nov 2011

Messagepar Subbat » Ven 16 Déc, 2011 17:14

Je vais peut-être dire une con****, mais aurais-tu vu ce "Video=Yadif(video,order=1)" sur le forum de m4ng dans un post quelconque, ou dans un script issue de m4ng ?

Parce que si c'est le cas, peut-être est-ce lié à m4ng cette ligne...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar godai61 » Ven 16 Déc, 2011 17:16

Non je l ai copie sur ton dernier post en page 3 lol

il faut que je le supprime ? ( le script fonctionne avec et sans)
godai61
 
Messages: 53
Inscription: 29 Nov 2011

Messagepar Subbat » Ven 16 Déc, 2011 17:25

godai61 a écrit:Non je l ai copie sur ton dernier post en page 3 lol

il faut que je le supprime ? ( le script fonctionne avec et sans)


Euh... sauf que le script que j'ai mi page 3 n'était qu'un copié collé de celui que tu avais posté pour lequel tu disais qu'il y avait une erreur...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Subbat » Ven 16 Déc, 2011 17:27

Ah... et sinon...

Le 4 décembre...
Subbat a écrit:Hello,

Pour le désentrelacement, j'utilise pour ma part Yadif, et non TDeint...

Ce que je vais dire pour mon exemple n'est sans doute pas valable pour tout... mais sur un Anim japonnais, j'ai obtenu de meilleure résultat avec yadif qu'avec Tdeint (option anime)... avec Tdeint, j'avais un espèces de scintillement sur les "lignes droites" présente dans l'animé... que je n'ai pas retrouvé avec yadif...

En revanche, je ne sais pas comment il marche... vu que j'utilise m4ng, et que je ne fais que coché la case désentrelacement classique...



Le 16 décembre...
godai61 a écrit:par contre avec yadif la qualite est superbe, il y aune vrai difference.


:whi: On a perdu 12 jours.... :yeap: :vc: :did:
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Subbat » Ven 16 Déc, 2011 17:28

godai61 a écrit:Non je l ai copie sur ton dernier post en page 3 lol

il faut que je le supprime ? ( le script fonctionne avec et sans)


Vu l'étonnement de leon, je dirais que tu peux le supprimer...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar godai61 » Ven 16 Déc, 2011 17:34

oki

le mode 3 est il le max pour yadif.

Lol bah un script est fait pour être perfectionné !!
godai61
 
Messages: 53
Inscription: 29 Nov 2011

Messagepar godai61 » Ven 16 Déc, 2011 17:44

il me reste juste peut etre a essayer d utiliser le lfs mode pour essayer d obtenir un peu plus de nettete.

Import("C:\Program Files\AviSynth 2.5\plugins\LSFmod.v1.9.avsi")
LSFmod(defaults="slow", strength=200)
godai61
 
Messages: 53
Inscription: 29 Nov 2011

PrécédenteSuivante

Retourner vers Scripts Avisynth

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités