Encodage x265

Tout ce qui concerne le nouveau format x265 / H265 / HEVC se passe ici ;)

Messagepar Subbat » Ven 24 Jan, 2014 14:38

pepsilite a écrit:Ah, il y a une nouvelle version?

Il y a des versions quasi tous les jours pepsi...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8416
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar pepsilite » Ven 24 Jan, 2014 14:49

Ok subbat ...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22997
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Subbat » Ven 24 Jan, 2014 15:19

Tsssss
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8416
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Subbat » Sam 22 Mar, 2014 15:58

J'ai testé des versions plus récentes du x265... je suis passé (en 64bits) d'environ 7 à 10fps en encodage... par contre, ils ont changé des commandes... Enfin au moins une qui pose problème pour m4ng...

--frames all devient --frames 0

Pour se procurer les versions plus récentes : http://builds.x265.eu/


Ils n'ont toujours pas intégré le mode 2 passes... et ils conseillent, pour faire une comparaison entre le x264 et le x265 d'utiliser le mode bitrate et non le mode crf ou qp... et il semblerait ainsi que le x265 soit maintenant meilleur que le x264... il faudra que je teste ça...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8416
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar pepsilite » Sam 22 Mar, 2014 17:27

Pourquoi changer le --frames all en --frames 0, si ce n'est pour emm*** les développeurs... C'est la 2ème fois que cette commande change, et l'autre fois c'était justement dans l'autre sens.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22997
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Subbat » Sam 22 Mar, 2014 17:49

:ange:
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8416
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Subbat » Sam 22 Mar, 2014 17:54

J'ai testé une vidéo (un clip de stromae) en 1280x720 à 650 kbps preset medium et tout par défaut pour le x264 et le x265, et effectivement le x265 s'en sort nettement mieux...

Pour ceux que ça intéresse:

http://lauden.fr/Subbat/test/x264_650kbps.mkv

http://lauden.fr/Subbat/test/x265_650kbps.mp4
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8416
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar pepsilite » Sam 22 Mar, 2014 17:55

Celle du x265 est dite "corrompue"
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22997
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Subbat » Sam 22 Mar, 2014 18:11

Fait un clic droit sur le lien puis enregistrer la cible du lien...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8416
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar pepsilite » Sam 22 Mar, 2014 19:24

C'est clair qu'il n'y a pas photo à l'arrivée, le x265 s'en sort parfaitement comparé au x264 relativement baveux et pixelisé.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22997
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Subbat » Sam 22 Mar, 2014 19:52

Voui...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8416
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar darknior » Ven 15 Aoû, 2014 0:31

Salut à tous :)

Bon alors je n'ai jamais fait de x265, tjs du x264 et en lisant vos commentaires je me suis dit pkoi pas :)
La qualité etant meilleure ce ne peux être que du bonus, sauf si ça ne passe pas sur mon Rspberry avec XBMC, c'est ce que je veux teser.
Je me demande si matériellement il va suivre ...

Du coup chez moicomme chez vous, je suis en Windows 8.1 et ça plante qd je lance la compression.

- En mode normal j'ai le message avs4x265.exe a cessé de fonctionner :(
- En mode Autonome, dans le log il me marque video No, son No :(

Pourtant comme écrit plus haut j'ai dl la dernière version de x264 : Built 2014-08-14
Et je l'ai copié à la place de celle de M4NG
Ensuite j'ai aussi désactivé le Smartscreen de Windows.

A votre avis, qui puis je faire de plus ?
Merci
Avatar de l’utilisateur
darknior
 
Messages: 268
Inscription: 01 Oct 2009

Messagepar Ducke » Ven 15 Aoû, 2014 8:37

le problème a été résolu normalement :yeap: tu as bien la dernière version de m4ng?
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8548
Inscription: 08 Fév 2007

Messagepar darknior » Ven 15 Aoû, 2014 11:48

Oui bien sur, j'ai mm une version beta de Pepsilite où il m'a réglé un bug pour l'encodage xbox 1

Et tout marche parfaitement en mode autonome en H264
C'est le H265 qui fume :(
Avatar de l’utilisateur
darknior
 
Messages: 268
Inscription: 01 Oct 2009

Messagepar darknior » Ven 15 Aoû, 2014 11:49

J'ai pas pris la V5 pour tester la beta par contre ... sais pas trop si c'est une bonne idée ? :p
Puis mon fix -ci pour la Xbox ne doit pas y être ...
Avatar de l’utilisateur
darknior
 
Messages: 268
Inscription: 01 Oct 2009

Messagepar Subbat » Ven 15 Aoû, 2014 12:22

Salut,

1. le x265 est encore plus ou moins expérimental...
2. Il faut télécharger les versions 32bits et 64bits du x265 et les mettre à la place de celles qui sont dans le dossier "C:\Program Files (x86)\m4ng_v5\system\x265_cli"

Par contre, je ne sais plus si les dernières versions du x265 sont compatible avec la v4 de m4ng... mais elles le sont avec la v5...

Et il n'y a aucune raison que ton fix xbox ne soit pas dans la v5... dès lors que pepsi débogue quelque chose, généralement il l'intègre pour toutes les maj ou version suivantes...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8416
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Subbat » Sam 03 Oct, 2015 13:22

@pepsi : tu as une erreur particuliere avec le avs4x265 ? Il est a jour lui ?
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8416
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar pepsilite » Sam 03 Oct, 2015 14:53

Oui, je l'ai mis à jour avec la dernière version.
Je n'ai pas de message d'erreur sauf que windows me dit qu'il a planté et qu'il cherche une solution ... La routine.
MAIS comme ça marche très bien en mode autonome, no soucy en fait.
Pour mémoire, je ne m'en souvenais plus mais ffmpeg "pipe" x265.exe pour l'encodage x265 en autonome, le son est aussi fait à part, en fait ffmpeg ne fait que remplacer avs4x265.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22997
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Subbat » Mar 13 Oct, 2015 12:17

En fait il semblerait que avs4x265 ait été remplacé par avs4x26x... J'ai fait quelques tests et il en ressort :
1. Il faut virer de la ligne de commande du x265 la commande --frames 0 sinon ça ne fonctionne pas
2. A la place de x265-binary il faut mettre x26x-binary et il faut écrire le chemin en dur et non relatif comme c'est le cas aujourd'hui (à moins qu'il ne faille juste virer le premier "\" j'ai pas essayer ça...)

Sinon donc ça fonctionne...

La chose se trouve ici : http://forum.doom9.org/showthread.php?t=162656

PS : Ah bah en fait il semble même, si je comprends bien, qu'il est même inutile de mettre le input-res et le fps dans la ligne de commande des lors qu'ils sont déjà définis dans l'avs...

Je teste ça pour voir...

[edit] Bon bah j'ai pas le temps là, mais j'arrive pas vraiment à tester, j'ai des avs4x26x a cesser de fonctionner 2 fois sur 3, donc je sais plus trop du coup...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8416
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar pepsilite » Mar 13 Oct, 2015 12:46

D'après mes propres tests, avs4x265 fonctionne sur la plupart des vidéos et plante sur certaines ... pratique tout ça, heureusement qu'il y a le mode autonome
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22997
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Précédente

Retourner vers x265 / H265 / HEVC : réflexions et problèmes

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités