Encodage x265

Tout ce qui concerne le nouveau format x265 / H265 / HEVC se passe ici ;)

Encodage x265

Messagepar Ducke » Dim 15 Déc, 2013 20:25

Bonsoir,

Je me demandais si il fallait quelque chose de spéciale d'installer sur le pc pour encoder en x265? D'après ce que j'ai lu non, m4ng embarque tout mais sait-on jamais j'ai peut-être loupé quelque chose.

Je n'arrive pas à encoder dans ce format, soit j'ai un fichier de 0ko soit un message d'erreur x265.exe a cesser de fonctionner.
Voici le x265_debug.bat je ne sais pas si ça peut servir

Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8549
Inscription: 08 Fév 2007

Messagepar pepsilite » Dim 15 Déc, 2013 23:50

Il n'y a rien besoin de spécial, sauf ce qu'il faut pour décoder la vidéo source ... Tu as une image dans la prévisualisation de m4ng?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23001
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Ducke » Lun 16 Déc, 2013 7:23

Oui oui bien sur j'ai de l'image dans la previsualisation, j'encode quasiment tous les jours en x264, il n'y a que le x265 qui ne veux pas.
j'ai aussi le demux qui ne se fait plus lors d'un encodage depuis que j'ai mis a jour mkvtoolnix et m4ng, mais ça je verrais plus tard.
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8549
Inscription: 08 Fév 2007

Messagepar pepsilite » Lun 16 Déc, 2013 12:33

pour le demux, il y a fort à partir que les commandes aient encore une fois changé.
Pour le x265, ça le fait avec n'importe quelle source?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23001
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Subbat » Lun 16 Déc, 2013 13:30

Suis plus très sur, mais il me semble avoir lu sur doom9 ou sur videohelp que certaines versions du x265 plantaient chez certains... Il me semble que celle de m4ng n'était pas concernée mais au cas où : https://x265.cc/builds/MSYS-x86/8bpp/x265_latest.zip

A mettre à la place du x265.exe actuel dans le dossier system de m4ng...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8417
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Ducke » Lun 16 Déc, 2013 17:50

J'ai essayé sur 3 ou 4 fichiers différents et c'est pareil.
J'ai aussi remplacé le x265.exe, idem par contre cette fois ci les fenêtres ne se fermes plus automatiquement


Dernière édition par Ducke le Lun 16 Déc, 2013 20:39, édité 1 fois.
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8549
Inscription: 08 Fév 2007

Messagepar pepsilite » Lun 16 Déc, 2013 17:54

"Output error" ton disque dur n'est pas plein?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23001
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Ducke » Lun 16 Déc, 2013 18:02

860Go de libre c'est pas suffisant?
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8549
Inscription: 08 Fév 2007

Messagepar pepsilite » Lun 16 Déc, 2013 18:04

ça devrait... tous tes fichiers de tests sont en HD? En mode QP (débit entre 0 et 51) ça donne quoi?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23001
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Ducke » Lun 16 Déc, 2013 18:08

oui ce sont des fichiers en hd, que ça soit en mode QP ou que je choisisse le débit ça coince pareil.
J'ai même récupérer une vidéo que tu as posté de batman en x265 et je n'arrive pas à la ré-encoder non plus


EDIT : j'ai désactivé l'UAC dans la bdr, je re-télécharge m4ng pour voir
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8549
Inscription: 08 Fév 2007

Messagepar pepsilite » Lun 16 Déc, 2013 18:12

Pourquoi re-télécharger m4ng?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23001
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Ducke » Lun 16 Déc, 2013 18:13

pour pouvoir le réinstaller que windows lui donne les droits

EDIT : toute façon c'est pareil ...
Dernière édition par Ducke le Lun 16 Déc, 2013 18:15, édité 1 fois.
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8549
Inscription: 08 Fév 2007

Messagepar pepsilite » Lun 16 Déc, 2013 18:15

Si c'était un problème de droits, ton encodage ne commencerait même pas, là il plante au bout d'un certain temps.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23001
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Ducke » Lun 16 Déc, 2013 18:16

oui c'est vrai
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8549
Inscription: 08 Fév 2007

Messagepar pepsilite » Lun 16 Déc, 2013 18:17

et en mode autonome?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23001
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Ducke » Lun 16 Déc, 2013 18:20

non ça ne veux pas non plus :hop:

un marabout peut-être?
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8549
Inscription: 08 Fév 2007

Messagepar pepsilite » Lun 16 Déc, 2013 18:21

j'aime beaucoup le "sorcier mondialement connu dans le quartier"...
Et ben pas de x265 pour toi. Tu as essayé dans une VM?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23001
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Ducke » Lun 16 Déc, 2013 18:23

j'ai pas eu le temps, je vais essayer. Tu tournes sur 7 ou 8 que je me mette à armes égale?
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8549
Inscription: 08 Fév 2007

Messagepar pepsilite » Lun 16 Déc, 2013 18:23

ça marche sur le deux chez moi ... mais mon PC de travail est un win 7
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23001
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Subbat » Lun 16 Déc, 2013 20:14

Je ne vois pas pourquoi ça changerait quelque chose... mais au cas où... essaye avec cette version : https://x265.cc/builds/VC12-x86/8bpp/x265_latest.zip

Elle est compilé avec le compilateur microsoft contrairement à celle embarquée dans m4ng... dès fois que certains win8 soient capricieux...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8417
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Ducke » Lun 16 Déc, 2013 20:23

désolé mais c'est pareil. Je viens de finir une installation d'une VM sous seven et l'encodage en x265 fonctionne :hop:
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8549
Inscription: 08 Fév 2007

Messagepar Subbat » Lun 16 Déc, 2013 20:29

Ah... donc c'est win8 qui fait chier... :/
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8417
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Ducke » Lun 16 Déc, 2013 20:31

ou un truc dessus, mais comme le message n'est pas très clair, ça ne vas pas être facile à trouver :hop:
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8549
Inscription: 08 Fév 2007

Messagepar Subbat » Lun 16 Déc, 2013 20:33

Le fait que le dossier de travail de m4ng soit sur D, c'est normal sous 8 ou c'est toi qui a paramétré ça différemment ? Je ne vois pas non plus pourquoi ça changerait quelque chose, mais sait-on jamais...

[edit] ça me semble très con ce que je viens d'écrire en fait...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8417
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Ducke » Lun 16 Déc, 2013 20:36

non ça c'est moi, m4ng et les autres programmes le supportent bien, mais peut-être que le x265 est capricieux...

J'ai édité ce message, j'avais mis 2 fois la même image
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8549
Inscription: 08 Fév 2007

Suivante

Retourner vers x265 / H265 / HEVC : réflexions et problèmes

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités