m4ng ne detecte pas mes codecs

Les questions des débutants ...

Modérateur: Modérateurs

m4ng ne detecte pas mes codecs

Messagepar Guillaume » Mer 02 Sep, 2015 13:55

Bonjour,

J'ai récemment installé m4ng v5, puis avisynth et le pack de codecs. J'avoue que j'étais un peu surpris en affichant ma conf multimedia... c'est un peu comme si je n'avais rien installé :) Je la joins en bas de ce message.

Je précise un peu ce que j'ai fait avec le codec pack. Une fois installé, j'ai déclenché manuellement l'installation de DivX, qui s'est déroulée normalement, qui est bien présent dans mon filesystem... mais qui apparemment n'est pas vu par m4ng.

D'une manière générale, il semble y avoir une solide différence entre ce qui est installé sur mon PC et la connaissance qu'en a m4ng. Y a-t-il autre chose à faire pour spécifier à m4ng les emplacements où se trouvent les codecs, filtres, et autres éléments additionnels ? Genre un bon vieux fichier de conf avec des pathnames :)

D'avance merci,

--
Guillaume



Code: Tout sélectionner
m4ng Video Analyser  [ 5.0.0.473 #39 - [exp 31/12/15] ]

(ChainLess: OFF)

[ Video ]
DivX :        - [ INTROUVABLE ]
Xvid :        - [ INTROUVABLE ]
X264 (cli) :      OK [ x264 0.142.2431 ac76440 ]
X264 (vfw) :     - [ INTROUVABLE ]
X265 (cli) :      OK [ 1.2.0.76 ]
VP6 :        - [ INTROUVABLE ]
VP7 :        - [ INTROUVABLE ]
DivX 3.11 :     - [ INTROUVABLE ]
Quicktime Alternative :  - [ INTROUVABLE ]
Quicktime Lite :     - [ INTROUVABLE ]
CoreAVC :        - [ INTROUVABLE ]
Real Alternative :     - [ INTROUVABLE ]
Real Video 10 :     - [ INTROUVABLE ]
DirectVobSub :     - [ INTROUVABLE ]
VSfilter :       
ffdshow :        - [ INTROUVABLE ]
----------------------------------------------------
[ Audio ]
CORE - AAC Codec :     - [ INTROUVABLE ]
CORE - VORBIS Codec :     - [ INTROUVABLE ]
LAME - MP3 Codec :    OK [ 0.9.1.0 ]
AC3 Filter :       OK [ 1.63b ]
Oggcodecs :    - [ INTROUVABLE ]
OggDs :        - [ INTROUVABLE ]
----------------------------------------------------
[ Miscs ]
Windows :       Windows 8 [Windows 8]
UAC :       User Account Control ON
Temp :       C:\Users\pc-\AppData\Roaming\m4ng\
Matroska Splitter :     - [ INTROUVABLE ]
DGindex :       OK [ 1.5.0.0 ]
m4ng Codec Pack :    OK [ v 2.0 ]
DVDFab Platinum :     - [ INTROUVABLE ]
DVDFab Decrypter :     - [ INTROUVABLE ]
DVDFab HD Decrypter :  - [ INTROUVABLE ]
DVDFab :        - [ INTROUVABLE ]
Web Browser :    C:\program files\Internet Explorer\iexplore.exe
----------------------------------------------------
[ Avisynth ]
AVIsynth.dll    OK [ 2.6.0.6 ]
C:\Program Files (x86)\AviSynth\plugins\*.*
 - colors_rgb.avsi OK
 - DirectShowSource.dll OK
 - TCPDeliver.dll OK
----------------------------------------------------
[ Matroska (MKV) ]
MKVExtractGui by DP : OK [ 1.6.5.300 ]
MKVtoolnix :     - [ INTROUVABLE ]
DEMUX MKV :     - [ INTROUVABLE ]
----------------------------------------------------
Drives :
C:\ D:\ E:\

C: - DRIVE_FIXED
D: - DRIVE_FIXED
E: - DRIVE_CDROM

** END OF FILE - 01808 bytes
Guillaume
 
Messages: 5
Inscription: 02 Sep 2015

Messagepar Guillaume » Jeu 03 Sep, 2015 13:24

Personne n'a jamais rencontré une problème semblable ? Ca m'étonne un peu... :-)

Je cherche surtout à comprendre comment m4ng fait le lien avec ses dépendances externes, s'il y a des considérations de compatibilité de versions qui expliqueraient par exemple que le module DivX, alors que je viens de l'installer en passant précisément par l'interface du codec pack, n'est pas vu par m4ng...

J'avoue que j'ai été surpris de n'avoir trouvé aucune forme de documentation là-dessus (sur tout ce qui est installation / configuration de filtres et autres codecs), hormis le super basique "téléchargez et installez le codec pack", qui ne semble pas être tout à fait suffisant :-)

C'est déjà un super-outil, j'ai pu sous-titrer mes vidéos même sans bénéficier des codecs que j'aurais aimé utiliser... du coup ça donne envie de le faire fonctionner comme il est censé fonctionner :-)

J'espère que quelqu'un pourra m'y aider.
Guillaume
 
Messages: 5
Inscription: 02 Sep 2015

Messagepar Ducke » Jeu 03 Sep, 2015 16:52

Salut,

Désolé il n'y a pas une assistance 24/24, et même si on passe régulièrement sur le fofo tous les problèmes ne nous inspire pas une solution. Et puis tu n'as pas besoin de tous les codecs à mon avis.

Déjà tu veux encoder quoi comme vidéo et en quoi car je vois qu'il te manque mkvtoolnix pour commencer.

Ensuite il y a un message en haut du forum à propos du divx et sincèrement je ne sais pas si c'est encore d'actualité car je n'utilise que le x264 qui est bien meilleur, et si besoin de créer un avi j'utilise le xvid et pour pas m’embêter avec les codecs j'utilise le mode autonome :yeap:
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8485
Inscription: 08 Fév 2007

Messagepar Guillaume » Ven 04 Sep, 2015 7:51

Salut,

Merci pour ta réponse. Je ne voulais pas donner l'impression que j'attendais une assistance h24, désolé.
Ok oublions DivX. Je vais installer le codec Xvid, et voir s'il est reconnu par m4ng. Merci aussi pour le conseil concernant x264 :yeap:

J'avoue que le mode autonome m'a donné pleine satisfaction, c'est plus pour en savoir un peu plus sur le soft que je pose ces questions.

Ah juste un truc : tu dis que si tu veux faire un AVI tu utilises Xvid. L'autre jour j'ai créé un AVI, or je n'ai ni DivX ni Xvid... c'est normal, docteur ? :mad:
Guillaume
 
Messages: 5
Inscription: 02 Sep 2015

Messagepar Guillaume » Ven 04 Sep, 2015 8:04

Bon, je viens d'installer Xvid 1.3.4, et à mon grand regret ça ne fait ni chaud ni froid à m4ng :kes:
Je confesse que j'aimerais mourir moins con et au moins savoir pourquoi :o:
Guillaume
 
Messages: 5
Inscription: 02 Sep 2015

Messagepar Ducke » Ven 04 Sep, 2015 8:39

Salut,

Guillaume a écrit:J'avoue que le mode autonome m'a donné pleine satisfaction, c'est plus pour en savoir un peu plus sur le soft que je pose ces questions.

Ne t'embête pas avec ça si le mode autonome te satisfait, il encode avec ffmpeg qui à permis de résoudre des problèmes insolubles chez certains utilisateurs et évite de télécharger des codecs externes.

Guillaume a écrit:Ah juste un truc : tu dis que si tu veux faire un AVI tu utilises Xvid. L'autre jour j'ai créé un AVI, or je n'ai ni DivX ni Xvid... c'est normal, docteur ? :mad:

Même réponse qu'au dessus :mrgreen: . Si tu utilises le mode autonomes tu n'as pas besoin des codecs, ffmpeg s'en charge.

Guillaume a écrit:Bon, je viens d'installer Xvid 1.3.4, et à mon grand regret ça ne fait ni chaud ni froid à m4ng :kes:
Je confesse que j'aimerais mourir moins con et au moins savoir pourquoi :o:

Je ne suis pas devant ma machine la, mais je tacherais d'installer le codec pour pour voir. Quand tu charges une vidéo dans m4ng et que tu choisis le codec xvid, il est écrit en rouge?

EDIT : apparemment la version 1.3.4 n'est pas reconnu par m4ng, tu peux installer le xvid 1.3.2
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8485
Inscription: 08 Fév 2007

Messagepar Guillaume » Ven 04 Sep, 2015 11:06

Yes, la version de Xvid que tu m'as pointée fonctionne, merci :mrgreen:
Merci pour ta disponibilité, c'est apprécié.
Guillaume
 
Messages: 5
Inscription: 02 Sep 2015

Messagepar Ducke » Ven 04 Sep, 2015 12:58

j'ai fait remonter l'info pour le xvid 1.3.4 et le divx 10
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8485
Inscription: 08 Fév 2007

Messagepar pepsilite » Sam 05 Sep, 2015 21:18

Ouais, je vois, ils ont surement encore tout changé dans la reconnaissance du codec, com dab ...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar pepsilite » Sam 05 Sep, 2015 23:07

Bon, j'ai intégré la reconnaissance du Xvid 1.3.4 et ça marche, par contre le DivX 10 fout (comme toujours) une zone pas possible en installant des kilos de codecs/filtres dans tous les sens et rien ne fonctionne plus correctement coté vidéo après, il est donc officiellement NON compatible avec m4ng !
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Ducke » Dim 06 Sep, 2015 7:23

pepsilite a écrit:... DivX 10 fout (comme toujours) une zone pas possible en installant des kilos de codecs/filtres dans tous les sens et rien ne fonctionne plus correctement coté vidéo après, il est donc officiellement NON compatible avec m4ng !


Ouais j'y ai eu aussi le droit, ça m'a tout déréglé dans la prévisu :hop:
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8485
Inscription: 08 Fév 2007

Messagepar pepsilite » Dim 06 Sep, 2015 13:19

J'ai modifié m4ng en conséquence, l'installation du codec DivX 10 ne sera pas validée et l'encodage se fera via le mode autonome et ffmpeg pour les "amoureux" du DivX à tout prix.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Ducke » Dim 06 Sep, 2015 15:07

pepsilite a écrit:J'ai modifié m4ng en conséquence, l'installation du codec DivX 10 ne sera pas validée et l'encodage se fera via le mode autonome et ffmpeg pour les "amoureux" du DivX à tout prix.


ok c'est le plus sage vu le bordel qu'il met ...
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8485
Inscription: 08 Fév 2007

Messagepar pepsilite » Dim 06 Sep, 2015 15:21

Ben c'est surtout que vu que plus aucune vidéo n'était décodée correctement, je n'ai même pas pu tester l'encodage en DivX vu que la vidéo source elle même n'était pas lisible ... Ils sont de plus en plus doués chez DivX.
Leur leitmotiv est simple, il n'y a qu'eux sur la terre et on écrase tout le monde quand on arrive sur un PC, peu importe les dommages collatéraux .
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar schmurtz » Lun 07 Sep, 2015 7:43

"peu importe les dommages collatéraux",tu dis bon
schmurtz
 
Messages: 2
Inscription: 16 Sep 2015


Retourner vers Premiers pas

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités