Pas d'encodage en V5

Les questions des débutants ...

Modérateur: Modérateurs

Messagepar Koala » Ven 22 Avr, 2016 7:40

En principe, mes vidéos font 45 min environ, donc je mets la taille finale à 350Mo (comme avec la V3)
Le débit et la résolution sont automatiquement gérés par M4ng
C'est ainsi que j'opérais avec la V3 sans problème
Si vous avez des suggestions, je suis preneur.
Koala
 
Messages: 89
Inscription: 08 Mar 2011

Messagepar Subbat » Ven 22 Avr, 2016 9:52

Tu encodes comment déjà ? Mode autonome ou normal ?

Si mode normal, tu peux mettre une copie écran de l'analyse graphstudio (via le (?) de m4ng)
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8280
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Koala » Mar 26 Avr, 2016 13:25

Bon après pas mal de tâtonnements, je converti mes vidéos avec les paramètres suivants:


encodeur interne____mode avancé
Codec: Xvid
Résolution: 1080 x 812
Conteneur; .mp4
Taille finale : 350 Mo ------>Le débit se règle automatiquement

Cela semble assez bien pour mes vidéos.

Comment faire pour avoir toujours les même paramètres, car dès que je ferme M4
ce sont les paramètres par défaut à l'ouverture suivante ?

Par contre si il y a des pubs au milieu des vidéos, je me retrouve à la fin avec 3 fichiers
OUT_vidéo_m4mbo1.mp4
OUT_vidéo_m4mbo2.mp4
OUT_vidéo_m4mbo3.mp4

Comment réunir ces 3 fichiers en 1 seul?

Merci pour votre aide et si vous avez des astuces je suis preneur.
Koala
 
Messages: 89
Inscription: 08 Mar 2011

Messagepar pepsilite » Mar 26 Avr, 2016 14:44

Pour conserver tes réglages, tu as la possibilité de "Créer nouveau profil" en cliquant sur le bouton le plus en bas à gauche, en dessous de la liste des presets intégrés, tu auras ensuite un nouveau preset qui s'ajoutera à la liste et tu n'auras qu'à cliquer dessus pour que tous tes paramètres soit appliqués à chaque fois.
Pour m4mbo, "normalement", le "collage" de différentes parties se fait tout seul, regarde si tu n'as pas aussi un fichier mp4 plus gros dans le coin, si ce n'est pas le cas, tu vas dans les outils de m4ng ( bouton "clef de 12" en haut de l'interface) => "Coller des parties de vidéos (identiques)", tu "ajoutes" chaque partie une par une dans l'ordre que tu veux à la sortie et tu fais [ Coller ], tu auras au final un seul et unique fichier vidéo avec toutes tes parties collées...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Koala » Sam 30 Avr, 2016 17:33

Bon,
j'ai testé votre indication,"Coller des parties de vidéo (identiques)
1° test, aucun résultat, j'ai la fenêtre, "Coller portions de vidéos pour former un film entier" qui s'affiche
Je clique sur ajouter, sélection de: Vidéo_m4mbo 1.mp4;
clique sur ajouter sélection de: Vidéo_m4mbo 2.mp4;
clique sur ajouter sélection de: Vidéo_m4mbo 3.mp4;
Affichage de : Vidéo destination D:\out_Vidéo_m4mbo 1.mp4 (OK)
Clique sur Coller
Affichage d'une fenêtre en arrière plan "M4ng V5 - Log" avec date/ heure Assemblage en cours
Et plus rien bien que j'ai attendu plus d'une heure.

J'ai tester avec une vidéo ayant été convertie la veille, donc M4 arrêter entre temps et une autre fois tout de suite après la fin de la conversion. Pas de collage sur les 2 tests.
Par ailleurs ayant converti cette vidéo plusieurs fois, je constate des différence de temps de conversion variant de 4 à 12 heures, j'ai testé d'autres vidéo avec les même résultats.

Une petite idée ? merci de vos réponses
Koala
 
Messages: 89
Inscription: 08 Mar 2011

Messagepar pepsilite » Sam 30 Avr, 2016 18:42

Là j'avoue que je perds pied, rien ne semble fonctionner à aucun niveau chez toi, franchement, à part un exorciste, je ne vois plus trop là ............
Si tu sais utiliser MMG des MKVtoolnix, utilise le pour coller les parties directement au lieu de passer par le module automatique de m4ng.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Koala » Mar 03 Mai, 2016 18:11

Je viens saluer votre travail, car hier j'ai installé la dernière mouture de votre programme et Oh miracle tout fonctionne (très) bien.
Mes documents sont bien convertis son et images (plus belles qu'avant) et lorsque j'ai du utiliser mambo, je peux coller les morceaux à la fin.
Seul petit bémol, la durée de la conversion un peu plus rapide qu'avant mais comptons sur 5 à 6 heures pour 1 heure 30 de vidéo.
Un grand merci à vous.
Tout vient à qui sait attendre.
Koala
 
Messages: 89
Inscription: 08 Mar 2011

Messagepar pepsilite » Mar 03 Mai, 2016 20:14

Content pour toi
Quand tu dis que tu peux coller les morceaux à la fin, tu veux dire que tu dois le faire à la main ou c'est automatique?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Koala » Mer 04 Mai, 2016 7:14

Je dois le faire à la main.
Oui en principe cela devrait se faire automatiquement mais bon
peut être qu'un jour cela se fera ainsi, je suis patient.
Un grand pas a été franchi.
Koala
 
Messages: 89
Inscription: 08 Mar 2011

Messagepar pepsilite » Mer 04 Mai, 2016 11:41

Mouais, il y a du mieux mais c'est pas très logique tout ça...
Maintenant que la grosse mise à jour a été publiée, je vais pouvoir faire des corrections et des versions de tests pour comprendre pourquoi ça ne marche pas chez toi.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Koala » Mer 04 Mai, 2016 13:01

Merci de votre soutien
Koala
 
Messages: 89
Inscription: 08 Mar 2011

Messagepar pepsilite » Mer 04 Mai, 2016 14:15

Bon, j'ai trouvé le problème du mux qui ne se fait pas automatiquement en mode autonome (encodeur interne), je corrige, je teste et je publie un correctif dès que tout est ok ;)
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar pepsilite » Mer 04 Mai, 2016 14:43

Hop, sitôt dit ...
Voilà le correctif :
m4ng 5.0.2.0 #16
C'est juste l'exécutable de m4ng à remplacer dans le dossier d'installation.

m4ng v5.0.2.0000 - #16
----------------------

- Correction de plusieurs bugs d'encodage audio en FLAC. A noter que l'encodage FLAC (in ou out) n'est possible qu'en mode autonome.

- Correction d'un bug de collage des parties de m4mbo en mode autonome.


ATTENTION, là encore ce correctif ne peut fonctionner qu'après avoir installé le nouveau setup #14 (dispo sur le site)
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Koala » Ven 06 Mai, 2016 10:03

Merci à vous, ma dernière vidéo s'est encodée automatiquement.
Génial
Reste juste un petit bug depuis la mise à jour du 2 mai,
les vidéo ne font pas la taille finale que je demande, mais reste pratiquement au volume de départ.
Exemple 1 vidéo .ts de 2,5 Go, une fois terminée fait toujours plus de 2 Go en .mp4, alors que j'ai demandé 800 Mo, comme si ce paramètre était oublié dans la conversion
Koala
 
Messages: 89
Inscription: 08 Mar 2011

Messagepar pepsilite » Ven 06 Mai, 2016 12:59

Content pour toi
Pour le "bug" absolument RIEN n'a été modifié de ce coté là depuis des lustres.
Est-ce que le débit vidéo final de ta vidéo correspond bien à celui demandé dans m4ng?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Koala » Sam 07 Mai, 2016 7:41

Non le débit vidéo, ne correspond pas à mes paramètres

Test sur une vidéo:
Ouverture de M4, choix de la vidéo,analyse dans la fenêtre de gauche;
Taille 2.800 GiB Extension TS
Codec AVC
Débit: 4514 kbps (01h 19 mn 51s)
Nombre d'images 119785
Fréquence image 25.000
Résolution 1440 x 1080 - [16/9]

Passage par m4mbo pour suppression des excédents Vidéo
OK

Mes paramètres pour la conversion:

Codec : Xvid
Résolution: 1080 x 608
Conteneur: MP4
Taille finale: 299 Mo (taille demandée 300 Mo)
Débit (automatique) 396
Convertir
OK

Vidéo après conversion, analyse dans la fenêtre de gauche:

Taille : 2.820 GiB Extension MP4
Codec : MPEG-4 Visual
Débit : 7.666 (c'est ici que le "bât blesse" alors qu'il était de 396"imposé par M4" quand j'ai donné la taille finale de la vidéo
Nombre d'images : 77.659
Fréquence image : 25.000
Résolution :1080 x 608 - [16/9]

Voilà, donc cette vidéo est sortie grandie de cette expérience
Cela ne se produisait pas avec la première installation de la V5
Koala
 
Messages: 89
Inscription: 08 Mar 2011

Messagepar pepsilite » Sam 07 Mai, 2016 15:04

Je crois me rappeler que c'est un des gros défaut du xvid qui n'arrive pas parfois à respecter le débit demandé, 2 choses :
1. Ne peux-tu réencoder en x264 à la place? Lui au moins il est fiable de ce coté là.
2. Demander un débit de 396 pour une résolution de 1080x608, si le débit était respecté, tu te retrouverais avec une bouillie de pixels pas possible en Xvid, il te faut au moins du 1000, voire 1500 (ou plutôt un indice de qualité aux alentours de 0.10)
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Koala » Ven 20 Mai, 2016 16:24

Après pas mal de tests et d'essais je me retrouve avec différents problèmes et parfois avec la même vidéo, la conversion est bizarre, par exemple, une taille vidéo demandée de 800 Mo se retrouve avec seulement 150 Mo.

Mais je crois avoir un problème plus important pour l'instant.
J'enregistre avec un tuner Hauppauge Win TV-Nova_TD_Stick double tuner qui fonctionne très bien en TV direct, image et son très bons, mais les fichiers générés .ts, sont souvent refusés par MPC-HC, c'est à dire:
je démarre M4, je sélectionne la vidéo,reconnaissance par M4, je passe sur m4mbo pour supprimer les excédents, je lis la vidéo pour placer les marqueurs et très souvent MPC-HC se bloque, m'obligeant à passer par le gestionnaire des tâches pour débloquer le PC.

Je vous joint les paramètres du tuner Hauppauge, pour voir si il y a des améliorations à apporter:

Rendu Vidéo; overlay - VMR7 - VMR9 - EVR (EVR activé)
Convertir les enregistrements MPEG-2.ts en MPEG (pas sélectionné)

Décodeurs; Activer décodeurs tiers (incompatibilité possible) (non sélectionné)

possibilités si j'active les décodeurs ::

Vidéo MPEG2---->MainConcept (HCW) MPEG-2 vidéo
Microsoft DTV-DVD vidéo décodeur
Disabled

Vidéo H 264------>ArcSoft Vidéo Décodeur
Disabled

HEVC Vidéo------->Disabled
Disabled

Audio MPEG-1------>Hauppauge MPEG Layer1/2 Audio
MPEG Audio Décodeur
Microsoft DTV-DVD audio décodeur
Disabled

Audio AC3----------->Hauppauge AC3 décodeur
Microsoft DTV-DVD audio décodeur
Disabled

Audio HE-AAC------->Disabled
Disabled

Audio DD+/EAC3----->Hauppauge EAC3 décodeur
Disabled


Je vous remercie par avance de votre aide
Koala
 
Messages: 89
Inscription: 08 Mar 2011

Messagepar pepsilite » Ven 20 Mai, 2016 21:09

pepsilite a écrit:Je crois me rappeler que c'est un des gros défaut du xvid qui n'arrive pas parfois à respecter le débit demandé, 2 choses :
1. Ne peux-tu réencoder en x264 à la place? Lui au moins il est fiable de ce coté là.
2. Demander un débit de 396 pour une résolution de 1080x608, si le débit était respecté, tu te retrouverais avec une bouillie de pixels pas possible en Xvid, il te faut au moins du 1000, voire 1500 (ou plutôt un indice de qualité aux alentours de 0.10)
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Koala » Sam 21 Mai, 2016 7:51

J'ai modifié comme vous m'aviez conseillé les paramètres de conversion.

X264, débit maximum suivant la taille de la vidéo, conteneur mp4, pour cela plus de problème quand la vidéo est acceptée par MPC-HC, si ce n'est la lenteur de la conversion.

Je cherche à savoir pourquoi MPC-HC se bloque pendant la lecture de certaines vidéo avec m4mbo.

Je pensais qu'il pouvait y avoir un problème au niveau des enregistrements, c'est pour cela que je vous demande conseille au niveau des paramètres du Stick Hauppauge.
Koala
 
Messages: 89
Inscription: 08 Mar 2011

Messagepar Subbat » Dim 22 Mai, 2016 19:31

Salut,

Nous ne sommes pas vraiment expert en enregistreur TV sur PC... Mais normalement MPC-HC se débrouille plutôt très bien à la lecture de n'importe quel type de flux...

Ton enregistreur enregistre les flux bruts ou il fait déjà une conversion à l'enregistrement ? Parce que s'il enregistre les flux bruts, peu importe la configuration du décodage... MPC-HC s'en moque lui, il a ses propres décodeurs...

Moi j'avais une clé TNT avermedia et je ne me servais pas du logiciel vendu avec mais de pouchinTV... Je ne sais pas s'il existe toujours ce logiciel, mais il était très bien... il capturait les flux direct...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8280
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar pepsilite » Dim 22 Mai, 2016 20:00

Là où MPC arrive à planter c'est quand on redémarre la lecture trop fréquemment pendant les opérations, seul Underground78 qui fait partie de l'équipe de développement de MPC pourrait éventuellement nous apporter ses lumières.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Koala » Lun 23 Mai, 2016 10:05

Bon, ça s'aggrave un peu.

Lecture d'un enregistrement en direct avec MPC, image et son OK

Mise en route M4.
Sélection vidéo vue précédemment.
Paramètrage de M4:
Codec = X264
Encodage = 2 passes
Qualité vidéo = Haute qualité
Débit = 1500
Indice de qualité =0,09 (automatique)
Audio 1 Codec = mp3 Débit = 128
Conteneur MP4
Taille finale = 1746
Fichier final = I\OUT_vidéo

ensuite Prévisualisation avec m4mbo, marquage des zones à supprimer OK/Fermer

Lancement conversion

6 heures plus tard, le fichier final fait 604 152 k et il n'y a pas de vidéo, mais le son est bon.

J'ai fait le test avec 3 vidéos différentes et en modifiant les paramètres de M4, plus de débit, taille finale plus grande et toujours un fichier final plus petit que la taille demandée et pas de vidéo.
J'ai donc désinstallé M4 et formaté le disque pour avoir une installation propre et toujours le même problème.

Je vais testé "pouchin TV" si je trouve.

Merci pour votre aide.
Koala
 
Messages: 89
Inscription: 08 Mar 2011

Messagepar Koala » Lun 23 Mai, 2016 17:33

Apparemment cela ne se produit que sur des vidéo comportant de la publicité au moins 3 fois. Sur des vidéos de 45 min avec suppression au début et à la fin, pas de problème.
Serait-ce m4mbo qui me jouerait un petit tour ?.

Hauppauge a éffectué une mise à jour qui semble améliorer l'enregistrement.

Je creuse de ce côté.
Koala
 
Messages: 89
Inscription: 08 Mar 2011

Messagepar pepsilite » Lun 23 Mai, 2016 20:23

Déjà 6h, c'est énorme comme durée d'encodage, ensuite si le fichier final fait 604 mo, c'est qu'il doit y avoir de la vidéo, un fichier audio seul ne peut faire cette taille à moins que la vidéo dure 5 ou 6h. Qu'est-ce qui te faire dire qu'il n'y a pas de vidéo? A la lecture? A l'analyse vidéo?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

PrécédenteSuivante

Retourner vers Premiers pas

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités