[Résolu] Pb pour extraire les sous-titres d'un fichier MKV

Pb pour extraire les sous-titres d'un fichier MKV

Messagepar guy » Mer 10 Sep, 2014 9:56

Bonjour à tous,

Comme le dit le sujet il s'agit d'extraire simplement les sous-titres à partir d'un fichier MKV.
J'ai longtemps remis à plus tard ce topic pensant que je faisais une erreur de débutant mais toutes mes tentatives ce sont soldées par le même résultat : un fichier .SRT de plusieurs Go aprés avoir démuxé.
Comment je pratique? comme le préconisait Subbat dans ce topic:

http://www.forum.m4ng.fr/incruste-les-s ... =soustitre

J'ai procédé à plusieurs essais sur des MKV différents mais toujours les mêmes résultats.
J'ai bien les outils de MKVToolnix et je suis sous Win7 64x

Ci-après ma config multimédia:

4ng Video Analyser [ 4.0.2200.434 - [exp 31/12/14] ]

(ChainLess: OFF)

[ Video ]
DivX : - [ INTROUVABLE ]
Xvid : OK [ Xvid 1.2.2 final ]
X264 (cli) : OK [ x264 0.129.2230 1cffe9f ]
X264 (vfw) : OK
VP6 : - [ INTROUVABLE ]
VP7 : - [ INTROUVABLE ]
DivX 3.11 : - [ INTROUVABLE ]
Quicktime Alternative : - [ INTROUVABLE ]
Quicktime Lite : - [ INTROUVABLE ]
CoreAVC : - [ INTROUVABLE ]
Real Alternative : - [ INTROUVABLE ]
Real Video 10 : - [ INTROUVABLE ]
DirectVobSub : - [ INTROUVABLE ]
VSfilter :
ffdshow : OK [ ffdshow v1.1.3611 [2010-10-06] ]
----------------------------------------------------
[ Audio ]
CORE - AAC Codec : OK [ 1.2.0.575 ]
CORE - VORBIS Codec : - [ INTROUVABLE ]
LAME - MP3 Codec : OK [ 0.9.1.0 ]
AC3 Filter : - [ INTROUVABLE ]
Oggcodecs : - [ INTROUVABLE ]
OggDs : - [ INTROUVABLE ]
----------------------------------------------------
[ Miscs ]
Windows : Windows 7 Home Premium [Windows 7 Home Premium]
UAC : User Account Control OFF
Temp : C:\Users\guy\AppData\Roaming\m4ng\
Matroska Splitter : OK [ 1.10.262.12 ]
DGindex : OK [ 1.5.0.0 ]
m4ng Codec Pack : OK [ v 2.0 ]
DVDFab Platinum : - [ INTROUVABLE ]
DVDFab Decrypter : - [ INTROUVABLE ]
DVDFab HD Decrypter : - [ INTROUVABLE ]
DVDFab : - [ INTROUVABLE ]
Web Browser : C:\Program Files (x86)\Google\Chrome\Application\chrome.exe
----------------------------------------------------
[ Avisynth ]
AVIsynth.dll OK [ 2.6.0.2 ]
C:\Program Files (x86)\AviSynth 2.5\plugins\*.*
- colors_rgb.avsi OK
- DirectShowSource.dll OK
- TCPDeliver.dll OK
----------------------------------------------------
[ Matroska (MKV) ]
MKVExtractGui by DP : OK [ 1.6.5.300 ]
MKVtoolnix : OK [ v4.4.0.0 ]
MUX MKV : C:\Program Files (x86)\MKVtoolnix\mkvmerge.exeOK
MKVINFOS : C:\Program Files (x86)\MKVtoolnix\mkvinfo.exeOK
DEMUX MKV : C:\Program Files (x86)\MKVtoolnix\mkvextract.exeOK
----------------------------------------------------
Drives :
C:\ D:\ E:\ F:\

C: - DRIVE_FIXED
D: - DRIVE_CDROM
E: - DRIVE_FIXED
F: - DRIVE_FIXED

** END OF FILE - 01983 bytes

Merci pour votre aide et vos conseils
@+
guy
 
Messages: 23
Inscription: 21 Nov 2013
Localisation: gironde

Messagepar Subbat » Mer 10 Sep, 2014 14:31

Salut,

je pense que c'est ta version des mkvtoolnix qui est obsolète... entre la tienne et les plus récentes, il y a eu un changement dans la numérotation des pistes... ce qui fait que dans ton cas, je suis persuadé que c'est une piste audio qui est extraite... tu n'as qu'à remplacé le .srt par .mp3 ou .ac3 ou .m4a en fonction du format des pistes audio contenu dans ton mkv... et tu verras que tu auras de l'audio...

Enfin bref, il te faut installer une version plus récente de mkvtoolnix et ton problème devrait être résolu... ;)
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8418
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar guy » Mer 10 Sep, 2014 17:21

Merci de ta réponse Subbat,
Je vais me mettre en quête d'une version plus récente de MKVtoolnix : la mienne est celle dans le pack des codecs de ce site (m4ng) :spo: j'ignorais qu'elle avait évolué
Je te tiens au courant :yeap:
guy
 
Messages: 23
Inscription: 21 Nov 2013
Localisation: gironde

Messagepar Subbat » Mer 10 Sep, 2014 19:18

Ah ouais... j'avais jamais fais attention pour le m4ng codec pack... je croyais en fait que pour les mkvtoolnix, ça pointait vers le site de téléchargement...

Donc la version de m4ng_cp est obsolète :/

Il te suffit d'aller dans les paramètres de m4ng et de cliquer sur télécharger les mkvtoolnix, ça te redirigera directement sur le site officiel de matroska... ;)
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8418
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar pepsilite » Mer 10 Sep, 2014 20:57

On va actualiser le pack de codecs un de ces quatre ...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 23003
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar guy » Mer 10 Sep, 2014 21:10

Merci Subbat mais j'ai trouvé un site avec toutes les versions pour Win 64x ou 32x, pour portable, Mac etc....
c'est la version 7.1.0 ici:

http://www.fosshub.com/MKVToolNix.html

j'ai supprimé auparavant la version du pack (v 4.4.0) - gros écart tout de même - et installer la ver 7.1.0.
J'ai extrait le fichier .str (72 Ko) de mon MKV, je l'ai visionné avec Wordpad et Bingo!!! Il est conforme aux sous titres que je recherchais!
Là, dessus j'ai réencodé mon film en AVI en incrustant les dits sous titres dans la vidéo cible!
Que dire Super!!:mrgreen:
Je te remercie et je te dis A+ :yeap:
guy
 
Messages: 23
Inscription: 21 Nov 2013
Localisation: gironde

Messagepar Subbat » Mer 10 Sep, 2014 21:21

;)
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8418
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...


Retourner vers m4ng V4

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités