Plantage Windows 8

Un soucis avec vos appareils multimédia ? Besoin d'aide ?

Modérateur: Modérateurs

Messagepar Puppet » Mer 14 Nov, 2012 12:43

darknior a écrit:Oui je parlais du CLi désolé ... et je ne sais pkoi je marqué VFV lol
Donc NON le CLI ne donne pas le mm résultat que le VFW !!!
C'est sur et certains, j'ai fais des tas de tests ...
Et l'équipe de XBMC pour XBox le confirme aussi ds son WIKI !

Le CLI donne un rendu légèrement meilleur, et encode bcp plus vite vue que il utilise les 4 coeurs à la fois.
Le VFW est légèrement inférieur, mm si c'est infime à l'oeil, mais surtout pour moi n'encode que avec un seul coeur, dc grosse perte de temps :(
Et c'est pour ça que je vais tester les updates ...

Par contre, la différence qui m’intéresse ds le VFW par rapport au CLI, comme notifié ds le WIKI de XBMC, c'est que il est bien moins gourmand à décoder !
Et donc là ou la xBox ne peux lire sans saccader que du 720x400 en H264 CLI, elle peut lire du 960x400 en VFW !!!
Et ce n'est pas une question de profil d'encodage, je met tout à fond avec les deux.


La VFW est une technique différente (filtre Directshow) basé sur la version CLI c'est la même chose et tout dépend des profils d'encodage.

Et c'est pour ça qu'il y a des profils par machine...

Quand je dis que c'est un standard, c'est que M4NG le présente en tps que tel ds le choix des résolutions : 960x... (Retina)
Oui je me suis trompé encore une fois ce n'était pas DVD HD lol
J'étais fatigué qd j'ai écris mon post précédent :p


Retina 960x = iPhone 4/4S... (la encore, profils d'encodage pour iPhone...)

Ducke a écrit:
darknior a écrit:Je viens de vérifier mon test d’encodage et tout s'est parfaitement déroulé SANS ffdshow 32bit ds ma machine !
Je n'ai mis que le 64 bit et tout fonctionne ... donc tu t'es trompé, pas besoin du 32 bit ;)
Sauf que le bouton ds M4NG pour le config n'est pas prévu pour pointer sur la version 64bit ... avec les PCs d'aujourd'hui c'est dommage ...

Sauf que Puppet voulait certainement parler des codecs 64bits pour encoder et non pour décoder. Ffdshow n'est pas un codec mais des filtres et servent seulement à la lecture pour m4ng.


Absolument. ^^
Image
Avatar de l’utilisateur
Puppet
Modérateur
Modérateur
 
Messages: 5855
Inscription: 03 Fév 2007
Localisation: Arcueil

Messagepar darknior » Mer 14 Nov, 2012 13:59

Ok je comprend pour VFW ...
Mais alors si c'est pareil, croie tu que il existe un réglage CLI qui me donne le mm résultat que le VFW et marche sur xBox par exemple ?
Vue que pour moi la différence se situe sur le taux d'encodage je suppose, indépendamment du bps video.
Vue que en VFW et CLI je met pareil 1200, la mm resolution, et que l'un passe et l'autre pas :(

Pour le 64bit, tu me dis donc d'installer la mise à jour du codec VFW en 32bit car la 64bit ne passera pas avec M4NG ?
Avatar de l’utilisateur
darknior
 
Messages: 268
Inscription: 01 Oct 2009

Messagepar Puppet » Mer 14 Nov, 2012 14:09

Sauf que ce dont tu parles ne joue pas. Qu'est-ce qu'il profil ? Tout simplement un fichier dans lequel sont spécifiés les paramètres d'encodage.

Tu choisis donc le profil en rapport avec ta machine et roulez jeunesse.

Prend l'exemple iPhone/iPod : http://lauden.fr/Ducke/Tutos_m4ng_v3/Ipod_iphone.html

Et pour bien comprendre de quoi il retourne : http://www.forum.m4ng.fr/comment-utilis ... t5860.html

VFW utilise VDM. Ce dernier étant en 32bit, il ne peut pas utiliser de filtre 64. Donc VFW 32bit.
Image
Avatar de l’utilisateur
Puppet
Modérateur
Modérateur
 
Messages: 5855
Inscription: 03 Fév 2007
Localisation: Arcueil

Messagepar darknior » Mer 14 Nov, 2012 15:29

Oui je voie ...

Mais en fait du coup je m'apperçoi que tous vos profils utilisent le CLI :(
Moi en fait je vais sur x264 et je sélectionne :

DXVA-Hight Def
Puis je change le CLI en VFW
Je règle le bitrate video à 1200
Je met le son en AC3 448 5.1
Puis j'encode ...

Soit en fait je choisie au départ un profil du genre :
DXVA-High Def. : permet de créer des vidéos haute définition (720p ou 1080p) décodables matériellement par les cartes graphiques supportant la norme DXVA.
DXVA-Standart Def. : permet de créer des vidéos "basse" définition (résolution DVD) décodables matériellement par les cartes graphiques supportant la norme DXVA.

La xBox n'ayant pas de carte de décodage matérielle, il me faut la seconde option.
Et je n'ai jamais essayé lol, dc c'est le moment :p

Du fait, la qualité est vraiment différente ?
Ou ça joue plus sur la taille du fichier qui est moins compressé et dc plus gros ?
Avatar de l’utilisateur
darknior
 
Messages: 268
Inscription: 01 Oct 2009

Messagepar Puppet » Mer 14 Nov, 2012 15:42

De mémoire, la Xbox n'est pas capable de lire de la HD, autrement dit au delà de la résolution DVD. (720x..)

Donc des le départ, pas de HD et peu importe la compression.
Image
Avatar de l’utilisateur
Puppet
Modérateur
Modérateur
 
Messages: 5855
Inscription: 03 Fév 2007
Localisation: Arcueil

Messagepar Subbat » Mer 14 Nov, 2012 15:45

Bah... il y a pas un profil xbox360 pour le x264 par hasard...

Il doit être optimisé pour... je pense...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8294
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Puppet » Mer 14 Nov, 2012 15:48

Xbox et Xbox360, c'est pas du tout la même chose.
Image
Avatar de l’utilisateur
Puppet
Modérateur
Modérateur
 
Messages: 5855
Inscription: 03 Fév 2007
Localisation: Arcueil

Messagepar darknior » Mer 14 Nov, 2012 16:29

Oui xBox 1 lol

Et non, en VFW elle lit le 960x400, c'est en CLI que elle est limité au 720x400.
D'où toutes mes questions depuis le début ...

Et dc là je vais tester du DXVA-Standart Def en CLI voir si ça passe ?
Ou si je suis condamné a rester sur le VFW :(
Avatar de l’utilisateur
darknior
 
Messages: 268
Inscription: 01 Oct 2009

Messagepar Puppet » Mer 14 Nov, 2012 17:17

Encore une fois et c'est pénible. CLI ou VFW ça n'a aucune importance, seul les paramètres d'encodage sont importants.

Les paramètres, c'est pas juste la résolution et le débit. Et une résolution 960x400 ça n'a aucun sens.
Image
Avatar de l’utilisateur
Puppet
Modérateur
Modérateur
 
Messages: 5855
Inscription: 03 Fév 2007
Localisation: Arcueil

Messagepar darknior » Jeu 15 Nov, 2012 2:11

Oui oui j'ai compris ...
Je me suis mal exprimé mais c'est comme ça que c'est expliqué sur le WIKI de XBMC pour XBOX !

Donc là j'ai fais un 1er test en XDVA-Standard pour faire du CLI avec j'espère les mm paramétrage que qd je faisais du VFW ...
Mais c'est dur vue que je ne les connais pas ...

La vidéo passe sur la xBox, mais mon test est mal choisi, je vais en faire d'autres pour être sur et je vous fais un retour.
Avatar de l’utilisateur
darknior
 
Messages: 268
Inscription: 01 Oct 2009

Messagepar Puppet » Jeu 15 Nov, 2012 10:57

Si le profils passe, rien ne t’empêche ensuite essaye de monter en résolution et en débit.

Tu sais au moins que les paramètres sont compatibles.
Image
Avatar de l’utilisateur
Puppet
Modérateur
Modérateur
 
Messages: 5855
Inscription: 03 Fév 2007
Localisation: Arcueil

Messagepar darknior » Ven 16 Nov, 2012 0:15

Bon mon second test a confirmé ce que je craignais :(
Ca passe sur la xBox, mieux que en DXVA-High Def, mais ca lague grave qd les scène s'accélairent !
Ca fini mm par décaler le son :(

Du coup comme tu dis que ça viens des paramètres d'encodage, je me dis que il faudrait un peu les baisser pour voir ?
Je ne sais pas trop ou aller, du coup pour le moment j'ai cliqué sur :

Je laisse en DXVA-Standard Def
Et je baisse la qualité de normal à fast.
Avec Optimisation film, on ne sais jamais si ça peux aider ?

Si je peux faire mieux, dite le moi ?
Je cherche en CLI à faire un réglage équivalent à :

DXVA-High Def
Sur lequel je changeais juste le CLI en VFW.
Avatar de l’utilisateur
darknior
 
Messages: 268
Inscription: 01 Oct 2009

Messagepar Puppet » Ven 16 Nov, 2012 12:19

En changeant de CLI à VFW, tu ne conservais pas les paramètres. Tu revenais aux paramètres par defaut du VFW.

Donc non, tu n'avais pas de paramètres HD en vfw, juste les paramètres standards.

Si ça lag, ça peut aussi être un manque de débit. Et puis surtout, la xbox n'est pas un monstre de puissance non plus (c'est un P3), elle n'est pas faite pour lire de la HD et encore moins du x264.

La xbox360 oui, la xbox non...
Image
Avatar de l’utilisateur
Puppet
Modérateur
Modérateur
 
Messages: 5855
Inscription: 03 Fév 2007
Localisation: Arcueil

Messagepar darknior » Mer 21 Nov, 2012 1:52

Juste pour dire que je n'ai pas laché l'affaire ...
J'ai déjà testé pas mal de config ...
iPhone 2, 3 , 5G ... Divx HD, ... et la je passe à Zune pour voir.

Le truc c'est que Divx HD ça lague sur xBox, iPhone 5 ça passe nickel, mais la fumée par exemple est plus pixelisée que avec le réglage par default du VFW ...
Donc je cherche encore, je ne sais pas ce qui pourrait être le plus proche ?
Décodage full software, mais pas trop violent, et pourtant belle image lol
C'est pas simple ...
Avatar de l’utilisateur
darknior
 
Messages: 268
Inscription: 01 Oct 2009

Messagepar Puppet » Mer 21 Nov, 2012 14:29

Tu peux changer de profils autant de fois que tu veux t'auras pas de miracle, a un moment faut quand même comprendre que le point le plus important c'est le débit utilisé.
Image
Avatar de l’utilisateur
Puppet
Modérateur
Modérateur
 
Messages: 5855
Inscription: 03 Fév 2007
Localisation: Arcueil

Messagepar darknior » Mer 21 Nov, 2012 18:50

Ben justement, je ne comprend pas ???
Si j'encode avec 1200kbps en CLI avec les paramètres iPhone 5 c'est tout pixélisé !
Si je fais aussi du 1200kps en VFW avec les réglages d'origine, c'est plus net !

Du coup la différence n'est que ds le paramétrage !
Surtout que les fichiers font la mm taille ...
Et dc ça me gave de pas trouver, car en CLI j'encode qd mm 4 fois plus vite :(
Avatar de l’utilisateur
darknior
 
Messages: 268
Inscription: 01 Oct 2009

Messagepar Subbat » Mer 21 Nov, 2012 18:54

darknior a écrit:Ben justement, je ne comprend pas ???
Si j'encode avec 1200kbps en CLI avec les paramètres iPhone 5 c'est tout pixélisé !
Si je fais aussi du 1200kps en VFW avec les réglages d'origine, c'est plus net !


Il faut aussi voir le rapport débit/résolution... 1200kbps en 720x... ça donne une vidéo plutôt de bonne qualité... mais 1200kbps en 1920x... ça va pas être top du tout, voir dégueulasse...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8294
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar darknior » Mer 21 Nov, 2012 19:52

Ben moi je suis tjs en 1200kps pour du 960x400 !
Logiquement ça doit être beau ...
Donc c'est pour ça que je ne comprend pas de ne pas trouver les bons réglages en CLI :(
Avatar de l’utilisateur
darknior
 
Messages: 268
Inscription: 01 Oct 2009

Messagepar pepsilite » Mer 21 Nov, 2012 19:59

pour savoir si le débit/résolution est "dans le bon", il faut regarde l'indice de qualité qu'affiche m4ng, s'il tourne autour de 0.10, c'est bon, au dessus c'est plus que mieux, en dessous, beaucoup en dessous, c'est mauvais.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22820
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar darknior » Mar 27 Nov, 2012 2:21

Mon indice de qualité est tjs largement au dessus :p
Sur mon dernier test il est a 0.13 :D

Apparemment la meilleur compromis CLI compatible xBox est d'utiliser la configuration Zune HD !
C'est pas parfait, sur mon PC les aplats de couleur sont pas terribles, MAIS avec XBMC4XBOX sur mon grand écran c'est nickel ...

Du coup je me dis que c'est le PC avec ffdshow qui décode mal ?
Même VLC fait mieux on dirait ?
Avatar de l’utilisateur
darknior
 
Messages: 268
Inscription: 01 Oct 2009

Messagepar pepsilite » Mar 27 Nov, 2012 2:38

Difficile de répondre sans voir la chose par soi-même ...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22820
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Underground78 » Mar 27 Nov, 2012 18:34

Normalement il ne devrait pas y avoir de différence sauf si la version de ffdshow que tu utilises est boguée.
Avatar de l’utilisateur
Underground78
Administrateur
Administrateur
 
Messages: 11267
Inscription: 06 Fév 2007
Localisation: France

Messagepar Puppet » Mar 27 Nov, 2012 19:06

Non mais tous ces tests de profils est un non sens hein.

DXVA SD et basta. Résolution standard et la télé fait ce qu'elle fait déjà, de l'upscalling.
Image
Avatar de l’utilisateur
Puppet
Modérateur
Modérateur
 
Messages: 5855
Inscription: 03 Fév 2007
Localisation: Arcueil

Messagepar darknior » Lun 03 Déc, 2012 16:41

Re

Bon alors, pour faire suite à tous mes posts ... vue que effectivement vous ne voyez pas de quoi je parle au niveau de l'imge, j'ai fais des screens sur une bande annonce.

Ce qui reste identique :
Bitrate 1200 bps
Resolution : 960x400

La bande annonce rippé en CLI setting Zune HD
Lecture avec Media Player Classic :




On voie pas mal de carré ... c'est vraiment pas net .

Lecture avec VLC




C'est bcp plus doux, pour moi la qualité me suffi, c'est propre et j'ai le même rendu avec XBMC sur la xBox 1 !
Du coup pquoi MPC rajoute des carré ? peux être mon ffdshow est mal réglé ???

Rippé avec VFW et setting de base apparemment :




Là ça passe nickel sans carrés "avec MPC" ... enfin il y en a plus que l'autre video avec VLC mais c plus corrext :p
Avatar de l’utilisateur
darknior
 
Messages: 268
Inscription: 01 Oct 2009

Messagepar Underground78 » Lun 03 Déc, 2012 18:40

Télécharge une version plus récente de ffdshow déjà. Ça ressemble à un bug de décodage.
Avatar de l’utilisateur
Underground78
Administrateur
Administrateur
 
Messages: 11267
Inscription: 06 Fév 2007
Localisation: France

PrécédenteSuivante

Retourner vers Assistance

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités