Prévisualisation -> M4NG a cessé de fonctionner

Pour les retours sur la v5 uniquement ...

Prévisualisation -> M4NG a cessé de fonctionner

Messagepar sethnesta » Dim 26 Mar, 2017 20:01

Bonjour,

suite à un problème avec un fichier vidéo, désormais, quand j'utilise la fonction prévisualisation cela fait planter M4NG alors qu'avant cela tout fonctionnait très bien. Les redémarrages ne donnent rien.

Je voudrais savoir comment réinitialiser complètement la solution. A priori, supprimer le dossier M4NG dans AppData/Roaming ne suffit pas, il doit y avoir des éléments de configuration ailleurs mais je ne sais pas où.

Merci !
sethnesta
 
Messages: 75
Inscription: 01 Avr 2011

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar Subbat » Lun 27 Mar, 2017 21:53

Salut,
Sans certitude aucune, essaie d'aller dans ce dossier : C:\Program Files (x86)\m4ng_v5\Xtra
Et réinstalle Avisynth...
Si ça plante c'est sans doute un problème de décodage quelque part...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar sethnesta » Lun 27 Mar, 2017 23:19

Merci Subbat pour ton aide.

Malheureusement, ça n'a rien donné, ça continue de planter.

J'ai trouvé ça dans l'eventviewer :

Nom de l’application défaillante m4ng_v5.exe, version : 5.0.2.28, horodatage : 0x57549cdc
Nom du module défaillant : CompPkgSup.DLL, version : 10.0.14393.953, horodatage : 0x58ba5a1f
Code d’exception : 0xc0000005
Décalage d’erreur : 0x0000346b
ID du processus défaillant : 0x758
Heure de début de l’application défaillante : 0x01d2a7476f6a4ad5
Chemin d’accès de l’application défaillante : C:\Program Files (x86)\m4ng_v5\m4ng_v5.exe
Chemin d’accès du module défaillant: C:\Windows\System32\CompPkgSup.DLL
ID de rapport : fb53b1a5-147e-4619-b11e-65a9cd1c7090
Nom complet du package défaillant :
ID de l’application relative au package défaillant :


Maintenant il y a peut-être des traces ailleurs mais je ne sais pas où chercher les logs générés par M4NG.
sethnesta
 
Messages: 75
Inscription: 01 Avr 2011

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar Subbat » Lun 27 Mar, 2017 23:24

Le problème, c'est que s'il y a un problème la dessus : Chemin d’accès du module défaillant: C:\Windows\System32\CompPkgSup.DLL
m4ng n'y est pour rien... ce n'est certainement pas m4ng qui a causé un problème à cette dll.
Peut-être essayer de récupérer cette dll quelque part pour la remplacer et voir ce que ça donne...
Mais je ne suis sur de rien... ça me dépasse un peu là je dois t'avouer...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar sethnesta » Lun 27 Mar, 2017 23:47

Bon, le remplacement de la DLL avec la même prise sur un autre système ne donne rien non plus.

C'est très étrange, c'est apparut vraiment spontanément, même pas après un redémarrage ou une mise jour. Je sens qu'on va avoir du mal à comprendre d'où ça vient... :bad:
sethnesta
 
Messages: 75
Inscription: 01 Avr 2011

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar Subbat » Mar 28 Mar, 2017 11:39

Bah tu sembles dire que c'est suite à un problème avec un fichier vidéo... ça a du mettre le bazar dans les filtres de lecture windows...
Essaies de charger une vidéo dans m4ng, puis via le (?) tu choisis [analyse via graphstudio]... Si ça ne plante pas, fais une copie d'écran que tu postes ici... mais à mon avis, ça va planter... Si c'est le cas, il faudra sans doute essayer de faire le ménage dans les filtres et codecs vidéo...
Dans m4ng, tu peux gérer les codecs et les filtres vidéo... Depuis le (?) puis configuration codecs... Tu as en bas, Win7DSfiltertweaker, tu cliques sur les preferred decoders, et tu choisis les codecs LAV pour à peu près tout (chez moi c'est pour tout)... Voir aussi peut-être la configuration des splitters...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar sethnesta » Mar 28 Mar, 2017 19:54

Effectivement, GraphStudio plante également. :glups:

Pour la gestion des codecs, je n'ai pas LAV, c'est souvent Microsoft ou ffdshow ou USE MERIT.
sethnesta
 
Messages: 75
Inscription: 01 Avr 2011

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar Subbat » Mar 28 Mar, 2017 20:00

Alors je te conseilles vivement d'utiliser LAV, ffdshow n'est plus mis à jour depuis des lustres...
J'ai fais ce petit post sur les outils de décodages... outils-pour-le-decodage-et-l-encodage-sous-m4ng-vt7498.html
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar sethnesta » Dim 02 Avr, 2017 11:31

Bon, une réinstall a corrigé le problème de plantage, c'est l'avantage des VM.

Par contre, depuis la réinstallation, je n'ai pas de prévisualisation et l'encode vidéo ne se fait pas (x264cli). Je ne comprends pas ...
sethnesta
 
Messages: 75
Inscription: 01 Avr 2011

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar Subbat » Dim 02 Avr, 2017 12:47

Parce que sans doute il te manque tout ce qu'il faut pour le décodage.
Tu as regarder le lien que j'avais mis au dessus ? Pour utiliser le mode "normal" de m4ng, il faut les outils de décodage...
Ca donne quoi l'analyse vidéo via graphstudio maintenant ?
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar sethnesta » Dim 02 Avr, 2017 13:28

Oui, oui, j'ai bien regardé ton lien mais j'ai dû zapper quelque chose.

Effectivement, l'analyse via graphstudio donne quelque chose comme ça :

Film.mkv -> ffdshow Audio decodeur -> Default direct sound device

Mais rien pour la vidéo.
sethnesta
 
Messages: 75
Inscription: 01 Avr 2011

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar Subbat » Dim 02 Avr, 2017 13:33

Ah bah pour les mkv, il faut le splitter en plus...
Je te conseilles donc de relire mes post précédents pour le lien vers les outils de décodage et les réglages ensuite avec codectweaktool...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar sethnesta » Dim 02 Avr, 2017 13:48

Bon effectivement, j'ai passer LAV en préféré sur les MVK au niveau des splitter et donc j'ai maintenant quelque chose de plus cohérent via grahstudio :

Film.mkv -> LAV Video decoder -> Video Renderer
-> ffdshow Audio decodeur -> Default direct sound device

Si ce n'est que quand je clique sur Prévisualisation, M4NG plante de nouveau. Me voila revenu au point de départ avec une VM pourtant toute fraiche.
sethnesta
 
Messages: 75
Inscription: 01 Avr 2011

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar Subbat » Dim 02 Avr, 2017 13:53

Très étrange tout ça... et quand tu as le graph, si tu cliques sur le bouton lecture de graphstudio, ça lit la vidéo ?
Si oui, je ne comprend pas puisque la prévisualisation de m4ng fonctionne exactement de la même manière que graphstudio si je ne me trompe pas...
Pepsi devrait être de retour d'ici quelques jours, il aura peut-être des pistes...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar sethnesta » Dim 02 Avr, 2017 13:55

Oui je te confirme que via graphstudio la lecture fonctionne nikel.

Dans l'eventviewer de Windows j'ai ça :

Nom de l’application défaillante m4ng_v5.exe, version : 5.0.2.28, horodatage : 0x57549cdc
Nom du module défaillant : LAVVideo.ax, version : 0.69.0.0, horodatage : 0x584d7194
Code d’exception : 0xc0000005
Décalage d’erreur : 0x0009c709
ID du processus défaillant : 0x14e8
Heure de début de l’application défaillante : 0x01d2abaf1dee8b70
Chemin d’accès de l’application défaillante : C:\Program Files (x86)\m4ng_v5\m4ng_v5.exe
Chemin d’accès du module défaillant: C:\Program Files (x86)\LAV Filters\x86\LAVVideo.ax
ID de rapport : f2453e2a-55e9-46f8-adec-5a77c2aa9aac

Je ne comprends pas non plus, ça fonctionnait sans problème depuis des années.
sethnesta
 
Messages: 75
Inscription: 01 Avr 2011

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar Subbat » Dim 02 Avr, 2017 14:17

Ah bah ça alors... au vu de ton message c'est le splitter LAV qui planterait... c'est franchement un comble là...
Il faudrait que je sois sur un pc où tout ça est installé pour voir...
Pourrais tu faire des capture d'écran des paramétrages de codectweaktool (réglage des splitters et tweak)
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar sethnesta » Dim 02 Avr, 2017 14:34

Pour le moment, la seule explication que je vois c'est une mise à jour de Windows.

Je suis en Windows 10 version 1607 (14393.969) x64.
sethnesta
 
Messages: 75
Inscription: 01 Avr 2011

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar Subbat » Dim 02 Avr, 2017 15:07

Ou la vidéo avec laquelle tu avais rencontré un problème que tu évoques au début, et qui aurait "cassé" quelque chose au niveau des filtres vidéos et/ou des directshow...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar sethnesta » Dim 02 Avr, 2017 20:14

Ouais, j'y ai pensé aussi mais là j'ai testé avec d'autres vidéos et le problème est le même ...
sethnesta
 
Messages: 75
Inscription: 01 Avr 2011

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar Subbat » Dim 02 Avr, 2017 21:38

Non, ce que je veux te dire c'est qu'au début tu dis "suite à un problème avec un fichier vidéo..."
Il est donc possible que ce problème ait "cassé" quelque chose, et que maintenant ça empêche tout bon fonctionnement avec toutes vidéos...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar sethnesta » Dim 02 Avr, 2017 22:47

Oui je comprends mais théoriquement, si je réinstalle un Windows tout frais avec une install propre de M4NG, le problème devrais avoir disparu. Or ça n'est pas le cas.
C'est là où je perd la logique des choses...
sethnesta
 
Messages: 75
Inscription: 01 Avr 2011

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar Subbat » Dim 02 Avr, 2017 23:01

Ah oui j'avais oublié que tu avais refait une installation de windows... Je ne vois pas ce qui cloche donc là...
Visiblement ne n'est pas le splitter qui plante mais le décodage LAV.
Essaie de remettre les tweaks sur windows et n'utiliser LAV que dans la partie splitter pour voir...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar sethnesta » Lun 03 Avr, 2017 22:48

Même résultat :bad:

Je vais essayer de monter une VM avec une version 1511 de Windows 10 histoire de voir si mon intuition est bonne.

Je te tiens au courant.
sethnesta
 
Messages: 75
Inscription: 01 Avr 2011

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar Subbat » Mar 04 Avr, 2017 8:12

Bah écoute, je sèche un peu là...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8388
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Re: Prévisualisation -> M4NG a cessé de fonctionner

Messagepar sethnesta » Mer 05 Avr, 2017 20:54

Bon et bien même résultat avec une VM en Windows 10 version 1511 toute fraiche.

J'en perd mon latin ...
sethnesta
 
Messages: 75
Inscription: 01 Avr 2011

Suivante

Retourner vers m4ng v5

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités