Probleme de delay avec profil d'encodage

Probleme de delay avec profil d'encodage

Messagepar bareau » Dim 30 Nov, 2014 3:25

Bonjour à tous,
voila j'ai un petit soucis, j'ai encodé des episodes d'une série ( plus de 100) avec fichier de profil d'encodage.
petit bémol, je n'ai pas fait attention mais la vidéo que j'ai utiliser pour enregistrer le profil d'encodage avait un décalage son de 200ms , or 98% des épisodes n'ont nativement aucun décalage et donc je me retrouve avec tous mes épisodes avec un décalage de 200ms.et chose étonnante, quand j'ouvre une tache de compression pour un épisode, j'ouvre la prévisualisation et le délai est de 0,mais quand je charge mon episode une fois encodé il me marque dans l'analyse delay 200ms0comment puis je faire pour remettre le délai a 0?
merci


[Edité par Subbat]Ajout d'un titre au sujet (titre non pris en charge si accent)
bareau
 
Messages: 16777215
Inscription: 20 Aoû 2014

Messagepar Underground78 » Dim 30 Nov, 2014 9:37

Bonjour,

Quel format de fichier as-tu utilisé ?
Avatar de l’utilisateur
Underground78
Administrateur
Administrateur
 
Messages: 11267
Inscription: 06 Fév 2007
Localisation: France

Messagepar bareau » Dim 30 Nov, 2014 11:32

mp4 malheureusement
bareau
 
Messages: 16777215
Inscription: 20 Aoû 2014

Messagepar Underground78 » Dim 30 Nov, 2014 11:59

C'est probablement possible de faire ça avec mp4box en ligne de commande si tu as beaucoup de fichiers. Est-ce qu'ils sont tous identiques en structure (nombre de pistes, etc.) ?
Avatar de l’utilisateur
Underground78
Administrateur
Administrateur
 
Messages: 11267
Inscription: 06 Fév 2007
Localisation: France

Messagepar bareau » Dim 30 Nov, 2014 12:12

oui ils sont identiques
bareau
 
Messages: 16777215
Inscription: 20 Aoû 2014

Messagepar bareau » Dim 30 Nov, 2014 14:28

chose étonnante , sur tout mes rip meme ceux ou j'ai pas utiliser le profil d'encodage(meme ceux qui n'ont rien a voir avec la serie), j'ai mes 200ms de delai. est 'il possible que le delai est ete enregistrer quand j'ai definit les parametre codec par defaut?

EDIT: oui c'est bien ca, quand j'ouvre n'importe quelle video pour un encodage, il me met systematiquement 200 ms de delai.J'ouvre la previsualisation, je change le delai de 200 a 0 , je valide ,je clic sur devenir la configuration codec par défaut au demarrage de m4ng, je ferme m4ng , je l'ouvre de nouveau , je charge n'importe quelle video et la j'ai plus de delai de 200ms. Mais pourquoi? le delai audio n'a rien a voir avec la config du codec video non?
bareau
 
Messages: 16777215
Inscription: 20 Aoû 2014

Messagepar Subbat » Dim 30 Nov, 2014 18:29

Là je crois que seul pepsi, absent pour le moment, pourra te répondre je pense...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8398
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar bareau » Dim 07 Déc, 2014 14:24

Hello, voila la suite de mes aventures:
J'ai reglé le probleme du decalage avec le profil mais de nouveaux problèmes,en mode non autonome, le son AAC est encodé en vbr et j'ai un tout petit decalage. En mode autonome , le son est encodé en cbr et aucun décalage, mais malheureusement, en mode autonome, les limites de cropping ne sont pas respectés j'ai une bande noire a gauche de l'image, même avec l'option utilisé le x264 en mode autonome.En mode non autonome les limites sont bien respectés, plus de bande noire a gauche.
j'ai donc le choix soit d'avoir un petit décalage et des bonnes limites d'images ou alors pas de décalage de son mais une image mal croppé.
est t'il possible de forcer le CBR en mode non autonome?
merci
bareau
 
Messages: 16777215
Inscription: 20 Aoû 2014

Messagepar Subbat » Dim 07 Déc, 2014 16:44

Je ne suis pas certain que le décalage vienne du fait que l'encodage audio soit en vbr... Essaie plutôt, en mode non autonome, de choisir l'option "utiliser ffmpegsource comme décodeur avisynth"...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8398
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar bareau » Dim 07 Déc, 2014 19:06

j'ai télécharger neroenc et je l'ai mis dans le dossier système, ca a régler le problème du décalage en non autonome.le problème venait sans doute de faac (c'est pas grand chose peut etre 100 ou 200ms d'avance mais visible , j'ai fait le test sans savoir quelle video je regardais via liste de lecture et suivant plein de fois, je me suis jamais trompé), mais en mode autonome j'ai toujours la bande noir a gauche.Comme j'ai plus de décalage, je vais les faire en non autonome.Y'a til un moyen d'encoder en CBR plutot qu'en VBR en non autonome?
bareau
 
Messages: 16777215
Inscription: 20 Aoû 2014

Messagepar Subbat » Lun 08 Déc, 2014 7:51

bareau a écrit:Y'a til un moyen d'encoder en CBR plutot qu'en VBR en non autonome?

Non je ne crois pas...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8398
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...


Retourner vers m4ng V4

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités