probleme pour encoder en 3gp et mp4

Modérateurs: Puppet, Modérateurs

probleme pour encoder en 3gp et mp4

Messagepar pepsy » Sam 01 Sep, 2007 10:59

salut les gens , J'essaie désespérement de convertir des clips vidéos en 3gp mais ça ne fonctionne pas.Les fichiers font 0 octet, Bref je n'y arrive pas. J'ai lu quelques sujets ici et sur "l'ancien" forum,mais cela ne répond pas vraiment à mes questions .Pouvez vous m'aider ?

PS: j'ai téléchargé la mise à jour psp, 3gp... et executer ripp it au moins une fois avant d'installer le pack psp, j'ai aussi essayer en installant ffdshow, mais ça marche pas. j'avais deja eu le meme probleme que j'avais resolu sur une ancienne installation, mais me rapel plus ce que j'avais fait

(j'avais eu l'aide de pepsilite)

Merci de m'aider , j'aimerai bien tester les capacités de mon nouveau telephone ,le P1 i silver

merci d'avance :yeap:
Avatar de l’utilisateur
pepsy
 
Messages: 9
Inscription: 01 Sep 2007

Messagepar Underground78 » Sam 01 Sep, 2007 11:08

Salut,

Commence par regarder si tu as des fichiers bat à la racine de ton disque dur et dis moi leurs noms s'il y en a ...

PS : Pour ceux qui se pose la question, j'ai effectivement un trou sur le nom ... :mrgreen:
Avatar de l’utilisateur
Underground78
Administrateur
Administrateur
 
Messages: 11267
Inscription: 06 Fév 2007
Localisation: France

Messagepar pepsy » Sam 01 Sep, 2007 11:15

Pas de .bat a la racine de mon disque dur que des .text(mpeg), (pvas),et ms dos(ffmpeg), (ffmpeg_debug)
Avatar de l’utilisateur
pepsy
 
Messages: 9
Inscription: 01 Sep 2007

Messagepar Underground78 » Sam 01 Sep, 2007 11:20

Pas de bat à la racine du disque dur où est installé Riam ? étrange ou alors c'est moi qui est plus rouillé que je le pensais ...
Avatar de l’utilisateur
Underground78
Administrateur
Administrateur
 
Messages: 11267
Inscription: 06 Fév 2007
Localisation: France

Messagepar pepsy » Sam 01 Sep, 2007 11:22

J'ai peut etre certaine extension que xp me cache, et je sais plus ou aller pour toute les rendre visible

riam est dans mon program files

(je file au taf , merci de ton aide, je repassse c'e soir)
Avatar de l’utilisateur
pepsy
 
Messages: 9
Inscription: 01 Sep 2007

Messagepar Dirk-Pitt » Sam 01 Sep, 2007 12:00

:welc pepsy


C'est ffmpeg_debug ;) il faut le lancer dans une Invite de Commandes ( Démarrer, Programmes, Accessoires ) et regarder le message d'erreur.
Sinon, le pro du téléphone c'est Dimdes. :o:
Dell OptiPlex 755, 8 Go ram, 1.5 To disk, dual screen 2 x Dell 2007FP ( 3200x1200 ). Linux openSUSE 11.0
Avatar de l’utilisateur
Dirk-Pitt
Membre Fondateur
Membre Fondateur
 
Messages: 10541
Inscription: 03 Fév 2007
Localisation: 01's Land

Messagepar pepsilite » Sam 01 Sep, 2007 14:10

Salut cousin Pepsy :D

tu essayes d'encoder en quel codec video et quelle resolution? Dimdes a dit que le 320x240 semblait ne pas passer en h263. ffmpeg_debug.bat te le dira de toute façon ...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar misterd » Sam 27 Oct, 2007 10:32

Après des essais sur des petites portions de film, le 320x240 en h264 passe très bien ainsi qu' en 352x288 en h263 mais avec le son soit en AAC soit en mp3. Seul le son en AMR ne fonctionne pas.
Avatar de l’utilisateur
misterd
 
Messages: 481
Inscription: 24 Oct 2007

Messagepar pepsilite » Sam 27 Oct, 2007 11:20

le son AMR ne passe pas en 320x240 ou dans tous les cas?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar misterd » Sam 27 Oct, 2007 13:05

AMR ne passe pas dans toutes les configurations (h263-h264-xvid, 320x.., 178x.., .....)
Avatar de l’utilisateur
misterd
 
Messages: 481
Inscription: 24 Oct 2007

Messagepar pepsilite » Sam 27 Oct, 2007 13:18

ok, je vais regarder ça...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Puppet » Sam 27 Oct, 2007 15:57

Malheureusement y a pas de configuration generique ! Chaque mobile a plus ou moins son format...

A par essayer de tester un peu de tout... Ca peut venir de l'extension... aac, m4a, m4v, mp4, 3gp... Du codec video... de son debit, de la resoltion, idem pour le son... mono, stereo etc...

Pour s'en sortir, il faudrait arriver a repertorier les config de chaque telephone, et ca...

D'ailleurs, si les visiteurs pouvaient laisser leur telephones (marque et model) et la configuration qui fonctionne, on pourrait lister ! :)
Image
Avatar de l’utilisateur
Puppet
Modérateur
Modérateur
 
Messages: 5855
Inscription: 03 Fév 2007
Localisation: Arcueil

MR

Messagepar misterd » Sam 27 Oct, 2007 16:43

Pour les configurations des téléphones, ok. Moi j' ai un nokia E65 et je ne lis pas en 320x240.

Mais quand je dis que ca ne passe pas avec le son AMR, c' est l' encodage qui ne fonctionne pas, donc je ne sais pas si mon téléphone accepte l' AMR.


PS:Après je pourrais essayer plusieurs config d' encodage, ça n'est pas très long pour réencoder un film.
Dernière édition par misterd le Sam 27 Oct, 2007 16:47, édité 1 fois.
Avatar de l’utilisateur
misterd
 
Messages: 481
Inscription: 24 Oct 2007

Messagepar pepsilite » Sam 27 Oct, 2007 16:46

C'est bon, j'ai trouvé pourquoi ça ne marchait pas, ffmpeg a complètement changé dans sa dernière version (c'était trop pratique avant) et le paramétrage du son AMR aussi, j'ai corrigé, ça fonctionne, mais j'ai cherché un bout de temps sur le web le bon paramétrage...
:hop:
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar misterd » Sam 27 Oct, 2007 16:50

Allons nous avoir une première mise à jour ? Du moins pour ma machine.
Avatar de l’utilisateur
misterd
 
Messages: 481
Inscription: 24 Oct 2007

Messagepar pepsilite » Sam 27 Oct, 2007 16:54

05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar misterd » Sam 27 Oct, 2007 17:00

Rapide efficace
Un grand merci, je pourrais continuer mes tests.
Avatar de l’utilisateur
misterd
 
Messages: 481
Inscription: 24 Oct 2007

Messagepar Puppet » Sam 27 Oct, 2007 17:26

Et nous donner les resultats ! ^^
Image
Avatar de l’utilisateur
Puppet
Modérateur
Modérateur
 
Messages: 5855
Inscription: 03 Fév 2007
Localisation: Arcueil

Messagepar misterd » Sam 27 Oct, 2007 17:46

Naturellement, je vais essayer toutes les configurations 3gp ou mp4 possible avec m4ng même si mon nokia ne les accepte pas.
Donc à bientôt.
Avatar de l’utilisateur
misterd
 
Messages: 481
Inscription: 24 Oct 2007

Messagepar dimdes » Dim 04 Nov, 2007 7:00

merci Misterd
Image
Avatar de l’utilisateur
dimdes
Membre Fondateur
Membre Fondateur
 
Messages: 621
Inscription: 04 Fév 2007

J'ai le même problème : Video finale = 0 octet

Messagepar louis10 » Mer 27 Jan, 2010 19:34

J'ai fait plusieurs essais : Video 320 x 240, MP4 ou 3GP, Audio MP3 8 (8, c'est quoi ?)
Avant de lancer l'encodage, je teste le son, Ok, je prévisualise la video, Ok.
L'encodage est très rapide et donne un fichier de 0 octet.

Pour l'instant, ces essais ne dépendent pas du mobile. On verra quand j'obtiendrai un fichier > 0 octet.
J'imagine que certains paramètres sont propres au mobile (HTC dans mon cas).
louis10
 
Messages: 36
Inscription: 26 Jan 2010

Messagepar pepsilite » Mer 27 Jan, 2010 19:39

8 = débit de l'audio.

lance le fichier c:\ffmpeg_debug.bat et regarde si tu vois un message d'erreur s'afficher dans la fenêtre de commande...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Message d'erreur :

Messagepar louis10 » Mer 27 Jan, 2010 19:43

C:\>"C:\PROGRA~1\m4ng\system\ffmpeg.exe" -i "C:\PROGRA~1\m4ng\system\Am4ng.avs"
-s 320x240 -b 400000 -vcodec xvid -r 14.985 -acodec mp3 -ab 8000 -f 3gp "c:\dvd\
OUT_film.MP4"
FFmpeg version SVN-r8564, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --enable-gpl --enable-pp --enable-swscaler --enable-pthreads --
enable-liba52 --enable-avisynth --enable-libdts --enable-libfaac --enable-libfaa
d --enable-libgsm --enable-libmp3lame --enable-libnut --enable-libogg --enable-l
ibtheora --enable-libvorbis --enable-x264 --enable-xvid --enable-amr_nb --enable
-amr_wb --cpu=i686 --enable-memalign-hack --extra-ldflags=-static
libavutil version: 49.4.0
libavcodec version: 51.40.2
libavformat version: 51.11.0
built on Mar 31 2007 16:35:11, gcc: 4.3.0 20070126 (experimental)
Input #0, avs, from 'C:\PROGRA~1\m4ng\system\Am4ng.avs':
Duration: 00:12:08.6, start: 0.000000, bitrate: 0 kb/s
Stream #0.0: Video: rawvideo, yuv420p, 352x256, 27033 kb/s, 25.00 fps(r)
Stream #0.1: Audio: pcm_s16le, 48000 Hz, stereo, 1536 kb/s
Output #0, 3gp, to 'c:\dvd\OUT_film.MP4':
Stream #0.0: Video: xvid, yuv420p, 320x240, q=2-31, 400 kb/s, 14.98 fps(c)
Stream #0.1: Audio: mp3, 48000 Hz, stereo, 8 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
Error while opening codec for output stream #0.1 - maybe incorrect parameters su
ch as bit_rate, rate, width or height
louis10
 
Messages: 36
Inscription: 26 Jan 2010

Messagepar pepsilite » Mer 27 Jan, 2010 19:50

ok, j'y vois déjà plus clair, en fait c'est un bug que personne n'avait encore repéré, avec le son MP3 on ne peut pas réencoder en dessous de 32 kbps (et pas 8), avec 32 minimum l'encodage se fait sans problème...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22806
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

L'encodage marche

Messagepar louis10 » Mer 27 Jan, 2010 20:00

Ca c'est de la hot line !!
Plus rapide, tu ...

Maintenant, je vais essayer le MP4 sur le HTC ...

Au fait, comment ça fonctionne m4ng. Il y a 1 ou 2 gars 24/24 h ... ?!
Et quelques développeurs... ?
louis10
 
Messages: 36
Inscription: 26 Jan 2010

Suivante

Retourner vers PSP - iPod - Mobiles

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités