Probleme resolution mpeg2

Probleme resolution mpeg2

Messagepar phyllox » Dim 05 Oct, 2014 10:50

Bonjour à tous

J'ai depuis peu de temps un souci que je ne sais pas comment régler.
Je réencode des vidéos (enregistrements télé) au format 720P en 1280 x 720. Ce sont des vidéos MPEG . Voici l'analyse M4ng :
d:\flms\film-1.mpg
[ Débit 12.7 Mbps - Taille 4.763 GiB - Durée 00h53m46s - 2 Pistes ]
01 Video 0xE0 | Débit 12000 kbps - MPEG2 - 161301 images - 50.000 /seconde - 1280x720 - [16/9]
02 Audio 0xC0 | Débit 224 kbps - MP2 Cbr - 2ch - delay 15ms - 48.0 khz | Und

Ces vidéos sont enregistrées avec un bord noir vertical assez important, je dois donc faire un crop et, en général, je passe leur taille à 1376 x 768 pour avoir une taille cropée de 1280 x 720 (je sais que ça ne sert à rien d'augmenter la taille, mais ça ne change rien au problème que j'ai ici).

Lorsque j'ouvre la fenêtre de crop, la taille de la vidéo est automatiquement changée à 1280 x 784 (la fenêtre affiche la nouvelle résolution).

J'ai donc une proportion erronée, que je ne peux rectifier que manuellement après avoir décoché "Conserver l'aspect de l'image".

Si j'essaye un autocrop avant ou après l'opération, le résultat est très aléatoire. Je ne parle même pas du crop manuel, où là, la résolution verticale augmente dans des proportions énormes jusqu'à me donner une image plus haute que large.

La vidéo n'est pas en cause, ni M4ng, parce que le même film sur une autre machine ne produit pas ce résultat erroné. C'est donc lié à ma machine, mais je ne sais pas à quoi.

- Le résultat est le même que je sois ou non en mode autonome
- Le résultat est le même avec M4ngV5 que j'ai installé hier (et qui mis à par ce problème auquel il n'est pour rien est vraiment TOP !) javascript:emoticon(':d:')

Par contre, une analyse avec Graph studio me montre que la vidéo passe par Microsoft DTV-DVD decoder : Film-1.mpg --> Main concept MPEG demultiplexer --> Microsoft DTV-DVD decoder --> Video renderer

Alors que sur l'autre machine, celle qui donne des résultats normaux, j'ai :
: Film-1.mpg --> Main concept MPEG demultiplexer --> Main concept MPEG2 video decoder --> Video renderer

Je crois me souvenir qu'il peut y avoir des soucis avec le decoder Microsoft - et de l'opinion que Pepsi a de lui - mais je ne me souviens pas de quoi il s'agit ni, surtout, comment modifier ça. Au moins pour essayer de voir si ça change quelque chose.

J'ai beau faire des recherches, je n'arrive pas à retrouver ça bien que je suis certain d'avoir déjà lu la solution sur ce forum.

Merci d'avance de votre aide pour retrouver des vidéos avec des proportions correctes.
A+
phyllox
 
Messages: 241
Inscription: 02 Fév 2009

Messagepar phyllox » Dim 05 Oct, 2014 12:58

Rebonjour à tous

Dans l'intervalle, j'ai réussi à passer le décodage Mpeg2 à Ffdshow, mais même désactivé Microsoft decoder avec Win7DSFilterTweaker, et Grapg studio me donne maintenant ffdshow video decoder à la place.

Mais le problème de taille verticale reste identique, ce qui en soit n'est pas étonnant, en y réfléchissant, vu que c'est bien avant le décodage que le problème se produit.

J'espère pouvoir profiter de ce message pour arriver à mettre un sujet à mon post.

Merci de vos idées
phyllox
 
Messages: 241
Inscription: 02 Fév 2009

Messagepar Subbat » Dim 05 Oct, 2014 13:23

Salut,

J'ai mis un titre à ton sujet... (nous avons des problèmes avec les accents suite à une mise à jour de notre hébergeur)...

En revanche, je suis désolé, mais je n'ai pas la moindre idée de ce qui peut être la cause de ton problème...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8402
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar pepsilite » Dim 05 Oct, 2014 13:32

Main concept MPEG2 video decoder est un décodeur qui a du être installé par un logiciel tiers sur ton autre machine, recherche sur le net un installeur et ça devrait résoudre ton problème.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22974
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar phyllox » Dim 05 Oct, 2014 14:47

@Tous
Merci d'avoir édité le sujet, et merci de vos réponses

Pepsi, je ne sais pas d'où vient le main concept decoder, peut être de Tmpgenc que j'ai sur mes machines, bien que ce soit du Sony, à priori (je n'ai aucun matériel ou logiciel Sony) ; mais il est là depuis plusieurs siècles (au moins) et c'est lui qui est utilisé pour le décodage sur la machine qui fonctionne. Donc...

Qui plus est, comme je l'ai édité dans mon second message, j'ai maintenant mis ffdshow en décodeur pour le mpeg2 sur la machine qui me fait l'erreur.

Je n'ai rien installé sur ma machine depuis au moins deux semaines, et je n'avais pas le souci il y a 8 jours.

Qu'est-ce qui est appelé dans M4ng lors de la prévisu nécessaire au crop ? C'est là que le changement se fait

Merci encore
phyllox
 
Messages: 241
Inscription: 02 Fév 2009

Messagepar pepsilite » Dim 05 Oct, 2014 20:10

m4ng "n'appelle" rien, c'est le codec "principal" pour le décodage du MPEG installé qui prend la main. Sur ton autre machine, c'est le main concept, sur celle là, c'est le décodeur de windows...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22974
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar phyllox » Dim 05 Oct, 2014 22:02

Mais je l'ai changé... C'est FFDSHOW maintenant. J'ai désactivé le décodeur de Windows !!!

Ca ne peut pas être lui qui est en cause...
Que puis-je faire d'autre ?
Merci
phyllox
 
Messages: 241
Inscription: 02 Fév 2009

Messagepar pepsilite » Dim 05 Oct, 2014 22:27

FFdshow ne décode pas le MPEG, il te faut installer le fameux main concept MPEG decodeur comme sur ton autre machine.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22974
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar phyllox » Lun 06 Oct, 2014 7:56

Salut Pepsi, bonjour à tous

Pepsi, je ne comprends pas. Avec Ffdshow (qui par ailleurs se laisse configurer comme décodeur Mpeg2, puisqu'on peut choisir libavcodec pour le mpeg2, codec Mpeg2 - et qui se laisse aussi configurer pour le Mpeg2 par Win7DSFilterTweaker), l'encodage se lance et s'exécute sans problème, bien qu'avec la mauvaise définition.

Si ça n'est pas ffdshow, ni Microsoft qui est désactivé, qu'est ce qui décode, alors ?

Et pourquoi la fenêtre de Crop s'affiche-t-elle ?

Sur les machines qui n'ont pas mon fameux Codec, et n'utilisent pas Microsoft, qu'est ce qui est utilisé pour décoder le Mpeg2 ?

Merci
phyllox
 
Messages: 241
Inscription: 02 Fév 2009

Messagepar pepsilite » Lun 06 Oct, 2014 12:04

Seul Graphstudio peut te dire ce qui décode ton MPEG, chez moi c'est le décodeur de windows et si je le vire, c'est le main concept qui le fait même si c'est ffdshow qui est paramétré pour.

Pour le crop, le cas est différent, ce n'est pas une vidéo mais une simple image qui s'affiche, laquelle est capturée par ffmpeg en tâche de fond.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22974
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Subbat » Lun 06 Oct, 2014 17:27

pepsilite a écrit:Seul Graphstudio peut te dire ce qui décode ton MPEG, chez moi c'est le décodeur de windows et si je le vire, c'est le main concept qui le fait même si c'est ffdshow qui est paramétré pour.

Pour le crop, le cas est différent, ce n'est pas une vidéo mais une simple image qui s'affiche, laquelle est capturée par ffmpeg en tâche de fond.


Alors le problème vient peut-être du batch de capture via ffmpeg... dans le cas d'un mpeg2 en entrée, il faut peut-être indiqué le ratio dans la commande... Je me demande si je n'ai pas déjà été confronté à ce problème... mais auquel cas on a du en parler et tu avais du corriger...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8402
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar phyllox » Lun 06 Oct, 2014 22:11

Bonsoir

En tous cas, j'ai encore vérifié que ça ne venait pas de la vidéo elle même. J'ai installé m4ng v5 sur une machine virtuelle Windws 8 sur la même machine que celle qui cause des soucis, et là, la vidéo n'est pas resizée (avec Windows decoder).

Et vraiment impossible de faire un resize manuel, dès qu'on sort de la fenêtre d'affichage de la vidéo pour le crop, le format change encore, et si on y retourne... Là je me retrouve avec une vidé qui est passée de 1280 x 720 à une dimension non cropée de... 1376 x 8528. C'est comme l'histoire du lit vertical...

Une chose est certaine, je ne sais pas, moi, résoudre ce problème...

Donc toutes vos idée seront les bienvenues

Merci encore
phyllox
 
Messages: 241
Inscription: 02 Fév 2009

Messagepar pepsilite » Lun 06 Oct, 2014 22:47

Que dire à distance ... Encode ta vidéo sur ta VM
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22974
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar phyllox » Mar 07 Oct, 2014 16:30

Salut

Je comprends le problème du à distance, mais moi je n'ai pas connaissance des mécanismes M4ng, comment la fenêtre de crop est appel à partir de la fenêtre principale.

Quant à encoder avec la machine virtuelle... Bon, une seul Core et 1 seul Go de mémoire, on n'est pas arrivé !

Mais je reviens à la charge parce qu'il y a quand même quelque chose d'anormal.

Je charge - dans la V5 où le problème est le même - une vidéo dont la taille confirmée par ffinfos et mediainfo est de 1280 x 720. J'y applique le codec video x264cli, un débit de 2300, l'AAC Nero pour l'audio et le conteneur MP4. Et à partir de cette simple config, je crée un nouveau profil, appelons le "film 1280".

Ensuite, je clique sur la flèche à droite, en haut, à droite du nom du film pour afficher la fenêtre de Crop.

Dans le bas de cette fenêtre la taille s'affiche à 1280 x 784 (au lieu de 720) et l'aspect à 1,633 / 1,778 (92 %) ce qui n'est déjà pas bon.

Je ferme cette fenêtre sans rien toucher : La vidéo s'affiche maintenant en 1280 x 784 (toujours au lien de 720).

Je ne fais rien. Je ferme simplement M4ng, sans re-sauvegarder le profil.

Je rouvre m4ng, choisis la même vidéo, qui s'affiche en 1280 x 720, je sélectionne le profil créé au début "Film 1280".

Instantanément, la taille s'affiche alors en 1280 x 784 - alors même que la taille était à 1280 x 720 quand j'ai sauvegardé le profil.

Les fichiers mediainfo et ffinfos indiquent toujours la taille correcte 1280 x 720

Où est-ce que le profil va chercher les 784 ??

Comment, moi, pourrais-je savoir où M4ng va chercher ses informations ?

Je précise que à la première ouverture du fichier, dans m4ng, vu que c'est du mpeg, il y a un d2v de créé (et un d2a) et que la taille dans le d2v s'affiche bien à 1280 x 720.

Est-ce que ces informations pourraient te permettre de m'aider ? A part recharger une vieille image de mon disque C:, je ne vois pas où je pourrais intervenir.

Je précise que les correctives manuelles de changer l'espect ne font qu'empirer le problème.

Merci encore de ton aide, si tu le peux.
phyllox
 
Messages: 241
Inscription: 02 Fév 2009

Messagepar phyllox » Jeu 09 Oct, 2014 12:35

Bonjour Pepsi, bonjour à tous

Je me permets de revenir à la charge. Est ce que c'est un programme externe qui lance la fenêtre de crop vidéo à partir de M4ng - et qui en l'occurrence me change d'autorité la résolution verticale - ou bien est-ce du développement m4ng ?

J'ai essayé d'ouvrir ma vidéo avec tous les logiciels qui savent le faire sur mon poste, Videoredo, Tmpgenc, VLC, Windows Media etc.. et tous m'affichent la résolution originale de 1280 x 720. Seul M4ng me change la résolution verticale.

Par ailleurs, si comme Subbat semble le dire, c'est ffmpeg qui le fait, j'ai vérifié que c'est bien le ffmpeg présent dans m4ng qui est configuré (j'ai viré la V4, et n'ai réinstallé que la v5). Ffmepg est par ailleurs installé dans le répertoire de configuration de mon Synology, mais je l'ai aussi sur l'autre machine.

J'ai vérifié les filtres et codecs vidéo installés, la seule différence entre la machine qui fonctionne et l'autre, c'est la présence du filtre MainConcept (je ne sais pas d'où il vient, c'est payant) et des codecs VP60 et 61 et Xvid, que je n'utilise jamais.

J'ai installé M4ng V5 sur une 3ème machine (qui ne fait pas de réencodage), j'ai les mêmes codecs et le même Graphstudio que la machine en cause ici, mais pas d'erreur d'affichage sur la machine en question.

J'ai viré de cette bécane tout ce qui ne me sert pas par ailleurs, mais j'ai besoin du reste.

Je suis à bout d'idées, j'ai vraiment besoin d'une piste pour continuer à chercher une solution.

Merci d'avance de toutes suggestions.
phyllox
 
Messages: 241
Inscription: 02 Fév 2009

Messagepar Subbat » Jeu 09 Oct, 2014 20:10

Bah là ça se complique... si tout va bien sur d'autres pc avec la même config et la même vidéo... on ne va pas pouvoir faire grand chose...

Tu as essayé d'aller dans les paramètres de m4ng et de faire un "effacer toutes traces de m4ng"...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8402
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar phyllox » Jeu 09 Oct, 2014 22:12

Bonsoir... Oui, bien entendu, j'ai fait ça aussi...

Petite précision importante. je pensais que ça ne touchait que les mpeg2, mais à priori, d'autres enregistrements en H264/AAC (1440 x 1080) sont concernés aussi. Mes enregistrement sur les chaines TNT HD. Je ne m'en étais pas aperçu parce que la vidéo est quasiment toujours retaillée en mode 16/9, mais pour ces vidéos également, la taille verticale affichée est trop importante.

Mais j'insiste sur le fait que l'ensemble des mes autres applis capables d'ouvrir des vidéos m'affichent la résolution correcte. J'ai juste le passage à la fenêtre de crop m4ng (v4 ou v5) qui génère le problème.

D'où ma question, est-ce que c'est un logiciel tiers qui s'ouvre, habillé par M4ng ? Quel processus au moment de l'ouverture est capable de changer la taille de la vidéo à la volée ?

Et qui plus est de modifier le profil sauvegardé ?

Si c'est un logiciel tiers, c'est celui là que je dois aller voir ou supprimer pour qu'il soit recréé ?

Bon, je dis peut être des âneries, la vidéo, c'est pas mon domaine informatique

Merci encore
phyllox
 
Messages: 241
Inscription: 02 Fév 2009

Messagepar Ducke » Ven 10 Oct, 2014 7:12

Si sur tes autres pc ça fonctionne, ça ne vient pas de m4ng lui même ... tu as quelque chose sur cette machine lui fait perdre la tête.
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar de l’utilisateur
Ducke
Administrateur
Administrateur
 
Messages: 8544
Inscription: 08 Fév 2007

Messagepar phyllox » Ven 10 Oct, 2014 8:07

Salut

Bon sang, je sais bien que c'est sur la machine !!!

Mais seules les informations demandées sur M4ng pourront m'aider à trouver quoi !

Merci
phyllox
 
Messages: 241
Inscription: 02 Fév 2009

Messagepar Subbat » Ven 10 Oct, 2014 8:35

Bah je te l'ai déjà dit... la fenêtre de crop n'est qu'une image créée par ffmpeg à partir de ta vidéo... Si tu vas dans le dossier de travail de m4ng, tu dois avoir un fichier qui s'appelle : $$$capture000000.bmp c'est l'image qui est utilisé dans la fenêtre du crop...

1. L'analyse ffinfo de ta video donne quoi ? Peux tu en faire copie ici ?
2. Dans le dossier de travail de m4ng tu as un fichier capture.bat... Fais un clic droit sur ce fichier, puis modifier... Tu ajoutes une ligne avec écrit "pause" (sans les guillemets)... Tu enregistres et tu lances ce capture.bat... Ensuite, dans la fenêtre dos qui restera ouverte, tu fais un clic droit puis sélectionner tout, puis tu tapes sur la touche entrée de ton clavier, ce qui copiera le contenu de cette fenêtre... tu n'auras plus qu'à copier ce contenu ici pour qu'on voit ce que ça donne...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8402
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar phyllox » Ven 10 Oct, 2014 16:43

Bonjour Subbat, merci de ton retour.

Voici les infos demandées :

Excéution du capture.bat AVANT l'ouverture du fichier dans la fenêtre de crop (mais c'est le même après, j'ai vérifié au cas où...)

C:\Users\Bureau\AppData\Roaming\m4ng>chcp 1252
Page de codes active : 1252

C:\Users\Bureau\AppData\Roaming\m4ng>C:\PROGRA~2\m4ng_v5\system\ffmpeg.exe -i "j
:\CIN~1\FREB4A~1.TS" -ss 00:01:00.000 -t 00:00:00.040 -y "C:\Users\Bureau\AppDat
a\Roaming\m4ng\$$$CAP~1.BMP"
ffmpeg version N-56749-g7057cc8 Copyright (c) 2000-2013 the FFmpeg developers
built on Sep 29 2013 18:04:55 with gcc 4.8.1 (GCC)
configuration: --disable-static --enable-shared --enable-gpl --enable-version3
--disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --ena
ble-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --e
nable-libcaca --enable-libfreetype --enable-libgsm --enable-libilbc --enable-lib
modplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrw
b --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinge
r --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --en
able-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis
--enable-libvpx --enable-libwavpack --enable-libx264 --enable-libxavs --enable-
libxvid --enable-zlib
libavutil 52. 46.100 / 52. 46.100
libavcodec 55. 33.101 / 55. 33.101
libavformat 55. 18.104 / 55. 18.104
libavdevice 55. 3.100 / 55. 3.100
libavfilter 3. 88.100 / 3. 88.100
libswscale 2. 5.100 / 2. 5.100
libswresample 0. 17.103 / 0. 17.103
libpostproc 52. 3.100 / 52. 3.100
Input #0, mpegts, from 'j:\CIN~1\FREB4A~1.TS':
Duration: 01:38:58.85, start: 0.150756, bitrate: 4506 kb/s
Program 1
Stream #0:0[0xdc]: Video: h264 (High) ([27][0][0][0] / 0x001B), yuv420p, 144
0x1080 [SAR 4:3 DAR 16:9], 25 fps, 25 tbr, 90k tbn, 50 tbc
Stream #0:1[0xe6]: Audio: aac ([15][0][0][0] / 0x000F), 48000 Hz, stereo, fl
tp, 129 kb/s
Stream #0:2[0xf1](fre): Subtitle: dvb_teletext ([6][0][0][0] / 0x0006)
Output #0, image2, to 'C:\Users\Bureau\AppData\Roaming\m4ng\$$$CAP~1.BMP':
Metadata:
encoder : Lavf55.18.104
Stream #0:0: Video: bmp, bgr24, 1440x1080 [SAR 4:3 DAR 16:9], q=2-31, 200 kb
/s, 90k tbn, 25 tbc
Stream mapping:
Stream #0:0 -> #0:0 (h264 -> bmp)
Press [q] to stop, [?] for help
frame= 1 fps=0.1 q=-1.0 Lsize=N/A time=00:00:00.04 bitrate=N/A
video:4556kB audio:0kB subtitle:0 global headers:0kB muxing overhead -100.000472
%

C:\Users\Bureau\AppData\Roaming\m4ng>Pause
Appuyez sur une touche pour continuer...


Et voici le ffinfos.txt

[STREAM]
index=0
codec_name=mpeg2video
codec_long_name=MPEG-2 video
profile=High
codec_type=video
codec_time_base=1/100
codec_tag_string=[0][0][0][0]
codec_tag=0x0000
width=1280
height=720
has_b_frames=1
sample_aspect_ratio=1:1
display_aspect_ratio=16:9
pix_fmt=yuv420p
level=4
timecode=00:00:00:00
id=0x1e0
r_frame_rate=50/1
avg_frame_rate=50/1
time_base=1/90000
start_pts=19800
start_time=0.220000
duration_ts=422843400
duration=4698.260000
bit_rate=N/A
nb_frames=N/A
nb_read_frames=N/A
nb_read_packets=N/A
DISPOSITION:default=0
DISPOSITION:dub=0
DISPOSITION:original=0
DISPOSITION:comment=0
DISPOSITION:lyrics=0
DISPOSITION:karaoke=0
DISPOSITION:forced=0
DISPOSITION:hearing_impaired=0
DISPOSITION:visual_impaired=0
DISPOSITION:clean_effects=0
DISPOSITION:attached_pic=0
[/STREAM]
[STREAM]
index=1
codec_name=mp2
codec_long_name=MP2 (MPEG audio layer 2)
profile=unknown
codec_type=audio
codec_time_base=1/48000
codec_tag_string=[0][0][0][0]
codec_tag=0x0000
sample_fmt=s16p
sample_rate=48000
channels=2
bits_per_sample=0
id=0x1c0
r_frame_rate=0/0
avg_frame_rate=0/0
time_base=1/90000
start_pts=20495
start_time=0.227722
duration_ts=422841600
duration=4698.240000
bit_rate=224000
nb_frames=N/A
nb_read_frames=N/A
nb_read_packets=N/A
DISPOSITION:default=0
DISPOSITION:dub=0
DISPOSITION:original=0
DISPOSITION:comment=0
DISPOSITION:lyrics=0
DISPOSITION:karaoke=0
DISPOSITION:forced=0
DISPOSITION:hearing_impaired=0
DISPOSITION:visual_impaired=0
DISPOSITION:clean_effects=0
DISPOSITION:attached_pic=0
[/STREAM]
[FORMAT]
filename=d:\flmsdvx\9MOISF~2.MPG
nb_streams=2
nb_programs=0
format_name=mpeg
format_long_name=MPEG-PS (MPEG-2 Program Stream)
start_time=0.220000
duration=4698.260000
size=7447717888
bit_rate=12681661
probe_score=52
[/FORMAT]


Voilà. J'espère que ça peut t'apporter des éclaircissements, parce qu'en ce qui me concerne...

Merci de ton aide
phyllox
 
Messages: 241
Inscription: 02 Fév 2009

Messagepar Subbat » Ven 10 Oct, 2014 17:20

Bah là ça va pas... ce n'est pas l'image de la vidéo dont tu as mis l'analyse qui est prise en entrée de du capture.bat...

L'analyse ffinfos est celle de la vidéo "d:\flmsdvx\9MOISF~2.MPG " et le capture.bat fait une capture image de la vidéo "j:\CIN~1\FREB4A~1.TS"

Mais à mon avis, tu as aussi un problème de déformation avec la vidéo "j:\CIN~1\FREB4A~1.TS" qui vient du fait comme je l'avais pensé, que c'est une vidéo anamorphosée... la vidéo fait 1440x1080 à laquelle on impose un ratio 16/9 pour qu'elle affiche un 1920x1080 (ou 1440x810... je sais plus...)

Il faudra donc je pense que pepsi modifie la routine de la capture pour le crop, en mettant le ratio dans la ligne de commande... mais je pense qu'en attendant, tu ne puisse pas faire grand chose...

A moins peut-être, il faudrait tester, mais un peu compliqué...

Quand tu veux faire un crop sur une vidéo...
1. tu charges ta vidéo dans m4ng, tu ouvres la fenêtre de crop... ton image sera déformée mais pas grave...
2. tu fermes cette fenêtre
3. tu vas dans le dossier de travail de m4ng et clic droit=>modifier sur le capture.bat
4. tu ajoutes juste avant le -y ce qui suit : -aspect 16:9 (ou 4:3 ou 2.35 etc en fonction de l'aspect ration que tu trouves dans l'analyse mediainfo ou ffinfo)
4. tu enregistres ce capture.bat et tu le lances (normalement l'image créée ($$$capture000000.bmp) aura le bon ratio)
5. tu fais un clic droit puis propriété sur l'image $$$capture000000.bmp et tu coches lecture seule...
6. tu rouvres la fenêtre de crop et là tu devrais avoir la bonne image... et ainsi pouvoir faire ton crop comme il faut...


Il faut penser ensuite à retourner décocher lecture seule dans les propriété de l'image $$$capture000000.bmp pour pouvoir faire les crop des vidéos suivante... et refaire tout ce processus à chaque fois...

Je n'ai pas testé mais ça devrait pouvoir le faire je pense...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8402
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar phyllox » Ven 10 Oct, 2014 18:34

Merci de ton retour

J'ai bien pris les deux infos ffinfos et capture.bat à la suite l'une de l'autre, avec le même film chargé dans m4ng v5.

Quant à la déformation... Mais

1°) Comment expliquer alors que la même vidéo soit lue correctement sur toutes les autres machines (2 physique et 1 virtuelle) où je les ai essayée ? Soit il y a un souci d'anamorphose pour tout le monde, soit pour personne... Pourquoi une machine y arriverait-elle et pas l'autre ?

2°) La vidéo que j'avais chargée ne fait pas 1440x1080. Il m'arrive d'utiliser ce format, mais pour le test, j'en avais pris une d'une autre source (une carte d'acquisition), configurée en 720P soit 180 x 720.

L'analyse ffinfos affiche le bon film, un .mpeg de 1280 x720. Pas l'analyse capture.bat. Mais j'ai lancé le fichier capture.bat sans rien faire avant, peut être fallait il faire une capture via le logiciel avant de lancer le .bat ?

Il est vrai que mes enregistrements télé sont anamorphosés et font 1440 x 1080. S'ils doivent s'afficher sur mon écran d'ordi ou de télé, alors oui, c'est du full HD.

J'ai peut être loupé une étape ? Je vais recommencer !

Merci encore de ton support.

Je vais recommencer.
phyllox
 
Messages: 241
Inscription: 02 Fév 2009

Messagepar Subbat » Ven 10 Oct, 2014 18:50

Oui, il fallait d'abord rouvrir la fenêtre de crop avec la vidéo chargée dans m4ng... c'est à ce moment là que le capture.bat est créé... donc si tu ne l'a pas fait, le capture.bat référence à la dernière vidéo utilisée pour le crop...

Pour répondre à ta 1ère question, tu as raison, j'avais oublié que ça marchait ailleurs...

Il me faut donc que tu refasses le test du capture.bat en copiant le contenu de la fenêtre dos en résultant mais à partir de la vidéo pour laquelle tu as ta déformation en 784 au lieu de 720...

On verra après...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8402
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar phyllox » Ven 10 Oct, 2014 18:58

Hello

Je pense que le résultat du capture.bat devrait être bon maintenant, il fallait juste que je trouve un moyen de faire une capture avec m4ng v5. C'est où Là j'y suis arrivé en capturant le pointeur de fin dans la fenêtre de crop.


C:\Users\Bureau\AppData\Roaming\m4ng>chcp 1252
Page de codes active : 1252

C:\Users\Bureau\AppData\Roaming\m4ng>C:\PROGRA~2\m4ng_v5\system\ffmpeg.exe -i "d
:\flmsdvx\9MOISF~2.MPG" -ss 00:00:20.000 -t 00:00:00.040 -y "C:\Users\Bureau\App
Data\Roaming\m4ng\$$$CAP~1.BMP"
ffmpeg version N-56749-g7057cc8 Copyright (c) 2000-2013 the FFmpeg developers
built on Sep 29 2013 18:04:55 with gcc 4.8.1 (GCC)
configuration: --disable-static --enable-shared --enable-gpl --enable-version3
--disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --ena
ble-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --e
nable-libcaca --enable-libfreetype --enable-libgsm --enable-libilbc --enable-lib
modplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrw
b --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinge
r --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --en
able-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis
--enable-libvpx --enable-libwavpack --enable-libx264 --enable-libxavs --enable-
libxvid --enable-zlib
libavutil 52. 46.100 / 52. 46.100
libavcodec 55. 33.101 / 55. 33.101
libavformat 55. 18.104 / 55. 18.104
libavdevice 55. 3.100 / 55. 3.100
libavfilter 3. 88.100 / 3. 88.100
libswscale 2. 5.100 / 2. 5.100
libswresample 0. 17.103 / 0. 17.103
libpostproc 52. 3.100 / 52. 3.100
Input #0, mpeg, from 'd:\flmsdvx\9MOISF~2.MPG':
Duration: 01:18:18.26, start: 0.220000, bitrate: 12681 kb/s
Stream #0:0[0x1e0]: Video: mpeg2video (High), yuv420p(tv), 1280x720 [SAR 1:1
DAR 16:9], max. 12288 kb/s, 50 fps, 50 tbr, 90k tbn, 100 tbc
Stream #0:1[0x1c0]: Audio: mp2, 48000 Hz, stereo, s16p, 224 kb/s
Output #0, image2, to 'C:\Users\Bureau\AppData\Roaming\m4ng\$$$CAP~1.BMP':
Metadata:
encoder : Lavf55.18.104
Stream #0:0: Video: bmp, bgr24, 1280x720 [SAR 1:1 DAR 16:9], q=2-31, 200 kb/
s, 90k tbn, 50 tbc
Stream mapping:
Stream #0:0 -> #0:0 (mpeg2video -> bmp)
Press [q] to stop, [?] for help
[image2 @ 00688300] Could not get frame filename number 2 from pattern 'C:\Users
\Bureau\AppData\Roaming\m4ng\$$$CAP~1.BMP' (either set updatefirst or use a patt
ern like %03d within the filename pattern)
av_interleaved_write_frame(): Invalid argument


C:\Users\Bureau\AppData\Roaming\m4ng>Pause
Appuyez sur une touche pour continuer...


Est-ce que ça t'en dit plus ?

Merci
phyllox
 
Messages: 241
Inscription: 02 Fév 2009

Suivante

Retourner vers m4ng V4

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité