[Résolu] Réencodage en X264 MP4 : impossible d'avancer dans le film

Modérateur: Modérateurs

Messagepar edhelas » Dim 24 Avr, 2011 17:12

J'ai lancé la conversion de mon mkv en audio seulement avec m4ng c'est un ptit peu long mais sa progresse j'att la fin et j'ai lancé yamb et de même sa progresse avec le mkv qui a cette fois bien reconnu mon fichier vidéo et audio en ac3 donc j'attends la fin et je te dis quoi.
edhelas
 
Messages: 16
Inscription: 22 Avr 2011

Messagepar edhelas » Dim 24 Avr, 2011 21:01

Alors Alors, il semblerais que le MP4 ai encore du mal avec le AC3 donc a chaque fois bug de Yamb a 99 % de la création du MP4. En revanche je peux récup mes fichiers .ac3 et .h264 mais le hic est que comme Yamb ne me les mux pas à cause du AC3 eh ben je peux pas remuxer donc je pense que la seule solution qu'il me reste est la conversion du AC3 en ACC mais en cb de temps :x
edhelas
 
Messages: 16
Inscription: 22 Avr 2011

Messagepar Subbat » Dim 24 Avr, 2011 21:43

Oh... normalement un ré-encodage audio, c'est vraiment pas très long... je dirais 10 min tout au plus...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8419
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar edhelas » Lun 25 Avr, 2011 10:56

Je test actuellement avec un DTS j'ai demux et j'ai réussi niquel la conversion DTS vers ACC là c'est en cours de remux sa n'a pas l'air de poser problème, j'attends tout de même la fin du mux.
Mais l'unique problème viendrais apparemment de la conversion AC3 vers ACC :x
edhelas
 
Messages: 16
Inscription: 22 Avr 2011

Messagepar edhelas » Lun 25 Avr, 2011 12:28

Alors là je pige plus rien j'ai un fichier MP4 qui passe et un autre non alors qu'ils ont exactement les mêmes caractéristique :O

Le fichier qui passe niquel :

Format : MPEG-4
Profil du format : Base Media
Identifiant du codec : isom
Taille du fichier : 2,55 Gio
Durée : 59mn 19s
Débit global moyen : 6 161 Kbps
Date d'encodage : UTC 2011-04-21 03:57:04
Date de marquage : UTC 2011-04-21 03:57:04

Vidéo
ID : 2
Format : AVC
Format/Info : Advanced Video Codec
Profil du format : High@L4.1
Paramètres du format, CABAC : Oui
Paramètres du format, RefFrames : 5 images
Identifiant du codec : avc1
Identifiant du codec/Info : Advanced Video Coding
Durée : 59mn 19s
Type de débit : Variable
Débit : 5 994 Kbps
Débit nominal : 6 500 Kbps
Débit maximum : 22,7 Mb/s
Largeur : 1 280 pixels
Hauteur : 720 pixels
Format à l'écran : 16/9
Type d'images/s : Constant
Images par seconde : 23,976 Im/s
Espace de couleurs : YUV
Sous-échantillonnage de la chrom : 4:2:0
Profondeur des couleurs : 8 bits
Type d'image : Progressif
Bits/(Pixel*Image) : 0.271
Taille du flux : 2,48 Gio (97%)
Bibliothèque utilisée : x264 core 93 r1542 5b86182
Paramètres d'encodage : cabac=1 / ref=5 / deblock=1:-1:-1 / analyse=0x3:0x113 / me=umh / subme=9 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=2 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=-2 / threads=12 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / wpredb=1 / wpredp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=2pass / mbtree=1 / bitrate=6500 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=1:1.00
Date d'encodage : UTC 2011-04-21 03:57:19
Date de marquage : UTC 2011-04-21 04:00:32

Audio
ID : 1
Format : AAC
Format/Info : Advanced Audio Codec
Profil du format : LC
Identifiant du codec : 40
Durée : 59mn 19s
Type de débit : Variable
Débit : 163 Kbps
Débit maximum : 229 Kbps
Canaux : 2 canaux
Position des cannaux : Front: L R
Echantillonnage : 48,0 KHz
Mode de compression : Avec perte
Taille du flux : 69,1 Mio (3%)
Date d'encodage : UTC 2011-04-21 03:57:04
Date de marquage : UTC 2011-04-21 04:00:32



Le fichier que je viens de faire qui n'est pas reconnu par la xboite :O
Format : MPEG-4
Profil du format : Base Media
Identifiant du codec : isom
Taille du fichier : 6,52 Gio
Durée : 2h 48mn
Débit global moyen : 5 542 Kbps
Date d'encodage : UTC 2011-04-24 09:33:23
Date de marquage : UTC 2011-04-24 09:33:23
Application utilisée : Yamb 2.1.0.0 [http://yamb.unite-video.com]

Vidéo
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Profil du format : High@L4.1
Paramètres du format, CABAC : Oui
Paramètres du format, RefFrames : 8 images
Identifiant du codec : avc1
Identifiant du codec/Info : Advanced Video Coding
Durée : 2h 48mn
Type de débit : Variable
Débit : 5 474 Kbps
Débit maximum : 15,4 Mb/s
Largeur : 1 280 pixels
Hauteur : 720 pixels
Format à l'écran : 16/9
Type d'images/s : Constant
Images par seconde : 23,976 Im/s
Espace de couleurs : YUV
Sous-échantillonnage de la chrom : 4:2:0
Profondeur des couleurs : 8 bits
Type d'image : Progressif
Bits/(Pixel*Image) : 0.248
Taille du flux : 6,44 Gio (99%)
Bibliothèque utilisée : x264 core 67 r1145M d2e1e1c
Paramètres d'encodage : cabac=1 / ref=8 / deblock=1:-3:-3 / analyse=0x3:0x113 / me=umh / subme=9 / psy_rd=0.9:0.0 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=-2 / threads=12 / nr=0 / decimate=0 / mbaff=0 / bframes=3 / b_pyramid=1 / b_adapt=2 / b_bias=0 / direct=1 / wpredb=1 / keyint=250 / keyint_min=25 / scenecut=40 / rc=2pass / bitrate=5474 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / vbv_maxrate=50000 / vbv_bufsize=50000 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:1.00
Date d'encodage : UTC 2011-04-24 09:33:23
Date de marquage : UTC 2011-04-24 09:47:32

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Profil du format : LC
Identifiant du codec : 40
Durée : 2h 48mn
Type de débit : Variable
Débit : 64,1 Kbps
Débit maximum : 89,0 Kbps
Canaux : 2 canaux
Position des cannaux : Front: L R
Echantillonnage : 48,0 KHz
Mode de compression : Avec perte
Taille du flux : 77,3 Mio (1%)
Date d'encodage : UTC 2011-04-24 09:47:21
Date de marquage : UTC 2011-04-24 09:47:32




Je commence à plus rien piger :O
edhelas
 
Messages: 16
Inscription: 22 Avr 2011

Messagepar Subbat » Lun 25 Avr, 2011 12:38

Disons qu'il se ressemble fortement, mais visiblement, ils n'ont pas été fait avec le même preset du x264 (cli)...

Celle qui ne passe passe pas, tu l'as ré-encodée, ou tu as juste remuxer un mkv dans un mp4 ?
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8419
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar edhelas » Lun 25 Avr, 2011 13:22

Celle qui ne passe pas je l'ai démuxer puis remuxer ;)
edhelas
 
Messages: 16
Inscription: 22 Avr 2011

Messagepar Subbat » Lun 25 Avr, 2011 13:29

Alors cela veut sans doute dire que le preset qui avait été utilisé pour l'encodage n'est pas compatible avec la xbox...

Je crains que tu ne sois obligé de devoir ré-encoder ton mkv donc...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8419
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar edhelas » Lun 25 Avr, 2011 13:41

Ce que je suis entrain de faire :x malheuresement je te redis quoi dans d'ici 6h je pense environ :)
Encore merci de ta présence et ton intéret
edhelas
 
Messages: 16
Inscription: 22 Avr 2011

Messagepar Subbat » Lun 25 Avr, 2011 13:46

You're welcome...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8419
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar edhelas » Mer 27 Avr, 2011 18:41

Alors Alors, après encodage complet (plus de 10 h :x) ma vidéo qui est sorti au bout passe niquel sur ma xbox360 donc je suis passé si je me souviens bien (je n'ai pas sous la main) d'un MKV avec x264 (vidéo) et DCS (pour le son) vers MPEG-4 avec AVC (vidéo) et ACC (son), je tiens tout de même à signaler que le son de sortie n'est pas aussi bon que sur le MKV d'origine ;).

C'est pourquoi voulant profiter à fond de mes Films HD j'ai fait l'acquisition de ceci pour m'éviter les heures de conversions notamment.

Mais ce logiciel reste une très bonne alternative, je le garde sous la main pour toute les autres types de conversions.

Encore merci de ton aide et au final de la résolution de mes problèmes car je peux également enfin me balader sur la vidéo comme je veux sans bug ;)

Encore merci

Cordialement Edhelas
edhelas
 
Messages: 16
Inscription: 22 Avr 2011

Messagepar Underground78 » Mer 27 Avr, 2011 21:49

Y a un bug étrange avec ton message, le contenu est bien là mais il apparait pas ! En plus c'est contagieux, ça fait pareil si je te cite !

Edit : Ah c'était juste une erreur de balise BBCode qui avait bien mis le boxon ...
Avatar de l’utilisateur
Underground78
Administrateur
Administrateur
 
Messages: 11267
Inscription: 06 Fév 2007
Localisation: France

Messagepar Subbat » Mer 27 Avr, 2011 22:10

Ok... :yeap:
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8419
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Précédente

Retourner vers m4ng V2

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 17 invités