Reproduire le Même Résultat qu'une Team

Modérateur: Modérateurs

Reproduire le Même Résultat qu'une Team

Messagepar djp » Ven 28 Oct, 2011 19:04

Bonjour a tous :did:

J'ai déjà posté un sujet ici au niveau des passages fantômes des mangas a enlever.
Je me suis lancé sur des ripp de mangas depuis quelques temps et je voulais savoir comment les Team qui font des ripp arrivent a un telle résultat alors que moi j'essaie depuis plusieurs semaine, je n'arrive pas reproduire le même résultat, si quelqu’un pouvait m'aider a reproduire un peu près le même résultat et me dire quelques filtres utilisé pour donner un tel résultat pourrai m'aider pour mes prochains ripp de mangas.
Voici un bout du DVD et le résultat de la team de Ken Le Survivant, ce sont des DVD Japonais NTSC :
http://www.megaupload.com/?d=0WZIE7FJ

Sinon, j'ai aussi commencer a ripper les premier épisodes de Dragon Ball des DVD Français PAL,
j'ai obtenu un résultat qui me parait convenable mais je voudrais savoir s'il est possible d'améliorer le paysages,
au niveau du ciel et des petit parasites au contours des personnages. Voici un bout de ce que j'ai encodé http://www.megaupload.com/?d=KJIAZU7R
djp
 
Messages: 9
Inscription: 03 Sep 2011

Messagepar leon1789 » Sam 29 Oct, 2011 12:42

Je trouve que le mkv concernant ton extrait du 1er DVD Japonais est pas mal, mais un peu flou (certains arrière-plans sont même carrément délavés)...
Je suis en train de regarder ce que je peux proposer. Je reviens dès que j'ai quelque chose. ;)
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Subbat » Sam 29 Oct, 2011 13:43

Si je ne m'abuse, pour obtenir les résultats des team de fansub de série japonaise, tu as intérêt à avoir un PC qui tient la route, parce qu'il me semble qu'elles font appel à des scripts de "fou"...

Mais je ne suis pas du tout expert en script avisynth... leon1789 sera sans doute bien mieux te répondre que moi...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8441
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar leon1789 » Sam 29 Oct, 2011 18:44

C'est vrai que certains scripts font carrément exploser le temps de traitement...

Djp,
il y a parfois des différences importantes sur les couleurs entre ton mkv et ton vob, c'est bizarre.
Voilà ce à quoi j'arrive (essentiellement avec SoftSharpen après un désentrelacement) : http://www.megaupload.com/?d=B9QA21RR

image de ton mkv (avec une couleur étrange pour la moitié droite des cheveux) :


image de mon avi :



image de ton mkv :


image de mon avi :


On peut voir que l'image de ton mkv est rognée en bas.
Et puis je n'arrive pas à expliquer la différence de couleurs dans le ciel...

Voici le code
Code: Tout sélectionner
MPEG2Source("vts.d2v")
tdeint(mode=2).selectevery(5,1,2,4,5)                                   # pour désentrelacer
CropResizeBorder(larg=640,full=true,format=4/3.)                   # pour redimensionner en 4/3
SoftSharpen(preset="anim",line=20,debr=15,debl=10,gain=1,move=0)   # traitement de l'image
Dernière édition par leon1789 le Dim 30 Oct, 2011 20:27, édité 10 fois.
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar djp » Sam 29 Oct, 2011 22:29

Merci pour ta réponse Léon, je regarde cela demain et je te tient au courant
djp
 
Messages: 9
Inscription: 03 Sep 2011

Messagepar djp » Dim 30 Oct, 2011 14:33

Super le résultat Léon, c'est presque comparable a celle de la team :cart:
Par contre, on peut voir des traces de compression au niveau des contours des personnages,
pour la couleurs , je pense que c'est le fait qu'en a pas les même DVD JAP,
pourtant il affirme avoir encodé avec les même DVD que j'ai en ma possession. Je suis confus :roll:
Mais c'est n'est pas grave, je ferais avec, je vais essayer de faire mieux que le sien avec quelques retouches
pour voir ce que ça donne et je posterai mon résultat pour comparer avec le tien. :boss:
djp
 
Messages: 9
Inscription: 03 Sep 2011

Messagepar leon1789 » Dim 30 Oct, 2011 14:57

Il y a tellement de paramètres qui rentrent en jeu (le fichier source, temps de traitement, config du codec de compression...) qu'il n'y a que toi qui peut comparer "sur place".

PS. J'ai modifié un peu le réglage du codec : est-ce qu'on voit une différence ?? (cf message précédent http://www.forum.m4ng.fr/image-vp105833.html#105833)
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar djp » Dim 30 Oct, 2011 16:06

Alors voici mon dernier encodage après plusieurs essaie http://www.megaupload.com/?d=RFCX09DO :mrgreen:
Pour le deuxième encodage avec les réglages modifié, on peut voir que l'image saccade au
niveau des visages des personnages, donc le premier reste le meilleur. :yeap:
djp
 
Messages: 9
Inscription: 03 Sep 2011

Messagepar leon1789 » Dim 30 Oct, 2011 16:30

djp a écrit:Alors voici mon dernier encodage après plusieurs essaie http://www.megaupload.com/?d=RFCX09DO :mrgreen:


Pas mal, effectivement c'est propre ton essai, mais certaines lignes noires disparaissent.
Tu devrais rogner les colonnes extrêmes gauche et droite car elles sont "blanches".
Pourquoi fais-tu dans la haute définition alors que ta source est en définition standard ?
Tu as renforcé les couleurs ? Quel est ton code ?

djp a écrit:Pour le deuxième encodage avec les réglages modifié, on peut voir que l'image saccade au
niveau des visages des personnages

ha oui c'est vrai. Du coup, j'ai changé SangNom pour TDeint(mode=2) : le résultat est plus stable. (cf http://www.forum.m4ng.fr/ici-vp105833.html#105833)
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Underground78 » Lun 31 Oct, 2011 14:15

Si tu encodes avec le x264 n'oublie pas de passer le codec en mode "anime" dans son panneau de config.
Avatar de l’utilisateur
Underground78
Administrateur
Administrateur
 
Messages: 11267
Inscription: 06 Fév 2007
Localisation: France

Messagepar Subbat » Mar 17 Juil, 2012 19:28

Salut à tous...

Je me permets de rouvrir ce sujet pour si le coeur vous en dit, me conseiller les filtres à appliquer pour une série animée (Hakkenden)... Ci-après un lien vers un extrait d'un des vob originaux (1min20 que j'ai mis dans un mkv) : http://subbat.free.fr/VTS_01_1-002.mkv

J'ai fait un test avec softshapen (de leon) en preset anim + antialiasing + deblocking à 20

J'ai fait l'encode en x264 à 768kbps en 640x... (mais je ne mets pas en ligne l'encodage...)

Si vous avez des idées... je suis preneur...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8441
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar leon1789 » Mer 18 Juil, 2012 10:24

Salut !
Evidemment, j'ai regardé ce que je pouvais faire. Bon, comme d'habitude avec les mangas, il y a des images "doubles", c'est pénible. Et puis, il y a des gros blocs... argh.

Voilà à quoi je suis arrivé : http://leon1789.perso.sfr.fr/tmp/subbat.mkv
Bon, c'est pas transcendant... Il reste encore beaucoup de défauts, mais la source n'est pas vraiment au top :mrgreen:

Dis-moi s'il te convient ? Si oui, alors je donnerai le script, mais je ne veux pas que tu sois influencé par le script avant d'avoir vu le résultat. :yeap:
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Subbat » Mer 18 Juil, 2012 10:48

Je me doutais bien que tu ne résisterais pas à la tentation... Merci d'avoir fait des tests... Il faudra que je compare à ce que j'ai fait chez moi, mais j'ai l'impression qu'avec ce que j'avais fais, les gros blocs ont été mieux gérés chez moi... mais peut être au détriment d'autre chose... A la limite je posterais ce que j'ai fais si tu veux toi aussi comparer...

Je ne sais pas si en plus du script avs ça a pu jouer, mais j'ai choisis le x264 avec l'option "dessin animé"...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8441
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar leon1789 » Mer 18 Juil, 2012 11:28

Subbat a écrit:j'ai l'impression qu'avec ce que j'avais fais, les gros blocs ont été mieux gérés chez moi... mais peut être au détriment d'autre chose...

Exact, je n'ai pas tapé directement sur les blocs pour éviter un flou trop important. J'ai essayé de faire autrement, mais...

Subbat a écrit:A la limite je posterais ce que j'ai fais si tu veux toi aussi comparer...

Bien sûr.

Subbat a écrit:Je ne sais pas si en plus du script avs ça a pu jouer, mais j'ai choisis le x264 avec l'option "dessin animé"...

C'est vrai que le codec joue aussi un rôle.
Effectivement, je n'ai pas pris cette option de x264. Il y a aussi le débit qui joue évidemment.
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Subbat » Mer 18 Juil, 2012 11:59

Je suis venu faire un saut chez moi... j'ai pas trop le temps de comparer les 2 vidéos, et à vue de nez, j'arrive pas à vraiment me faire une idée, mais j'ai le sentiment que la mienne est meilleur avec un débit bien inférieur...

La voici : http://subbat.free.fr/hakkenden_test1.mkv

Mais effectivement, la source est vraiment crade...

Pour info, au niveau désentrelacement, j'ai utilisé yadif à la place de Dteint... Faudrait que je vois, mais je pense qu'il faudra que je joue sur l'affinage des lignes...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8441
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar leon1789 » Mer 18 Juil, 2012 14:20

Les débits, mais aussi les résolutions sont différentes, et la gestion des bandes noires.
Ton encodage est plus flou (image 100 par exemple).
En revanche, mon encodage contient beaucoup plus d'artéfacts que le tien (blocs, etc.).
J'ai essayé d'éliminer une partie des images "doubles" (blend), sans y arriver totalement.
Voici mon code (en mettant la vidéo en 640x480) :
Video = Video.CropResizeBorder(larg=640,haut=480,full=true,rightCut=1) #recadrage
Video = Video.SRestore(omode=2)
Video = Video.SoftSharpen(preset="anim",aa=true,debrT=8.2,sharp=28.8)

srestore est là pour éviter une partie des images "doubles", mais il n'y a pas de miracle. Je n'ai pas utilisé de deblocking car je trouve que ça floute trop la vidéo. J'ai essayé d'augmenter le débruitage temporel debrT=8.2 pour compenser (mais évidemment, cela n'a pas la même effet :) ). J'ai augmenté la netteté : on aime ou on aime pas.
Et puis le script est lent (l'option aa=true y est pour quelque chose).
Tu peux essayer de voir ce que tu peux en tirer...
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Subbat » Mer 18 Juil, 2012 15:41

Ok, merci, je regarderai ça de plus près... je ferais d'autres tests pour voir... Encore merci de t'être penché sur ce cas... :d:
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8441
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar leon1789 » Mer 18 Juil, 2012 16:58

De rien ! (c'est les vacances :D )
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Subbat » Mer 18 Juil, 2012 18:16

Je ne sais pas si ça a une incidence, mais quand on utilise le générateur de script softsharpen, ça ne met par les paramètres dans le même ordre que toi...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8441
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Subbat » Mer 18 Juil, 2012 18:21

Ah... autre question... pour les images doubles, tu vois ça comment ? Le désentrelacement c'est encore autre chose ?
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8441
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar leon1789 » Mer 18 Juil, 2012 18:55

Subbat a écrit:Ah... autre question... pour les images doubles, tu vois ça comment ? Le désentrelacement c'est encore autre chose ?

Oui, le désentrelacement est autre chose.
L'image "double" c'est cela :

Cela arrive quand on modifie le nombre d'images par seconde "comme un bourrin". Il est fort probable que ton manga soit initialement en 29.97 ips et que quelqu'un l'aie mis en 25 ips en mélangeant des images entre elles. D'où le résultat que tu vois.

Quand la vidéo est lue à vitesse normale (au moins 20 images par seconde), cela ne se voit pas en fait.
Pour le voir, il faut faire du image par image.


Dans les faits, c'est assez lié au désentrelacement car les films en 29.97 ips sont entrelacés (format ntsc) et lorsque on les désentrelace, on les remet très souvent en 25 ips ou 23.976... et c'est à ce moment là que les choses se gâtent si on est "bourrin". Le problème n'est pas tellement le désentrelacement, mais le changement de ips qui suit. Et une fois que les images sont mélangées, c'est très dur de les séparées !


Cela fait longtemps que je voudrais faire un script de détection et de "réparation" (d'autres l'ont fait, pourquoi pas moi ? :mad: ) , mais je m'y suis cassés les dents. Il suffit d'un message comme ça pour relancer la machine ;)
Dernière édition par leon1789 le Mer 18 Juil, 2012 19:01, édité 1 fois.
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Subbat » Mer 18 Juil, 2012 18:59

Ok, merci... Donc pour la vidéo en question, elle a donc des images doubles en plus d'être entrelacée... Parce que chez moi, si je ne mets pas de désentrelacement, j'ai un effet de peigne...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8441
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar leon1789 » Mer 18 Juil, 2012 19:03

Subbat a écrit:Ok, merci... Donc pour la vidéo en question, elle a donc des images doubles en plus d'être entrelacée... Parce que chez moi, si je ne mets pas de désentrelacement, j'ai un effet de peigne...

Ta vidéo source n'est plus entrelacée, mais effectivement elle a un effet de peigne (suite à un désentrelacement mal fait probablement) et elle a des images doubles (probablement suite à changement de fps "bourrin"). Pas gaté ! :mrgreen:
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Subbat » Mer 18 Juil, 2012 19:21

Bah écoute en fait, si je charge le .ifo, il y a un effet peigne important qui est bien visible...

Quand j'ai fait le mkv pour ne prendre qu'un court extrait du vob, sans que je ne touche à rien, le mkv s'est retrouvé en 50fps, que j'ai ensuite remuxé en 25fps avant de le mettre en ligne... Et sur l'un ou l'autre de ces mkv, je ne vois plus l'effet de peigne...

Il faudra que je teste un encodage à partir de l'ifo avec ou sans désentrelacement pour voir ce que ça donne... Mais je suis d'accord, c'est vraiement la cata de dvd... Ca semble assez fréquent sur les dvd des japanimations qui commence à dater...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8441
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar leon1789 » Mer 18 Juil, 2012 19:44

Subbat a écrit:Bah écoute en fait, si je charge le .ifo, il y a un effet peigne important qui est bien visible...

C'est un effet de peigne, pas un entrelacement ? Il y a-t-il des images doubles (pas forcément facile à voir quand il y a entrelacement...) ?

Subbat a écrit:Quand j'ai fait le mkv pour ne prendre qu'un court extrait du vob, sans que je ne touche à rien, le mkv s'est retrouvé en 50fps,

ok, ton source doit être en 25 ips , puis il doit y a voir un doublement de fréquence (bob, séparation de champs) et là, plus d'entrelacement ni de peigne.

Subbat a écrit:que j'ai ensuite remuxé en 25fps avant de le mettre en ligne... Et sur l'un ou l'autre de ces mkv, je ne vois plus l'effet de peigne...

Oui, et là justement, il n'y a pas apparition d'image double ? Sais-tu quelle commande est utilisée pour changer le fps ? (par exemple, en avisynth, il y a en 2 avec différentes options)

Subbat a écrit:Il faudra que je teste un encodage à partir de l'ifo avec ou sans désentrelacement pour voir ce que ça donne... Mais je suis d'accord, c'est vraiement la cata de dvd... Ca semble assez fréquent sur les dvd des japanimations qui commence à dater...

Si tu n'as pas peur de perdre du temps, tu peux poster le vob (ou un bout).
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Suivante

Retourner vers Scripts Avisynth

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité