SoftSharpen 8.8 - Script vidéo AviSynth

Modérateur: Modérateurs

Messagepar Subbat » Mer 01 Fév, 2012 10:20

Je ne sais pas si tu as vu mon MP... mais il y a 2 espaces insécables (&.nbsp;) de trop après chaque dernière vignette d'une même série de vignettes...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8294
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar leon1789 » Mer 01 Fév, 2012 19:04

salut,
effectivement, le MP m'avait échappé.

aujourd'hui, je n'ai pu avancer...

je vais mettre à jour en suivant ce que m'a dit :)
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Subbat » Mer 01 Fév, 2012 20:31

Euh... ce que je voulais dire, c'était de virer les espaces insécables que tu avais mis après la dernière vignette de chaque "groupe" de vignettes, mais pas ceux qui étaient entre 2 vignettes...

Je voyais la chose comme ça :

vignette1 espace espace vignette2

et chez toi ça donnait :

vignette1 espace espace vignette2 espace espace
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8294
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar leon1789 » Mer 01 Fév, 2012 20:52

okey !! :D ......done
j'en ai profité pour changer la place du "retour vers générateur"
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Subbat » Mer 01 Fév, 2012 22:16

:hop: sur un ecran de resolution inférieure à 1300px, la flèche se superpose au texte sur certains chapitres...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8294
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar leon1789 » Jeu 02 Fév, 2012 8:56

ah...... je remets la flèche comme avant :mad: http://leon1789.perso.sfr.fr/avisynth/S ... arpen.html
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Subbat » Jeu 02 Fév, 2012 17:26

Ok... En même temps, j'aime autant comme ça moi...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8294
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Subbat » Ven 03 Fév, 2012 21:47

Salut leon... une petite chose me "chagrinait" sur les écrans de moins de 1300px de résolution, à savoir qu'avec les images transparentes xxx_rvb.png, ça faisait un grand espace vierge un peu bizarre visuellement... Et je viens d'avoir une "illumination"... j'ai retaillée toutes ces images en 5px de hauteur... ce qui est tout de suite plus agréable (à mon sens)... Par contre, je ne sais pas ce que ça donne sur un écran de plus de 1300px... il n'y a pas de raison que ça dénature quoi que ce soit... mais au cas où, tu peux essayer pour voir ? c'est ici : http://subbat.free.fr/SoftSharpen/SoftSharpen.html

Si ça marche aussi chez toi et si tu le veux bien, les images retaillées sont ici : http://subbat.free.fr/SoftSharpen/images_png.zip


Par contre, je ne sais pas trop comment l'expliquer (le mieux serait que tu puisses tester sur un écran de moins de 1300px), mais il faudrait que le dernier chapitre soit un chapitre où il n'y ait pas d'image transparente associée à l'image source...

Voili, voila... :d:
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8294
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar leon1789 » Sam 04 Fév, 2012 8:55

Salut !
De mon coté, la mise en page est la même qu'avant, pas de problème.
Et j'ai placé gain_explain à la fin, comme ça, il n'y pas d'image transparente. http://leon1789.perso.sfr.fr/avisynth/S ... arpen.html

J'avoue que je n'avance pas sur les 3 dernières explications (banding, ringing, blocking) car je n'arrive pas à trouver d'image ayant les défauts à traiter.
Et puis je me suis mis à tester un autre debruiteur hqdn3D et faire des comparaisons... ca prend du temps (... surtout si on s'y prend mal dès le début ! :oups: )
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Subbat » Sam 04 Fév, 2012 11:23

Ca prendra le temps qu'il faut :yeap:
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8294
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar leon1789 » Mer 15 Fév, 2012 12:21

mise à jour 8.4 :
quelques modifs dans le code avisynth de softsharpen, notamment pour l'antialiasing
aide en ligne html (merci Subbat) qui n'est pas encore complètement terminée, mais ça pourra se faire tranquillement.
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Subbat » Mer 15 Fév, 2012 13:43

:d:
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8294
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Subbat » Mer 07 Mar, 2012 11:43

Tiens, j'avais pas vu que tu t'étais attaqué au deblocking... :d:

Il y a une petite faute dans la 1ère phrase... je pense que tu voulais dire "...les blocs disgracieux pouvant apparaître sur une vidéo." et non "pouvait"...

Sinon, côté css, il faudrait ajouter ce qui suit pour éviter les contour sur les images "liens" :

img{
border: none;
}

a:hover, a:visited, a:link{
outline:none;
}
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8294
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar leon1789 » Mer 07 Mar, 2012 19:02

Ok, c'est tout corrigé. :)
Merci !
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar leon1789 » Lun 30 Juil, 2012 18:43

Version 8.5 :

suite aux essais sur le manga de Subbat, je me suis remis à réfléchir sur le problème de blend (image mélangée) : comment le détecter et ensuite le corriger, et comment éliminer des images "figées" (deux images consécutives identiques) en réduisant le FPS.

J'y avais déjà réfléchi quelques fois, mais cette fois-ci, j'ai enfin pu conclure de manière très positive !

La correction du blend (nouvelle option blend dans softsharpen) n'est évidemment pas parfaite, mais fonctionne mieux que ce que j'ai pu obtenir avec srestore. Et je trouve que la réduction de FPS (nouvelle option fps dans softsharpen) fonctionne plutôt bien, évitant des images figées consécutives, sans réclamer plusieurs passes (cf. des fonctions genre DeDup).

Le seul souci (dont la raison m'échappe complètement) est que l'initialisation de la correction de blend demande un certain temps... mais une fois l'initialisation passée, les calculs de traitement se font relativement normalement.
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Subbat » Lun 30 Juil, 2012 19:35

Il faudra que je regarde ça alors... J'aurais peut-être alors une ou 2 questions sur le "comment ça marche"/"comment ça se paramètre"...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8294
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Subbat » Lun 30 Juil, 2012 19:49

Waw... et en plus c'est déjà intégré dans l'aide en ligne... merci leon... :d:
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8294
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar leon1789 » Lun 30 Juil, 2012 19:50

;)
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Subbat » Lun 30 Juil, 2012 20:09

Et la ligne import(...\softsharpen.avsi) a elle aussi été intégrée... :d:

Il ne reste donc plus que 2 fonctions à expliquer "deringing" et "debanding" c'est ça ? C'est quoi exactement les caractéristiques de ces "défauts"... Sait-on jamais si un jour je tombe sur une vidéo présentant ces défauts... je t'en filerait un extrait...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8294
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Subbat » Lun 30 Juil, 2012 20:19

Par contre, pour l'aide en ligne... pour l'option fps, la span class pour l'infobulle doit être "bulle2" et pas "bulle1", sinon, sur un écran 4/3, on a pas toute l'info bulle à l'écran...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8294
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar leon1789 » Lun 30 Juil, 2012 20:21

ok, c'est modifié !
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Subbat » Lun 30 Juil, 2012 20:31

Ok...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8294
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar ricou » Mar 31 Juil, 2012 1:03

Je viens m’incruster dans la conversation, non pas pour partager mes connaissances (trop faible), mais pour savoir comment tirer parti de votre travail. :)

Je vois qu'il y a plusieurs années que vous bosser sur la manière d'améliorer les vidéos et ça m’intéresse beaucoup. J'avoue ne pas avoir lu toutes les 15 pages de ce sujet, mais j'aimerais savoir comment nous (simples utilisateurs) pouvons utiliser les scripts que vous faites ? Ils sont intégrés à M4NG au fur et à mesure ?
ricou
 
Messages: 105
Inscription: 29 Juil 2012

Messagepar leon1789 » Mar 31 Juil, 2012 11:29

Le script n'est pas intégré à M4ng. Pour utiliser softsharpen, le plus simple est de décompresser le contenu du zip ( téléchargeable ici http://leon1789.perso.sfr.fr/avisynth/ ) dans le répertoire C:\Program Files (x86)\AviSynth 2.5\Plugins\ (mais on peut faire autrement).

Ensuite, c'est plutôt à la fin du script d'encodage qu'il faut placer une ligne de code, genre
video = video.SoftSharpen(preset="film", sharp=21.3, line=10.0)

Les options de softsharpen sont expliquées ici : http://leon1789.perso.sfr.fr/avisynth/S ... arpen.html
Cette page web permet de générer une ligne de code qu'il faut insérer dans le script d'encodage de M4ng (dans Prévisualisation, cliquer sur le bouton "Script AVS" / "éditer le script" ).

Exemple :
# **** m4ng & AVIsynth 2.5x script **** pass 2+

LoadPlugin("C:\PROGRA~2\m4ng_v3\system\undot.dll")
LoadPlugin("C:\PROGRA~2\m4ng_v3\system\FluxSmooth.dll")
LoadPlugin("C:\PROGRA~2\m4ng_v3\system\Convolution3D.dll")
LoadPlugin("C:\PROGRA~2\m4ng_v3\system\MaskTools.dll")
LoadPlugin("C:\PROGRA~2\m4ng_v3\system\MVTools.dll")
LoadPlugin("C:\PROGRA~2\m4ng_v3\system\Asharp.dll")
LoadPlugin("C:\PROGRA~2\m4ng_v3\system\MSharpen.dll")

Source="c:\videos\SEPTAN~1\SEPTAN~1.AVI"
Largeur=720
Hauteur=304
ratio =2.368421
vratio =2.368421
real_l=720
real_l4=720
Crop_g=0
Crop_d=0
Crop_h=0
Crop_b=0
Borders_g=0
Borders_d=0
Borders_h=0
Borders_b=0
Indice=0.114218

Video=DirectShowSource( Source, fps=25.000000).DelayAudio(0.000000)
Video=ConvertToYV12(Video)
Video=BilinearResize(Video, Largeur, Hauteur)

video = video.SoftSharpen(preset="film", sharp=21.3, line=10.0)

Return(AssumeFrameBased(Video))
Avatar de l’utilisateur
leon1789
 
Messages: 775
Inscription: 26 Aoû 2007

Messagepar Subbat » Mar 31 Juil, 2012 11:36

@leon : Et en mettant les dll et le avsi de softsharpen on a pas besoin d'ajouter les loadplugin des dll et l'import de l'avsi ?
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8294
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

PrécédenteSuivante

Retourner vers Scripts Avisynth

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités