[Résolu] Sous titres non voulus

Modérateur: Modérateurs

Sous titres non voulus

Messagepar Resiliator » Dim 26 Fév, 2012 20:21

Bonjour à tous,

j'ai un petit problème pas banal que je n'arrive pas à résoudre alors j'aurais besoin de vos conseils les amis.

Voilà, j'ai un film MKV de 8 Go que je voudrais réencoder (toujours en MKV et en x264 : Divx Plus HD)
pour qu'il ne fasse plus que 1.5 Go.

Au niveau encodage, aucun souci et j'obtiens mon fichier qui est impeccable.

Le seul souci c'est que j'ai les sous titres qui apparaissent (apparemment incrustés) tout au long du film alors que je n'ai jamais voulu les mettre.

Après un autre essai, c'est pareil et j'ai remarqué qu'ils apparaissent aussi dans la prévisualisation.

Quelqu'un aurait une idée de la manière d'empêcher cela ?

Je précise que dans mon fichier final, je ne veux aucun sous titres.

Merci à tous pour vos conseils.
Resiliator
 
Messages: 21
Inscription: 26 Fév 2012

Messagepar elcascador972 » Dim 26 Fév, 2012 20:39

Salut !

Essayes déjà de regarder dans la page principale de m4ng si tu n'as pas sélectionné sans le faire exprès ou non, l'incrustation des sous-titres.

Pour cela, quand tu as chargé ta vidéo à réencoder, tu cliques sur la clé à molette à droite de "chemin des sous titres" et tu décoches (si c'est coché !) "incruster les sous-titres sélectionnés" et/ou "incruster automatiquement les sous-titres détectés" et/ou "ajouter les sous-titres au fichier mkv". Bref tout ce qui ressemble à de l'incrustation de pres ou de loin !

Un passage dans la prévisualisation te permettra ensuite de voir si la manip' a fonctionné !
Quand le sage montre la lune, le fou regarde le doigt
Avatar de l’utilisateur
elcascador972
 
Messages: 402
Inscription: 13 Mai 2011
Localisation: 14° 46' 57'' Nord / 60° 59' 37'' Ouest

Messagepar misterd » Dim 26 Fév, 2012 20:42

salut,
on dirait que tes sous-titres sont déjà incrustés dans l'original, à vérifier dans le mkv d' origine s' ils sont séparés avec Mme. Sinon vérifie que l'option "incrustrer les sous-titres" ne soit pas sélectionnées.
Avatar de l’utilisateur
misterd
 
Messages: 481
Inscription: 24 Oct 2007

Messagepar elcascador972 » Dim 26 Fév, 2012 20:46

misterd a écrit:salut,
on dirait que tes sous-titres sont déjà incrustés dans l'original, à vérifier dans le mkv d' origine s' ils sont séparés avec Mme.

Effectivement, ta précision est utile :yeap: ! Et si c'est déjà incrusté dans le flux vidéo d'origine, bah me semble bien qu'il ne reste plus qu'à pleurer ! Si c'est effectivement une piste distincte dans le mkv d'origine, il devrait par contre pouvoir sans sortir sans difficulté :d: !
Quand le sage montre la lune, le fou regarde le doigt
Avatar de l’utilisateur
elcascador972
 
Messages: 402
Inscription: 13 Mai 2011
Localisation: 14° 46' 57'' Nord / 60° 59' 37'' Ouest

Messagepar Resiliator » Mar 28 Fév, 2012 6:50

Tout d'abord merci de m'avoir répondu.

Alors j'ai vérifié tout cela, la case "incruster automatiquement les sous titres" n'est pas cochée, aussi bien dans la page principale (la clef) que dans le menu paramètres.

Lorsque je lis le fichier MKV original, les sous titres apparaissent effectivement mais si je vais dans "Vidéo -> Pistes de sous-titres" et que je fais "Désactiver", ils n'y sont plus donc ils ne sont pas incrustés dans l'original.

Donc c'est vraiment bizarre tout cela. Je ne sais plus ou chercher.

Si je charge tout simplement le film et que je choisis x264, les sous titres apparaissent toujours dans la prévisu.
Resiliator
 
Messages: 21
Inscription: 26 Fév 2012

Messagepar misterd » Mar 28 Fév, 2012 7:59

tu ouvres ton mkv avec mkvmerge, décoches les sous-titres et cliques "demarrer le multipexage". Tu auras un mkv sans sous-titres que tu pourras réencoder.
Avatar de l’utilisateur
misterd
 
Messages: 481
Inscription: 24 Oct 2007

Messagepar Subbat » Mar 28 Fév, 2012 10:48

Moi je dirais que ffdshow est réglé pour décoder les sous titres... en decochant la fonction dans les paramètres de ffdshow... ca devrait régler ton problème...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8360
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar Resiliator » Jeu 01 Mar, 2012 6:45

j'ai essayé ce que tu as dit misterd et ça a marché.

Quand à ffdshow, j'ai essayé mais ça ne marche pas.

Merci à tous pour votre aide.
Resiliator
 
Messages: 21
Inscription: 26 Fév 2012


Retourner vers Sous-titres

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités