Temps d'encodage

Les questions des débutants ...

Modérateur: Modérateurs

Temps d'encodage

Messagepar shmft1 » Ven 12 Fév, 2016 16:49

Bonjour, je suis nouvel utilisateur de m4ng. J'utilise la v5.
J'ai encodé un dvd sur lequel était enregistré un film: enregistrement TV sur mon graveur de DVD (Philips). Le résultat est un fichier AVI de 839 Mo. Le film a une durée de 1h50 et l'encodage a duré plus de ..... 21 heures !! Est-ce normal?
Remarque: avec le précédant encodeur (RIAM) ceci me prenait en tout et pour tout 45 minutes pour un film de 1h45 en moyenne.

Voici le contenu du log:
11/02 17:50:40 *** m4ng [ 5.0.0.485 #42 - [exp 31/12/15] ]
11/02 17:50:40 *** shutdown_off ***
11/02 17:50:40 =============================
11/02 17:50:40 1 Conversion(s) -- m4ng v5
11/02 17:50:40 =============================
11/02 17:50:40 01 : vts_01_0.ifo
11/02 17:50:40 =============================
11/02 17:50:40 01/01 - conversion : vts_01_0.ifo
11/02 17:50:40 DVD VR_#0.avi
11/02 17:50:41 Encodage en cours :: Passe 1/2
11/02 19:16:18 Encodage en cours :: Passe 2/2
12/02 15:18:29 conversion OK
12/02 15:18:29 ==========
12/02 15:18:29 ---


Il doit sûrement y avoir un mauvais réglage que je n'ai pas encore vu. J'ai utilisé les configurations "Encodeur Interne (Autonome)" et "Mode simplifié". J'ai 3 disques durs sur ma machine et d'habitude je choisis des disques différents entre le dossier des fichiers dvd décryptés, le dossier de travail et le dossier du résultat final. Je n'ai pas encore trouvé comment effectué ce réglage avec m4ng.
Merci de votre aide.
crdlt
shmft1
 
Messages: 5
Inscription: 11 Fév 2016

Messagepar Subbat » Sam 13 Fév, 2016 11:46

Salut, et :welc sur le forum

C'est effectivement très étrange cette durée d'encodage, qui plus est avec le mode autonome qui n'a que faire des codecs et autres choses installés sur ton PC...

Tu as essayé avec un autre DVD pour voir ?
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8417
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar shmft1 » Sam 13 Fév, 2016 12:35

Bonjour,
Merci pour la réponse.
C'est en cours: j'ai pris un tout petit enregistrement au format DVD. J'attends le déroulement et je te tiens au courant.
Petite question pour un néophyte: pourquoi y-a-t-il plusieurs titres (4 dans le cas présent) dans un DVD sur lequel j'ai enregistré mon film, alors qu'il était vierge au début de l'enregistrement? Merci.
crdlt
shmft1
 
Messages: 5
Inscription: 11 Fév 2016

Messagepar Subbat » Sam 13 Fév, 2016 16:33

Plusieurs titres ? C'est à dire ?
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8417
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar shmft1 » Sam 13 Fév, 2016 17:31

c-à-d que lorsque j'insère mon DVD, il est ouvert par Windows Media et sa structure est la suivante:
- titre 1: contient 23 chapitres
- titre 2: contient 1 chapitre
- titre 3: contient 23 chapitres
- titre 4: contient 1 chapitre
Je retrouve la même structure lorsque je lance DVD Decrypter; en version anglaise: 4 PGC (titre) et le même nombre de Chapter (chapitre). Je ne sélectionne et décrypte que le titre 1 et j'obtiens tout le film sur disque.
Par lecture successives, titres 1 et 3 contiennent les mêmes chapitres ainsi que titres 2 et 4.
Alors à quoi servent les titres 2, 3 et 4?

2ème test: l'encodage d'un film de 50 minutes a mis 2h30 (habituellement 1 H environ avec RIAM sur la même machine).

Question subsidiaire: comment fixer le paramètre du fichier output sur le format: 4/3, 16-9 ou Cinemascope?
J'ai encodé un film enregistré en 16-9 et je crois que le résultat est au format 4/3 javascript:emoticon(':grr:'). Pas beau à voir (têtes allongées).
Merci.
Crdlt
shmft1
 
Messages: 5
Inscription: 11 Fév 2016

Messagepar Subbat » Sam 13 Fév, 2016 18:00

Je ne sais pas du tout a quoi servent la multitude fe titre mais ça, ça vient de ton enregistreur...

Pour ce qui est de la durée d encodage, c'est étrange cette lenteur... Tu peux essayer en mode non autonome pour voir la durée ? Par contre tu peux aussi essayer d enregistrer quelque chose de seulement 2 ou 3 minutes...

Pour le format de sortie 16/9 je ne sais plus si on peut gerer ce paramètre en mode simple... Il faudrait que je vérifie...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8417
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar shmft1 » Sam 13 Fév, 2016 22:24

Bonsoir,
En attendant de faire un test avec une vidéo courte, j'ai réinstallé RIAM et la vidéo de 1h50 qui a été encodée en 22 heures avec m4ng a été encodée en 31minutes! Donc cela ne vient pas de la vidéo mais sûrement d'un mauvais paramétrage de ma part.
A suivre....
crdlt

Update: une vidéo de qques minutes est en cours d'encodage. Il me semble que la passe 1 sur 2 de l'encodage (avec une fenêtre de commande ouverte) est TRES lente par rapport à la même sur RIAM. Déja plus de 5 minutes de traitement pour une vidéo d'environ 3 minutes.
shmft1
 
Messages: 5
Inscription: 11 Fév 2016

Messagepar shmft1 » Sam 13 Fév, 2016 23:17

Enfin terminé!
Voici le résultat:
- vidéo de 5mn 01s
- encodage: 9 minutes
- taille fichier initial (.vob) 186Mo
- taille fichier final (.avi) 132 Mo

Il y a un message d'erreur dans la fenêtre cmd dès le début du traitement d'encodage, mais qui n'a pas empêché la tache d'aller jusqu'au bout:
-------------------------------------------------------------------------------------------------------------------
[ac3 @ 017b3D80] frame sync error
error while decoding stream #0:2: Invalid data found when processing input

[libmp3 lane .....] Queue input is backward in time

-------------------------------------------------------------------------------------------------------------------


:grr: et toujours un output avec un format 4/3 alors que l'original était en 16/9ème !

crdlt
shmft1
 
Messages: 5
Inscription: 11 Fév 2016

Messagepar Subbat » Dim 14 Fév, 2016 1:08

Tu as encodé en mode autonome ou non autonome... parce que sur Ri4m il n'y avait pas le mode autonome...

Je dirais que pour l'instant tu es en mode autonome donc il faudrait tester en mode non autonome pour voir...
Image
Image Image
Avatar de l’utilisateur
Subbat
Administrateur
Administrateur
 
Messages: 8417
Inscription: 11 Déc 2008
Localisation: Quelque part... dans le centre de la France...

Messagepar pepsilite » Lun 15 Fév, 2016 13:26

Salut à toi
Le message d'erreur indique que l'enregistrement original a eu un problème avec le son AC3, il manque des informations et ça provoque un décrochage dans la continuité.
Vu le message d'erreur, tu sembles être en mode autonome (encodeur interne), comme le dit Subbat au dessus, essaye en mode "non autonome" et là tu seras dans les mêmes conditions qu'avec "l’ancêtre" (dont je refuse d'écrire le nom)... Va aussi vérifier dans la prévisualisation si l'image est déformée ou pas.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22999
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...


Retourner vers Premiers pas

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 5 invités