Ts vers Mpg finalisé

Fusion des anciens forums encodage et re-encodage

Modérateur: Modérateurs

Ts vers Mpg finalisé

Messagepar Dr Cat » Mar 15 Déc, 2009 12:47

Bon, après des déconvenues pour passer de VOB à du avi, je me lance maintenant dans le réencodage d'une émission TV. :d:

Dans un premier temps, j'ai converti sans problème mon fichier TS en mpg.
Je choisis ensuite "Ré-encodage (expert)".
Là, après avoir sélectionné ma vidéo, je choisis mp2 (format d'origine du son, ne voyant pas à priori l'intérêt de le convertir en mp3) et 128.

Mon souci intervient à l'étape "vidéo". Je choisis du Xvid. Hélas, je n'ai ensuite accès qu'à la case "MKV", les cinq autres étant grisées. Que faire pour laisser la vidéo en mpg (facilement lisible par les lecteurs de salon), au niveau du format de sortie ?.

En outre, dans "Prévisualisation", la vidéo n'apparait pas dans la fenêtre centrale.


L'analyse avec Médiainfo est la suivante:
General

Complete name : d:\dvdrip\aaaa.mpg

Format : MPEG-PS

File size : 3.03 GiB

Duration : 2h 9mn

Overall bit rate : 3 337 Kbps



Video

ID : 224 (0xE0)

Format : MPEG Video

Format version : Version 2

Format profile : Main@Main

Format settings, Matrix : Default

Duration : 2h 9mn

Bit rate mode : Constant

Bit rate : 2 914 Kbps

Nominal bit rate : 3 100 Kbps

Width : 720 pixels

Height : 576 pixels

Display aspect ratio : 16/9

Frame rate : 25.000 fps

Standard : PAL

Colorimetry : 4:2:0

Scan type : Interlaced

Scan order : Top Field First

Bits/(Pixel*Frame) : 0.299



Audio

ID : 192 (0xC0)

Format : MPEG Audio

Format version : Version 1

Format profile : Layer 2

Duration : 2h 9mn

Bit rate mode : Constant

Bit rate : 192 Kbps

Channel(s) : 2 channels

Sampling rate : 48.0 KHz

Resolution : 16 bits

Video delay : -248ms



A noter aussi que lorsque, je vais dans "Couper vidéo", après avoir sélectionné ma vidéo source, tout reste grisé, alors que la taille du fichier est la bonne.

J'ai aussi remarqué que ma vidéo TS fait 3,13 Go, alors qu'après conversion, ma vidéo mpg fait 3,02 Go. Mais je suppose que c'est normal, puisque je peux lire les deux sans aucun problème avec VLC.

Merci d'avance pour vos conseils.
Dr Cat
 
Messages: 89
Inscription: 09 Mai 2008

Messagepar pepsilite » Mar 15 Déc, 2009 13:45

déjà, tu es en v1 ou v2?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22999
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Puppet » Mar 15 Déc, 2009 14:18

Pourquoi passer d'un TS a un MPG ? o_O""
Image
Avatar de l’utilisateur
Puppet
Modérateur
Modérateur
 
Messages: 5855
Inscription: 03 Fév 2007
Localisation: Arcueil

Messagepar Dr Cat » Mar 15 Déc, 2009 14:22

Toujours en v1 (puisque la fenêtre prévisualisation de la v2 plante m4ng sous mon Vista ---- bref, je ne vais pas réexpliquer ce souci).
Dr Cat
 
Messages: 89
Inscription: 09 Mai 2008

Messagepar pepsilite » Mar 15 Déc, 2009 15:07

1. si tu choisis du son MP2, le SEUL conteneur qui l'accepte est le MKV.
2. convertir du mp2 en mp2 est un non sens, le mp2 est bien moins performant que le mp3 et la conversion entrainera des pertes. si tu veux un autre conteneur de sortie que le MKV, il faut réencoder en MP3
3. si tu n'as aucune image dans la prévisualisation c'est qu'il manque quelque chose pour décoder dans windows.
4. la prévisualisation "plante" en v2 à priori avec une source DVD pour laquelle on demande un boost, le problème n'existe (normalement) pas pour les autres types de sources.
5. s'il s'avère bien que c'est le boost qui fait planter la prévisualisation en encodage de vob, ne le demande pas et fais-le en manu une fois la vidéo réencodée, un simple remux et le tour est joué.
6. la v1 et la v2 peuvent très bien cohabiter pour peu qu'elles soient installées dans 2 dossiers différents, je ne saurais que trop te conseiller d'installer ladite v2 et de faire un test direct avec ton .TS, il y a de grandes chances que ça marche direct.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22999
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...

Messagepar Dr Cat » Mer 16 Déc, 2009 3:08

OK, merci pour toutes tes indications.
J'essaye tout cela, probablement pas avant jeudi ou vendredi, et je te tiens au courant.
Dr Cat
 
Messages: 89
Inscription: 09 Mai 2008

Messagepar Dr Cat » Lun 21 Déc, 2009 17:49

6. la v1 et la v2 peuvent très bien cohabiter pour peu qu'elles soient installées dans 2 dossiers différents, je ne saurais que trop te conseiller d'installer ladite v2 et de faire un test direct avec ton .TS, il y a de grandes chances que ça marche direct.

Ce que j'ai fait, et à priori ça a parfaitement fonctionné. J'ai vu le résultat sur le PC très rapidement, et je jetterai un œil ce soir sur la TV. Merci !

3. si tu n'as aucune image dans la prévisualisation c'est qu'il manque quelque chose pour décoder dans windows.

Effectivement, je n'ai plus la prévisualisation de l'image, ni dans la v1.4, ni dans la v2.
La fenêtre est toujours active, puisque je peux choisir les nombreuses options (désentrelacement, taille, etc...), mais je n'ai plus le rendu visuel, ce qui rend notamment le positionnement des sous-titres problématique.

Bizarre, surtout que l'affichage a brutalement disparu (et puis, je n'ai rien installé récemment).
Et je n'avais jamais eu de problème avec ça.
Dr Cat
 
Messages: 89
Inscription: 09 Mai 2008

Messagepar BiGf0oT » Lun 21 Déc, 2009 18:01

comme tu traites un .ts as tu essayé de reinstaller dans le pack de codecs : MKV + MP4 Splitter
Proverbe Chien : Si ça ne se mange pas, Si ça ne se baise bas, Pisse dessus !
Avatar de l’utilisateur
BiGf0oT
Administrateur
Administrateur
 
Messages: 6072
Inscription: 03 Fév 2007
Localisation: Dans ma grotte

Messagepar Dr Cat » Jeu 24 Déc, 2009 15:14

comme tu traites un .ts as tu essayé de reinstaller dans le pack de codecs : MKV + MP4 Splitter

BiGf0oT, petite question d'un néophyte : Quelle serait, pour moi, l'intérêt d'installer du mkv, alors que je désire au final avoir du avi ?

Sinon, après vérification, mon premier encodage ts en avi est parfait. Merci à tous.


Effectivement, je n'ai plus la prévisualisation de l'image, ni dans la v1.4, ni dans la v2.
La fenêtre est toujours active, puisque je peux choisir les nombreuses options (désentrelacement, taille, etc...), mais je n'ai plus le rendu visuel, ce qui rend notamment le positionnement des sous-titres problématique.

Quelqu'un a-t'il une idée, d'où pourrait venir ce problème. Dois-je modifier, voire réinstaller certains éléments ?

En attendant, je vous souhaite à tous un Joyeux Noël !!
Dr Cat
 
Messages: 89
Inscription: 09 Mai 2008

Messagepar pepsilite » Jeu 24 Déc, 2009 15:37

le MKV + MP4 splitter est une sorte de couteau suisse qui sert à beaucoup de choses, notamment à ouvrir bon nombre de formats autres que le MKV et MP4...
Si tu n'as pas d'image, ça peut justement venir du splitter mal installé.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar de l’utilisateur
pepsilite
The Grinch
The Grinch
 
Messages: 22999
Inscription: 03 Fév 2007
Localisation: Chez moi le plus possible ...


Retourner vers m4ng V1

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités