Un nouveau codec : le V-P-8

News, infos diverses ...

Modérateur: Modérateurs

Messagepar Seb007 » Mer 07 Mar, 2012 22:29

Alors en fait le fichier provenait ce matin de http://www.youtube.com/watch?v=ekpOjRNed5w
Il ne m'etait proposé qu'en format Webm... Et la ce soir j'ai le format H264 comme d'hab !
Donc je n'y comprends plus rien mais via Keepvid, on retrouve le lien du Webm 720p de 17,7 Mo ;)
http://keepvid.com/?url=http%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DekpOjRNed5w

Enfin bref, pour le plaisir, ça serait bien d'essayer de résoudre le mystère de la conversion :d:
Avatar de l’utilisateur
 
Messages: 12
Inscription: 07 Mar 2012

Messagepar Underground78 » Jeu 08 Mar, 2012 10:33

Je pense qu'il n'y a pas grand chose à faire ... Le webm est un dérivé du MKV donc comme pour le MKV l'information sur le débit d'images est juste indicative. Ici elle n'est probablement même pas renseignée et MediaInfo considère que c'est 1000 fps (peut-être parce que la norme indique que c'est la valeur par défaut je ne sais pas). La lecture du fichier montre que le débit d'images réel est 25 fps (ce qui est logique pour un spot TV), il faut donc forcer ce débit d'images dans m4ng pour pouvoir réencoder ce fichier. Il y a également possibilité de remuxer le fichier en mkv par exemple en indiquant un débit d'images de 25 fps ce qui revient au même.
Avatar de l’utilisateur
Administrateur
Administrateur
 
Messages: 11265
Inscription: 06 Fév 2007
Localisation: France

Messagepar Seb007 » Jeu 08 Mar, 2012 21:11

Bin quand j'avais essayé de le convertir, j'avais une erreur d'Avisynth de VirtualDub, donc je ne sais pas.
Par contre oui je n'ai pas essayé le remuxage en MKV ;)
Avatar de l’utilisateur
 
Messages: 12
Inscription: 07 Mar 2012

Messagepar Underground78 » Jeu 08 Mar, 2012 21:20

Seb007 a écrit:Bin quand j'avais essayé de le convertir, j'avais une erreur d'Avisynth de VirtualDub, donc je ne sais pas.
Par contre oui je n'ai pas essayé le remuxage en MKV ;)

L'erreur AviSynth ça peut être autre chose, essaie d'ouvrir la prévisualisation pour voir le message d'erreur exact. Il y a des chances que tu n'ais pas le bon décodeur. Il faudrait par exemple configurer ffdshow pour prendre en charge le décodeur du VP8.
Avatar de l’utilisateur
Administrateur
Administrateur
 
Messages: 11265
Inscription: 06 Fév 2007
Localisation: France

Messagepar elcascador972 » Mar 13 Mar, 2012 20:52

Underground78 a écrit:L'erreur AviSynth ça peut être autre chose, essaie d'ouvrir la prévisualisation pour voir le message d'erreur exact. Il y a des chances que tu n'ais pas le bon décodeur. Il faudrait par exemple configurer ffdshow pour prendre en charge le décodeur du VP8.

Salut ! Au début du topic, Pepsi disait effectivement qu'en dehors de MPC HD, il fallait un filtre DirectShow pour le lire et il donnait un lien.

Car j'ai aussi un soucis avec une vidéo de format WebM (mais qui porte curieusement une extension .mp4) avec VP8.
General
Complete name : c:\films_rippes\voisins.mp4
Format : WebM
File size : 5.61 MiB
Duration : 1mn 3s
Overall bit rate : 738 Kbps
Writing application : google
Writing library : google

Video
ID : 1
Format : VP8
Codec ID : V_VP8
Duration : 1mn 3s
Bit rate : 572 Kbps
Width : 638 pixels
Height : 360 pixels
Display aspect ratio : 16:9
Frame rate : 1 000.000 fps
Compression mode : Lossy
Bits/(Pixel*Frame) : 0.002
Stream size : 4.34 MiB (77%)
Language : English / English

Audio
ID : 2
Format : Vorbis
Format settings, Floor : 1
Codec ID : A_VORBIS
Duration : 1mn 3s
Bit rate : 128 Kbps
Channel(s) : 2 channels
Sampling rate : 44.1 KHz
Compression mode : Lossy
Stream size : 996 KiB (17%)
Language : English


Et avant que j'installe ce filtre, j'avais l'erreur ci-dessous dans la prévisualisation de m4ng :



Après installation du filtre, la prévisualisation affiche la 1ère image et lit normalement l'audio, mais pas plus que ça...Il doit effectivement falloir configurer ffdshow ...
Quand le sage montre la lune, le fou regarde le doigt
Avatar de l’utilisateur
 
Messages: 402
Inscription: 14 Mai 2011
Localisation: 14° 46' 57'' Nord / 60° 59' 37'' Ouest

Messagepar Underground78 » Mar 13 Mar, 2012 21:04

Essaie de configurer ffdshow pour décoder le VP8 à place d'utiliser l'autre filtre pour voir.
Avatar de l’utilisateur
Administrateur
Administrateur
 
Messages: 11265
Inscription: 06 Fév 2007
Localisation: France

Messagepar elcascador972 » Mar 13 Mar, 2012 21:26

Bah j'ai mis le VP8 sur "libavcodec", fait "appliquer" et "ok" mais pas mieux.



Si je force le fps à 25, c'est même pire...même plus de lecture du son... :kes:

Du coup, j'ai essayé de démuxer mais non (même avec Yamb), ça plante. Mais un fichier.raw apparait dans le log : le flux vidéo ???



Après j'ai tenté de réencoder vidéo (en x264) et audio (en AC3) séparément puis de multiplexer le tout et bien, alors que les réencodages séparés n'avaient annoncés aucun soucis, après lecture du fichier obtenu, la vidéo est tjs calée sur la 1ère image :bad:
Quand le sage montre la lune, le fou regarde le doigt
Avatar de l’utilisateur
 
Messages: 402
Inscription: 14 Mai 2011
Localisation: 14° 46' 57'' Nord / 60° 59' 37'' Ouest

Messagepar Underground78 » Mar 13 Mar, 2012 23:58

Tu as essayé d'utiliser ffmpegsource dans les options de la prévisualisation ?
Avatar de l’utilisateur
Administrateur
Administrateur
 
Messages: 11265
Inscription: 06 Fév 2007
Localisation: France

Messagepar elcascador972 » Mer 14 Mar, 2012 0:42

Oui mais c'est pire...

Pour résumé, en chargeant juste la vidéo source dans m4ng puis en allant dans la prévisualisation, j'obtiens la 1ère image figée avec le son qui est lu normalement :



Si je passe à FFmpegsource dans la prévisualisation, j'ai le message d'erreur suvant :



La vidéo source, elle, est lue tout à fait normalement dans VLC, et ceci depuis le début, même bien avant que j'installe le filtre directshow et l'encodeur en VP8... :cry: Je vais tenter de réinstaller le filtre, des fois que le téléchargement du filtre et son installation se soient mal passées...
Quand le sage montre la lune, le fou regarde le doigt
Avatar de l’utilisateur
 
Messages: 402
Inscription: 14 Mai 2011
Localisation: 14° 46' 57'' Nord / 60° 59' 37'' Ouest

Messagepar Underground78 » Mer 14 Mar, 2012 1:23

VLC n'utilise pas les filtres DirectShow mais ces propres filtres embarqués donc c'est logique. Tu as essayé de remuxer le fichier que tu as dans un mkv ?
Avatar de l’utilisateur
Administrateur
Administrateur
 
Messages: 11265
Inscription: 06 Fév 2007
Localisation: France

Messagepar elcascador972 » Mer 14 Mar, 2012 2:15

Underground78 a écrit:Tu as essayé de remuxer le fichier que tu as dans un mkv ?

Oui mais pas mieux...Le fichier .mkv obtenu se lit sans problème dans vlc mais présente le même soucis dans la prévisualisation de m4ng : 1ère image figée et son OK.

En fait, quand on avance la vidéo "à la main" dans la prévisualisation, on a bien la suite de la vidéo mais qui reste aussi figée (j'espère être clair !). C'est le décodage du flux vidéo de la source qui...euh..semble cafouiller on dirait bien :hop:
Quand le sage montre la lune, le fou regarde le doigt
Avatar de l’utilisateur
 
Messages: 402
Inscription: 14 Mai 2011
Localisation: 14° 46' 57'' Nord / 60° 59' 37'' Ouest

Messagepar Underground78 » Mer 14 Mar, 2012 9:47

Tu pourrais mettre un lien pour récupérer la vidéo en question ?
Avatar de l’utilisateur
Administrateur
Administrateur
 
Messages: 11265
Inscription: 06 Fév 2007
Localisation: France

Messagepar elcascador972 » Mer 14 Mar, 2012 23:48

Bonsoir Underground78 !

Ci-joint 2 liens vers le site ImageShack :

http://imageshack.us/clip/my-videos/4/p0rx.mp4/

http://img4.imageshack.us/img4/344/p0rx.mp4

en espérant que l'un des 2 au moins te permettra de récupérer la vidéo (dont le titre a été curieusement modifié ???)
Quand le sage montre la lune, le fou regarde le doigt
Avatar de l’utilisateur
 
Messages: 402
Inscription: 14 Mai 2011
Localisation: 14° 46' 57'' Nord / 60° 59' 37'' Ouest

Messagepar Underground78 » Jeu 15 Mar, 2012 0:35

Le lien ne semble pas fonctionnel. :/
Avatar de l’utilisateur
Administrateur
Administrateur
 
Messages: 11265
Inscription: 06 Fév 2007
Localisation: France

Messagepar elcascador972 » Jeu 15 Mar, 2012 3:27

Quand le sage montre la lune, le fou regarde le doigt
Avatar de l’utilisateur
 
Messages: 402
Inscription: 14 Mai 2011
Localisation: 14° 46' 57'' Nord / 60° 59' 37'' Ouest

Messagepar Underground78 » Jeu 15 Mar, 2012 11:58

J'ai un peu de mal à m'en sortir avec ce fichier ... J'ai réussi à avoir une image mais elle est toute déformée.

Je te tiens au courant !

Ah oui ce que tu peux faire c'est vérifié que tu as bien tout ce qu'il faut pour que le fichier soit décodé avec des filtres DirectShow, pour ça tu télécharges GraphStudioNext et tu fais un cliquer-glisser de ton fichier dedans et tu regardes ce que ça donne.
Avatar de l’utilisateur
Administrateur
Administrateur
 
Messages: 11265
Inscription: 06 Fév 2007
Localisation: France

Messagepar Underground78 » Jeu 15 Mar, 2012 12:34

Bon j'ai fini par m'en sortir !

Voila le graphe DirectShow qui est utilisé sur mon PC et ci-dessous le script modifié que j'ai utilisé :
Code: Tout sélectionner
# **** m4ng & AVIsynth 2.5x script **** pass 2+

LoadPlugin("C:\PROGRA~1\m4ng_v3\system\undot.dll")
LoadPlugin("C:\PROGRA~1\m4ng_v3\system\FluxSmooth.dll")
LoadPlugin("C:\PROGRA~1\m4ng_v3\system\Convolution3D.dll")
LoadPlugin("C:\PROGRA~1\m4ng_v3\system\MaskTools.dll")
LoadPlugin("C:\PROGRA~1\m4ng_v3\system\MVTools.dll")
LoadPlugin("C:\PROGRA~1\m4ng_v3\system\Asharp.dll")
LoadPlugin("C:\PROGRA~1\m4ng_v3\system\MSharpen.dll")
LoadPlugin("C:\PROGRA~1\m4ng_v3\system\TDeint.dll")

Source="voisins.mp4" # à modifier
Largeur=0
Hauteur=0
ratio  =-1.#IND00
vratio =-1.#IND00
real_l=0
real_l4=0
Crop_g=0
Crop_d=0
Crop_h=0
Crop_b=0
Borders_g=0
Borders_d=0
Borders_h=0
Borders_b=0
Indice=-1.#IND00

# Video=DirectShowSource( Source, fps=1.000000).DelayAudio(0.000000)
Video=DirectShowSource(Source, pixel_type="RGB").DelayAudio(0.000000)
Video=BilinearResize(Video, 640, 360)
Video=ConvertToYV12(Video)
# Video=BilinearResize(Video, Largeur, Hauteur)

Return(AssumeFrameBased(Video))


Si tu veux changer la taille de la vidéo, il faudra le faire à la main dans le script par contre.
Avatar de l’utilisateur
Administrateur
Administrateur
 
Messages: 11265
Inscription: 06 Fév 2007
Localisation: France

Messagepar elcascador972 » Ven 16 Mar, 2012 2:17

Salut ! Et merci du temps que tu consacres à mon problème !

Au niveau de GraphStudioNext, ça donne ça sur mon PC : étonnant de longueur pour le flux vidéo ! Ca doit expliquer mon problème !



Sur ton graph, je vois que tu as LAV Splitter d'ou une question : faut il que je l'installe avant de modifier le script ou seule la modification du script suffit ?
Quand le sage montre la lune, le fou regarde le doigt
Avatar de l’utilisateur
 
Messages: 402
Inscription: 14 Mai 2011
Localisation: 14° 46' 57'' Nord / 60° 59' 37'' Ouest

Messagepar Underground78 » Ven 16 Mar, 2012 11:14

Hmm commence par essayer juste la modification du script pour voir. Si ça ne fonctionne pas, tu peux essayer de désactiver le décodage par ffdshow et installer LAVFilters pour décoder le VP8 (et éventuellement servir de splitter).
Avatar de l’utilisateur
Administrateur
Administrateur
 
Messages: 11265
Inscription: 06 Fév 2007
Localisation: France

Messagepar elcascador972 » Sam 17 Mar, 2012 16:55

C'est maintenant impeccable dans la prévisualisation mais effectivement, il faut à la fois modifier le script ET installer LAV Splitter.

Pour le réencodage, le fichier obtenu se lit sans soucis si je choisis de réencoder en .AVI (Xvid+mp3). Par contre, si je choisis du .mkv ou du .mp4 (x264+aac pour les 2 conteneurs), le fichier obtenu présente le même soucis .

Mais bon, on a fortement progressé et je vais me contenter de ça pour le moment !

Merci underground 78 !

PS : c'est vrai que vu le débit vidéo du fichier source, ce codec VP8 est très prometteur !
Quand le sage montre la lune, le fou regarde le doigt
Avatar de l’utilisateur
 
Messages: 402
Inscription: 14 Mai 2011
Localisation: 14° 46' 57'' Nord / 60° 59' 37'' Ouest

Messagepar Underground78 » Sam 17 Mar, 2012 17:52

Ça parait bizarre qu'un réencodage en x264 pose problème quand le XviD marche mais bon on sait jamais ...

Pour ce qui est de la qualité, à priori le vp8 ne fait quand même pas réellement le poids face au x264 justement.
Avatar de l’utilisateur
Administrateur
Administrateur
 
Messages: 11265
Inscription: 06 Fév 2007
Localisation: France

Précédente

Retourner vers Software

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité