[Résolu] Pb pour flouter

Fusion des anciens forums encodage et re-encodage

Modérateur : Modérateurs

Verrouillé
Avatar du membre
misterd
Messages : 483
Enregistré le : mer. 24 oct., 2007 19:01

[Résolu] Pb pour flouter

Message par misterd » sam. 07 févr., 2009 14:34

Bonjour,
je n'arrive pas à parametrer m4ng pour flouter une partie de l'image ici en gris :

Je mets du flou de partout sauf ou je le veux.
Merci à vous.
Modifié en dernier par misterd le sam. 07 févr., 2009 19:47, modifié 6 fois.
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23122
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » sam. 07 févr., 2009 14:42

bon, il faut connaitre la résolution de ton image, mettons 300x300, là ça devrait être du
gauche 280, haut 20, droite 299, bas 60...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar du membre
misterd
Messages : 483
Enregistré le : mer. 24 oct., 2007 19:01

Message par misterd » sam. 07 févr., 2009 14:58

Mon image fait 400x320, et en essayant tes cotes et d'autres, j'ai le même message qui revient suivant les dimensions essayées :
et l'image est affichée comme etant du 500x56
Avatar du membre
misterd
Messages : 483
Enregistré le : mer. 24 oct., 2007 19:01

Message par misterd » sam. 07 févr., 2009 15:14

j'ai réussi enfin (380-20-400-120), mais ce n'est pas si simple que ça, vu tous les messages d'erreurs rencontrés.
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23122
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » sam. 07 févr., 2009 15:24

euh, la résolution 500x76 n'est pas la résolution de l'image de base, c'est celle du message d'erreur à l'écran... en fait, il ne faut pas cropper pour flouter, ou alors après le floutage, sinon AVisynth râle qu'il manque des bouts d'image, ce n'est pas évident on est bien d'accord...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar du membre
BiGf0oT
Administrateur
Administrateur
Messages : 6072
Enregistré le : sam. 03 févr., 2007 23:10
Localisation : Dans ma grotte
Contact :

Message par BiGf0oT » sam. 07 févr., 2009 15:26

misterd a écrit :et l'image est affichée comme etant du 500x56
ca c est la la taille d affichage du message d erreur

si tu avais ce genre de message c est que tu depassais la resolution de ta video au niveau du positionnement de ta zone flouttée
Proverbe Chien : Si ça ne se mange pas, Si ça ne se baise bas, Pisse dessus !
Avatar du membre
misterd
Messages : 483
Enregistré le : mer. 24 oct., 2007 19:01

Message par misterd » sam. 07 févr., 2009 15:47

euh, la résolution 500x76 n'est pas la résolution de l'image de base, c'est celle du message d'erreur à l'écran
:whi:

Mes messages d'erreurs venaient du fait que je ne pouvais pas agrandir, par exemple, xgauche "indéfiniment" sans mofifier à un moment donné xdroit. Sinon j'obtenais des erreurs, les 2 sont liés.
Avatar du membre
rouillou
Messages : 143
Enregistré le : lun. 03 déc., 2007 13:09

Message par rouillou » ven. 06 avr., 2012 12:42

Je dois dire que je m'y colle en ce moment, et je me demande s'il n'y aurait pas un moyen plus simple.

1. Régler la taille du floutage.
2. Régler le positionnement.
3. Aller se boire un cocktail?

Ca serait beauuuuu!!
Quand on va vraiment au bout des choses, on trouve toujours la même chose: Un précipice...
Avatar du membre
rouillou
Messages : 143
Enregistré le : lun. 03 déc., 2007 13:09

Message par rouillou » ven. 06 avr., 2012 12:58

J'ai un 1280*720p et un beau logo m6.
J'ai beau m'approcher du truc, dans les derniers réglages, quelque chose m'échappe, mais alors grave!!
Ca donne envie de se taper la tête contre les murs sérieux...

Je n'ai jamais la taille de floutage voulue.
Ni l'emplacement exact.

Voilà!
Quand on va vraiment au bout des choses, on trouve toujours la même chose: Un précipice...
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23122
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » sam. 07 avr., 2012 5:12

C'est simple pourtant :D
Tu as une image de 1280x720 ... Il faut d'abord "estimer" la position du logo, l'idéal est de faire une capture écran taille réèlle puis d'aller dans un soft d'édition d'image pour trouver sa position exacte en pixels, mettons qu'il soit en haut à droite à la position 1000 depuis la gauche et 10 depuis le haut de l'image, il faut ensuite trouver la taille de ce logo, mettons 100x80...
Ca nous donnerait dans m4ng :
X gauche : 1000
Y haut : 10
X droit : 1000+ largeur du logo (100) = 1100
Y bas : 10 + hauteur du logo (80) = 90
il faut cocher "rendre la zone floue" et éventuellement le "récupérer image en dessous de la zone" pour ne pas flouter le logo lui-même mais une portion de l'image en dessous de celui ci...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar du membre
rouillou
Messages : 143
Enregistré le : lun. 03 déc., 2007 13:09

Message par rouillou » lun. 09 avr., 2012 23:23

Absolument d'accord avec toi, pepsilite!

Une fois que l'on sait qu'il faut donner la même info aux deux paramètres opposés: Gauche-droite et Haut-bas, et qu'ensuite il faut y rajouter la taille du logo estimée, d'accord, c'est facile... :ange:

Seulement... je n'ai trouvé cette info nulle part avant ça.

Et puis logoaway est quand même un peu plus instinctif, je trouve.

Merci encore pour ces précisions indispensables.

Une fois de plus. :yeap:
Quand on va vraiment au bout des choses, on trouve toujours la même chose: Un précipice...
Verrouillé