MPC-HC + EVR Custom Pres. + DirectVobSub = Problème ?

Modérateur : Modérateurs

Répondre
Avatar du membre
Seb007
Messages : 12
Enregistré le : mer. 07 mars, 2012 10:44

MPC-HC + EVR Custom Pres. + DirectVobSub = Problème ?

Message par Seb007 » sam. 11 août, 2012 9:46

Bonjour

Avant de passer à l'ère du "HD", donc les DivX, je n'avais pas de problème avec l'affichage
des sous-titres "srt" sur Media Player Classic Home Cinema avec option "VMR-9" cochée +
DirectVobSub d'installé.


Aujourd'hui il y a le MKV...
Sur mon PC je suis obligé de cocher l'option "EVR Custom Pres." pour avoir l'accéleration
materielle afin d'obtenir une bonne fluidité du MKV HD (sans ça c'est saccade en folie)...
Je n'ai pas un PC ultra-récent, il a au moins 8 ans... Bref...


Du coup avec cette option DirectVobSub n'affiche plus les sous-titres !
Je viens juste de me rendre compte de ça parce qu'il y a longtemps que je ne m'étais pas
servis de sous-titrage... Dès que je remets "VMR-9" ça réaffiche bien... :kes:

Du coup il y a t'il une solution à part balancer le PC par la fenêtre ?

Merci
Avatar du membre
Underground78
Administrateur
Administrateur
Messages : 11269
Enregistré le : mar. 06 févr., 2007 21:54
Localisation : France
Contact :

Message par Underground78 » sam. 11 août, 2012 18:43

Salut,

Hmm, théoriquement l'accélération matériel devrait fonctionner aussi avec VMR-9 (renderless). Tu as essayé le moteur de rendu de sous-titres internes de MPC-HC aussi ?

Si tu arrives à me trouver un sample de taille raisonnable ça m'intéresse.

Je suis aussi intéressé par le contenu du menu "Play" > "Filters" dans les deux cas.

Ah oui et pour être sûr, teste une version récente de MPC-HC.
Avatar du membre
Seb007
Messages : 12
Enregistré le : mer. 07 mars, 2012 10:44

Message par Seb007 » lun. 13 août, 2012 15:48

Salut

Je viens de prendre la nouvelle version (j'étais encore sous la 1.4) ...
Maintenant il y a des coches vertes ou des croix rouges qui indique
ce que l'on dispose lorsqu'on choisi tel ou tel filtre de sortie.

Avec l'EVR, on a bien le DXVA


Avec le VMR-9, on ne l'a plu ;)


Et voici les filtres ouverts en DXVA :


Du coup, avec le sample que je viens de créer, je viens de retester le
fichier sous-titre... il ne s'affiche qu'avec le moteur interne de MPC-HC...

OK ça fonctionne mais j'aurai voulu avoir "comme avant" avec VobSub ^^
Serait-ce à cause de l'acceleration materiel ??? (ou DXVA)


Lien du Sample 1min en 720p + srt (86 Mo) : http://srparty.fr/Divers/Sample.rar
Avatar du membre
Ducke
Administrateur
Administrateur
Messages : 8621
Enregistré le : jeu. 08 févr., 2007 18:02

Message par Ducke » lun. 13 août, 2012 16:31

je viens de voir sur ton site qu'on habite très près l'un de l'autre :mrgreen:
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar du membre
Seb007
Messages : 12
Enregistré le : mer. 07 mars, 2012 10:44

Message par Seb007 » lun. 13 août, 2012 17:56

Tu es d'où ? ^^
(depuis j'ai un peu migré à la "frontière" du 85/79)
Avatar du membre
Ducke
Administrateur
Administrateur
Messages : 8621
Enregistré le : jeu. 08 févr., 2007 18:02

Message par Ducke » lun. 13 août, 2012 17:56

je passe en message privé :yeap:
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar du membre
Underground78
Administrateur
Administrateur
Messages : 11269
Enregistré le : mar. 06 févr., 2007 21:54
Localisation : France
Contact :

Message par Underground78 » lun. 13 août, 2012 18:48

Salut,
Seb007 a écrit :Je viens de prendre la nouvelle version (j'étais encore sous la 1.4) ...
Maintenant il y a des coches vertes ou des croix rouges qui indique
ce que l'on dispose lorsqu'on choisi tel ou tel filtre de sortie.

Avec l'EVR, on a bien le DXVA

Avec le VMR-9, on ne l'a plu ;)
Hmm sous XP j'ai bien la croix verte pour le DXVA avec VMR-9 (sans rendu). Il est possible que ça ne fonctionne pas sous Vista/Seven. Je vais me renseigner et éventuellement corriger l'indicateur s'il est faussé.
Seb007 a écrit :Du coup, avec le sample que je viens de créer, je viens de retester le
fichier sous-titre... il ne s'affiche qu'avec le moteur interne de MPC-HC...

OK ça fonctionne mais j'aurai voulu avoir "comme avant" avec VobSub ^^
Serait-ce à cause de l'acceleration materiel ??? (ou DXVA)
Possible que ça soit à cause d'un bug connu et pas encore corrigé dans VSFilter, je vais tester le sample.
Après utiliser le moteur de sous-titres interne ou VSFilter ça ne change pas grand chose puisque la grande majorité du code est commune.
Avatar du membre
Underground78
Administrateur
Administrateur
Messages : 11269
Enregistré le : mar. 06 févr., 2007 21:54
Localisation : France
Contact :

Message par Underground78 » lun. 13 août, 2012 19:03

Bon j'ai fait quelques tests :
- l'indicateur est bien correct, le mode DXVA n'a pas l'air de marcher sous Seven avec le moteur de rendu VMR-9 (sans rendu).
- les sous-titres sont bien affichés dans tous les cas avec ou sans VSFilter MAIS le DXVA ne semble pas être activé quand VSFilter est utilisé.

Je vais essayer de me renseigner.

Edit : J'ai eu ma réponse, pas de DXVA possible avec VSFilter puisqu'il est nécessaire que le décodeur soit connecté directement au moteur de rendu or VSFilter va s'intercaler entre les deux. Conclusion si tu veux avoir du DXVA et les sous-titres, utilise le moteur de rendu interne (qui est exactement identique à VSFilter puisque c'est le même code).
Avatar du membre
Seb007
Messages : 12
Enregistré le : mer. 07 mars, 2012 10:44

Message par Seb007 » lun. 13 août, 2012 21:39

OK ;)

Merci bien de la reponse bien expliquée ^^

Du coup je vais faire avec, pas le choix :lol:
Avatar du membre
Underground78
Administrateur
Administrateur
Messages : 11269
Enregistré le : mar. 06 févr., 2007 21:54
Localisation : France
Contact :

Message par Underground78 » mar. 14 août, 2012 17:35

Pas de problème ! :)
Répondre