Des nouvelles de m4ng v4 ...

Sorties et mises à jour

Modérateur : Modérateurs

Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » dim. 28 oct., 2012 17:11

Soit je suis ramolli du cerveau soit je suis fatigué mais je ne comprends RIEN à tout ça ...
Désolé mais là je ne vois pas ce que je dois faire pour résoudre le problème, je suis complètement à la rue.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » dim. 28 oct., 2012 17:13

@matou, ce sont les entrées "preset" et "tuning" de la BDR qui sont réinitialisées?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8564
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Message par Subbat » dim. 28 oct., 2012 17:14

pepsilite a écrit :Soit je suis ramolli du cerveau soit je suis fatigué mais je ne comprends RIEN à tout ça ...
Désolé mais là je ne vois pas ce que je dois faire pour résoudre le problème, je suis complètement à la rue.
Qu'est ce que tu comprends pas...
Image
Image Image
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » dim. 28 oct., 2012 17:16

Je n'ai pas quelque chose en particulier que je ne comprends, je ne comprends RIEN en totalité ... :D
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » dim. 28 oct., 2012 18:35

LA question étant : "est-ce que m4ng doit ou non conserver les paramètres de qualité et d'optimisation si on change de type d'encodage? (cad avec un nouveau preset différent)".
Les avis sont partagés.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar du membre
Underground78
Administrateur
Administrateur
Messages : 11269
Enregistré le : mar. 06 févr., 2007 21:54
Localisation : France
Contact :

Message par Underground78 » dim. 28 oct., 2012 18:40

Je pense qu'il ne doit pas les conserver dans ce cas là, par contre il ne faudrait pas qu'il envoie la notification de changement de preset à m4ng x264 config quand le preset n'a pas été changé manuellement.

Est-ce que tu vois ce que je veux dire ?
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8564
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Message par Subbat » dim. 28 oct., 2012 18:48

Moi je ne vois pas tout à fait ce qu'U78 veut dire dans sa 2ème partie... mais je pense également que chaque changement de preset doit remettre la qualité et l'optimisation à "zero"... c'est à dire à medium sans tune...
Image
Image Image
Avatar du membre
Underground78
Administrateur
Administrateur
Messages : 11269
Enregistré le : mar. 06 févr., 2007 21:54
Localisation : France
Contact :

Message par Underground78 » dim. 28 oct., 2012 18:50

J'ai l'impression que même si l'utilisateur ne resélectionne pas un preset, m4ng envoie quand même la notif. Il faudrait que Pepsi voit dans son code dans quel cas la notif est envoyée exactement.
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » dim. 28 oct., 2012 19:14

Bon, c'est la galère ce truc, il y a 4 entrées :
1. le "device" choisi dans la liste x264
2. le "preset", la vitesse en fait
3. le "tuning", l'optimisation
4. l'"options" qui comporte les 3 paramètres à la suite, ça j'avoue que je ne me souviens plus pourquoi elle y est.
m4ng ne gère aucunement et à aucun niveau le "preset" et le "tuning", il en fait que récupérer la valeur définie dans le panel pour l'attribuer à la tache en cours mais il ne renvoie JAMAIS ces valeurs au panel ou à la BDR.
Quand on choisit un preset x264 dans la liste ou qu'on choisit le codec x264 dans le menu déroulant, les valeurs de preset et tuning sont remises à 0 par une bizarrerie que je ne m'explique pas vu que je ne saisis pas bien (voire pas du tout) le rôle de la clef "options" dans tout ça.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8564
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Message par Subbat » dim. 28 oct., 2012 19:16

Bah contrairement à ce que disait ricou, le fichier x264.cli conserve le dernier profil qu'a définit l'utilisateur (preset, qualité et optimisation)... Donc si on sélectionne le codec x264 depuis la liste des codecs, effectivement c'est les infos contenus dans le x264.cli qui sont conservées à l'encodage me semble-t-il... et là je trouves ça bien... et ça répond à l'attente de notre ami... En revanche, si on sélectionne un preset, là le x264.cli se réinitialise pour prendre les valeurs du preset...

Donc, finalement, moi je ne changerais rien... Il faudrait juste éventuellement faire en sorte que le panneau de config puisse lire ces données... et ne pas indiquer "medium" et "sans" (optimisation) si ce n'est pas le cas dans le x264.cli...

[edit]oups un peu long à répondre...
Modifié en dernier par Subbat le dim. 28 oct., 2012 19:23, modifié 1 fois.
Image
Image Image
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8564
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Message par Subbat » dim. 28 oct., 2012 19:21

Subbat a écrit :Donc si on sélectionne le codec x264 depuis la liste des codecs, effectivement c'est les infos contenus dans le x264.cli qui sont conservées à l'encodage me semble-t-il... et là je trouves ça bien...
Ah bah non en fait... j'étais persuadé du contraire...
Image
Image Image
ricou
Messages : 106
Enregistré le : dim. 29 juil., 2012 13:43

Message par ricou » dim. 28 oct., 2012 19:26

Désolé pour la galère. :)

subbat, chez moi, comme l'a dit pepsi, dès qu'on sélectionne le codec x264 dans la liste des codecs, le fichier x264cli est réinitialisé au profil medium sans tuning.

Je viens de me rendre compte également que lorsque je clic sur le preset x264 (dans la barre horizontal en haut, où il y a xvid, divx, x264, bluray, etc ; c'est bien ça que vous appelez preset ?), m4ng plante et se ferme.
Enfin je m'en moque je ne m'en sers jamais, c'est juste pour info.
Ca le fait toujours après avoir supprimé tout le dossier m4ng se trouvant dans les application data.


EDIT : tu me rassures
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » dim. 28 oct., 2012 19:35

Pourquoi ça change chez toi?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8564
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Message par Subbat » dim. 28 oct., 2012 19:40

@ pepsi : c'est à moi que tu poses la question ?

@ricou : ça planterait pas parce que tu as mis le x264.cli en lecture seule par hasard ?
Image
Image Image
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » dim. 28 oct., 2012 19:44

Subbat a écrit :@ pepsi : c'est à moi que tu poses la question ?

Oui, à toi, le x264 ne change pas si on ne fait que sélectionner le x264 dans la liste

@ricou : ça planterait pas parce que tu as mis le x264.cli en lecture seule par hasard ?

Il y a fort à parier...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8564
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Message par Subbat » dim. 28 oct., 2012 19:45

pepsilite a écrit :
Subbat a écrit :@ pepsi : c'est à moi que tu poses la question ?

Oui, à toi, le x264 ne change pas si on ne fait que sélectionner le x264 dans la liste
Si il change... le x264.cli ne change pas au démarrage de m4ng... mais dès lors qu'on sélectionne le codec, là il change...
Image
Image Image
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » dim. 28 oct., 2012 19:51

Ben non pourtant, il ne change ni au démarrage de m4ng, ni au choix du codec x264 ni même au lancement de l'encodage, il ne change QUE quand on choisit un preset ou qu'on va dans le panel de config du x264 ...
Ce n'est pas parce que notepad te dit qu'il a été modifié qu'il l'a vraiment été, il a été "re-sauvegardé, c'est tout
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8564
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Message par Subbat » dim. 28 oct., 2012 19:55

Bah non, je t'assures, chez moi il change... le preset revient sur medium et le tune s'en va...
Image
Image Image
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » dim. 28 oct., 2012 19:58

tu vérifies ça comment?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8564
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Message par Subbat » dim. 28 oct., 2012 20:03

j'ouvres mon x264.cli avec notepad++, je lances m4ng, je charges une vidéo, je choisis un preset et je modifies ses paramètres (qualité et optimisation), je vais sur notepa++ qui me dis que mon fichier a été modifié et me propose de le mettre à jour... je met oui... le x264.cli a bien le preset et le tune que je lui ai demandé... je fermes m4ng... je l'ouvres à nouveau... Ok, le x264.cli n'a pas bougé... je charges une vidéo, je choisi le x264 cli dans la liste des codec... je rafraichis le x264.cli dans notepad++, et le preset revient sur medium et plus de tune...
Image
Image Image
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » dim. 28 oct., 2012 20:11

On ne doit pas avoir le même m4ng alors parce que je l'ai vérifié et re--vérifié, rien n'est changé en dehors de ce que j'ai mis au dessus...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
ricou
Messages : 106
Enregistré le : dim. 29 juil., 2012 13:43

Message par ricou » dim. 28 oct., 2012 20:16

Subbat a écrit :@ricou : ça planterait pas parce que tu as mis le x264.cli en lecture seule par hasard ?
Non, j'y avais pensé, et c'est justement pour vérifier si ce n'était pas un bidouillage qui faisait ça que j'ai testé en supprimant le dossier m4ng de application data
Subbat a écrit :j'ouvres mon x264.cli avec notepad++, je lances m4ng, je charges une vidéo, je choisis un preset et je modifies ses paramètres (qualité et optimisation), je vais sur notepa++ qui me dis que mon fichier a été modifié et me propose de le mettre à jour... je met oui... le x264.cli a bien le preset et le tune que je lui ai demandé... je fermes m4ng... je l'ouvres à nouveau... Ok, le x264.cli n'a pas bougé... je charges une vidéo, je choisi le x264 cli dans la liste des codec... je rafraichis le x264.cli dans notepad++, et le preset revient sur medium et plus de tune...
Voilà, tout pareil chez moi, je viens de vérifier (avec le notepad windows).

En sachant que c'est bien ce qui est écrit dans ce fichier qui est utilisé par l'encodeur, puisque si on le modifie avec notepad sans ouvrir le panneau de configuration x264, les paramètres sont pris en compte.

EDIT : pourtant tu as écris ça pepsi :
pepsilite a écrit :Quand on choisit un preset x264 dans la liste ou qu'on choisit le codec x264 dans le menu déroulant, les valeurs de preset et tuning sont remises à 0 par une bizarrerie que je ne m'explique pas vu que je ne saisis pas bien (voire pas du tout) le rôle de la clef "options" dans tout ça.
C'est pas la même chose que tu voulais dire ?
Modifié en dernier par ricou le dim. 28 oct., 2012 20:17, modifié 1 fois.
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8564
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Message par Subbat » dim. 28 oct., 2012 20:16

pepsilite a écrit : Quand on choisit un preset x264 dans la liste ou qu'on choisit le codec x264 dans le menu déroulant, les valeurs de preset et tuning sont remises à 0 par une bizarrerie que je ne m'explique pas
Euh... bah alors on dit la même chose... quand on choisit le x264 dans la liste des codec (le menu déroulant), les valeurs sont remises à 0... c'est bien ce que je dis...
subbat a écrit :je choisi le x264 cli dans la liste des codec... je rafraichis le x264.cli dans notepad++, et le preset revient sur medium et plus de tune...
Image
Image Image
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » dim. 28 oct., 2012 20:18

Subbat a écrit :
pepsilite a écrit : Quand on choisit un preset x264 dans la liste ou qu'on choisit le codec x264 dans le menu déroulant, les valeurs de preset et tuning sont remises à 0 par une bizarrerie que je ne m'explique pas
Euh... bah alors on dit la même chose... quand on choisit le x264 dans la liste des codec (le menu déroulant), les valeurs sont remises à 0... c'est bien ce que je dis...
subbat a écrit :je choisi le x264 cli dans la liste des codec... je rafraichis le x264.cli dans notepad++, et le preset revient sur medium et plus de tune...
Non, on ne dit pas la même chose, quand je parle des valeurs remises à 0, je parle dans le panel du codec x264, toi tu nous parles du x264.cli dans le notepad...
Modifié en dernier par pepsilite le dim. 28 oct., 2012 20:22, modifié 1 fois.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » dim. 28 oct., 2012 20:22

- Le fichier x264.cli n'est modifié QUE quand on choisit un preset x264 (par le BOUTON x264, pas dans la liste déroulante avec les autres codecs) et quand on modifie à la main les paramètres dans le panel du codec .

- Les valeurs du panel sont remises à 0 uniquement quand on choisi le codec x264 dans la liste déroulante avec les autres codecs, il est actualisé dans tous les autres cas, chargement d'une tache, lancement de l'encodage ou choix d'un preset x264 de m4ng etc etc.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Répondre