Re encodage 24 im/s to 25 im/s

Modérateur : Modérateurs

superpopo
Messages : 16
Enregistré le : lun. 16 mars, 2009 22:49

Re encodage 24 im/s to 25 im/s

Message par superpopo » lun. 16 mars, 2009 23:14

Bonjour,

merci pour ce logiciel !

petite question : est il possible de ré encoder un mkv de 24 im/s en mkv (sortie final en .mp4 apparemment si h264 cli) en 25 img/s et ce simplement
+ un décalage (accélération ?) automatique du son (apparemment mkv en DTS vers Ac3)?

Merci. :d:
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » lun. 16 mars, 2009 23:36

Salut à toi
Tu n'as pas besoin de réencoder la vidéo pour passer de 24 à 25 fps, il suffit de démuxer la vidéo du MKV en format brut .264 puis de la remuxer dans un autre MKV en précisant 25 fps, par contre il te faudra accélerer l'audio mais là ça n'est pas aussi simple il faut la démuxer en WAV, la passer dans le "time stretching" de m4ng et réencoder le WAV final en AC3 et remuxer le tout.
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar du membre
Puppet
Modérateur
Modérateur
Messages : 5855
Enregistré le : sam. 03 févr., 2007 20:04
Localisation : Arcueil

Message par Puppet » lun. 16 mars, 2009 23:54

Mais quel est le but de tout ca ? ^^"
Image
Avatar du membre
Ducke
Administrateur
Administrateur
Messages : 8628
Enregistré le : jeu. 08 févr., 2007 18:02

Message par Ducke » mar. 17 mars, 2009 7:10

:welc sur le forum superpopo


:mdr
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
superpopo
Messages : 16
Enregistré le : lun. 16 mars, 2009 22:49

Message par superpopo » mar. 17 mars, 2009 12:28

Bonjour et merci à tous !

le but est de pouvoir lire sans saccades (effet judder) des films au format mkv sur ma freebox HD et ma futur TV full HD, en effet le 24 im/s si il n'est pas bien traité par la TV c horrible à regarder !

J'ai bien vu les explications de la première réponse je vais essayer de les suivre et vous tiens au courant durant la semaine ! :mrgreen:
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » mar. 17 mars, 2009 13:02

Je me doutais que c'était pour ça, la prochaine version de m4ng intégrera des outils pour faire ce passage très facilement...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
superpopo
Messages : 16
Enregistré le : lun. 16 mars, 2009 22:49

Message par superpopo » mer. 18 mars, 2009 13:23

Salut,

alors j'ai fait quelques tests hier soir ça a l'air de bien fonctionner mais j'ai des questions :

Lors du remux du fichier video + fichier piste son (d'ailleurs MMG ou M4NG pour le remux ?) ou doit on indiquer les 25 fps ? Seul MMG le propose ?!?

Oupps je viens de voir :

[Tuto] Changer le framerate d'un film 23.976 fps NTSC

C vers la fin :

16. aller dans le module "décalage son"
17. charger la copie de film
18. changer le fps en 25 (il doit être à 23.976)
19. cliquer sur (appliquer à la vidéo d'origine)


C bien ça ?

N'y a t il pas une perte de qualité sonore lors du ré en codage de la piste son vers wav puis vers AC 3 (+ 5.1 coché) ? Doit on sélectionner une qualité particulière (maxi 356 avec AC3 rien en Wav) ?

J'ai eu un petit problème avec un piste DTS d'un film de 1h 15 environ qui sortait en wav (et donc après en Ac3) systématiquement en 41m25s comme si le re encodage bloquer à ce temps précis.

N'ayant pas d'autres film mkv+DTS je ne puis tester si c récurrent ?

:o:

Merci
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » mer. 18 mars, 2009 13:36

superpopo a écrit :Salut,

alors j'ai fait quelques tests hier soir ça a l'air de bien fonctionner mais j'ai des questions :

Lors du remux du fichier video + fichier piste son (d'ailleurs MMG ou M4NG pour le remux ?) ou doit on indiquer les 25 fps ? Seul MMG le propose ?!?

Il faut utiliser MMG et impérativement démuxer en .264 pour que justement MMG demande quel fps utiliser vu qu'il n'est pas stocké dans un .264. pour le spécifier il faut sélectionner la piste .264 dans la partie "tracks :" puis l'onglet "Format specific options" et la case "fps", elle ne sera malheureusement dégrisée que si la piste vidéo est en .264...

Oupps je viens de voir :

[Tuto] Changer le framerate d'un film 23.976 fps NTSC

C vers la fin :

16. aller dans le module "décalage son"
17. charger la copie de film
18. changer le fps en 25 (il doit être à 23.976)
19. cliquer sur (appliquer à la vidéo d'origine)


C bien ça ?

Non, cette manip ne s'applique pas au MKV, tu dois faire comme je l'ai dit dans mon message plus haut...

N'y a t il pas une perte de qualité sonore lors du ré en codage de la piste son vers wav puis vers AC 3 (+ 5.1 coché) ? Doit on sélectionner une qualité particulière (maxi 356 avec AC3 rien en Wav) ?

Etant donné que le passage au WAV change la vitesse de l'audio, il y a forcément une perte, mais elle est négligeable. Le débit maxi du AC3 avec m4ng 1.4.0 est 384 kbps, il peut y avoir une petite perte de qualité par rapport au DTS original, mais tu n'as pas le choix, il faut réencoder le son...

J'ai eu un petit problème avec un piste DTS d'un film de 1h 15 environ qui sortait en wav (et donc après en Ac3) systématiquement en 41m25s comme si le re encodage bloquer à ce temps précis.

Quelle est la taille du WAV "timestretché"?

N'ayant pas d'autres film mkv+DTS je ne puis tester si c récurrent ?

:o:

Merci
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
superpopo
Messages : 16
Enregistré le : lun. 16 mars, 2009 22:49

Message par superpopo » mer. 18 mars, 2009 22:58

Ok pour la video !


Mais je change juste la valeur du Fps et ne touche pas au reste je suppose que MMg garde le reste : aspect/ratio... identique à la vidéo initial H264 ?

Quelle est la taille du WAV "timestretché"?

Avant stretch waw : 454 Mo

Après Stretch waw : 435 Mo

Mais je viens de faire un test : lors du demux avec MEG de la piste DTS s'arrête aussi à 41 min donc j'en conclu qu'il y a un blem avec la piste son à la base....


En plus je suis en plein devirussage alors je n'ai pas eu le temps de chercher un autre film avec DTS ...

Merci
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » mer. 18 mars, 2009 23:17

devirussage?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar du membre
Underground78
Administrateur
Administrateur
Messages : 11269
Enregistré le : mar. 06 févr., 2007 21:54
Localisation : France
Contact :

Message par Underground78 » mer. 18 mars, 2009 23:24

Bataille contre un virus je pense.
superpopo
Messages : 16
Enregistré le : lun. 16 mars, 2009 22:49

Message par superpopo » jeu. 19 mars, 2009 12:56

Underground78 a écrit :Bataille contre un virus je pense.
:yeap:
Oui c malheureusement çà !
superpopo
Messages : 16
Enregistré le : lun. 16 mars, 2009 22:49

Message par superpopo » sam. 28 mars, 2009 16:10

bonjour,

me revoilou : donc j'ai du formater mon disque dur pour pouvoir m'en sortir (et j'en suis pas encore sur...)

Alors du coup j'ai re installé M4ng mais je n'ai pas mis toute les composantes : j'ai juste installé matroska pack + ac3 + wma.

Donc j'ai récupéré correctement mon fameux fichier en DTS, je le demux, je transforme le DTS en Wav 5.1 puis je reprend le wav pour le time streché et la patatra :

virtual dub mod crash à 10-16 % et m'indique :

"An out-of-bounds memory access (access violation) occurred in module 'ntdll'."

http://www.imagup.com/imgs/1238277917.html

J'ai tester avec un autre fichier AC3 et re-belote ...

alors voilà, une idée ?

Précision : Avant formatage ca avait l'aire de fonctionner....)
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » sam. 28 mars, 2009 16:18

vu que c'est un gros plantage de la mort qui tue de windows, pas facile de t'aider sur ce coup là ... si tu pars d'un mp3 pour faire cette manip, est-ce que ça passe?
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar du membre
Underground78
Administrateur
Administrateur
Messages : 11269
Enregistré le : mar. 06 févr., 2007 21:54
Localisation : France
Contact :

Message par Underground78 » sam. 28 mars, 2009 16:19

Bonjour,

Je doute qu'on arrive à apprendre quoi que ce soit avec ce message d'erreur (l'assembleur c'est rigolo mais pas très simple).

Essaie à partir d'un wav stéréo pour commencer (tu peux le générer à partir de n'importe quel mp3 par exemple).
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » sam. 28 mars, 2009 16:21

:mdr
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
superpopo
Messages : 16
Enregistré le : lun. 16 mars, 2009 22:49

Message par superpopo » sam. 28 mars, 2009 16:33

bonjour et merci,

J'ai récupéré un mp3 libre de droit sur le net et ça fonctionne sans soucis....

J'ai désinstallé et re installé M4NG rien ne change ...

Et si je re ré implante virtual dub dans le répertoire M4NG ?
superpopo
Messages : 16
Enregistré le : lun. 16 mars, 2009 22:49

Message par superpopo » sam. 28 mars, 2009 18:03

bon y en a marre.... :grr:

je recrache une image de ma partition c: et je re installe le tout

On va bien voir :glups:
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » sam. 28 mars, 2009 19:02

c'est peut être le fait que la source soit en 5.1 qui fait planter, vu qu'une en stéréo passe...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
Avatar du membre
Underground78
Administrateur
Administrateur
Messages : 11269
Enregistré le : mar. 06 févr., 2007 21:54
Localisation : France
Contact :

Message par Underground78 » sam. 28 mars, 2009 19:03

Donc visiblement ça vient du multicanal, c'est étrange ...

Edit : Les grands esprits se rencontrent ... :mrgreen:

NB: @Pepsi : on ne rigole pas avec l'assembleur, j'ai des cours de ça moi ... :mad:
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23129
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Message par pepsilite » sam. 28 mars, 2009 19:12

ce n'était pas de l'assembleur dont je me gaussais, d'ailleurs j'ai pratiqué aussi dans le temps où je faisais des jeux, je riais de constater à quel point ta réponse était identique à la mienne, et ça s'est confirmé encore juste au dessus...
05/07/15 m4ng v5 est disponible au téléchargement en version finale : m4ng v5
superpopo
Messages : 16
Enregistré le : lun. 16 mars, 2009 22:49

Message par superpopo » sam. 28 mars, 2009 19:34

je confirme ca passe avec un fichier DTS transformé en waw 2 CH mais pas lorsque je coche 5.1, le time stretching me fait planter virtual DUB.....

Des idées ?

dois je installer tout le pack de codec ?
Avatar du membre
Underground78
Administrateur
Administrateur
Messages : 11269
Enregistré le : mar. 06 févr., 2007 21:54
Localisation : France
Contact :

Message par Underground78 » sam. 28 mars, 2009 20:19

Hum avec ce fichier en gardant le 5.1, tu as le problème ?

@Pepsi : Oki ;)
Avatar du membre
BiGf0oT
Administrateur
Administrateur
Messages : 6072
Enregistré le : sam. 03 févr., 2007 23:10
Localisation : Dans ma grotte
Contact :

Message par BiGf0oT » sam. 28 mars, 2009 20:30

as tu parametré le AC3 en 5.1 au moins dans le pack m4ng ?
Proverbe Chien : Si ça ne se mange pas, Si ça ne se baise bas, Pisse dessus !
superpopo
Messages : 16
Enregistré le : lun. 16 mars, 2009 22:49

Message par superpopo » sam. 28 mars, 2009 20:50

BiGf0oT a écrit :as tu parametré le AC3 en 5.1 au moins dans le pack m4ng ?
euh ? ou çaaaaaaaaaaaa qu'on fait ça ? tu veux dire dans le codec pac le AC3 oui je l'ai installé.

Je dl le fichier envoyé par underground pendant ce temps.

Non avec le fichier son tout pareil ca plante virtual dub :cry:
Modifié en dernier par superpopo le sam. 28 mars, 2009 20:58, modifié 1 fois.
Répondre