Peut on revenir à la version antérieure

Pour les retours sur la v5 uniquement ...
Répondre
guy
Messages : 29
Enregistré le : jeu. 21 nov., 2013 11:59
Localisation : gironde

Peut on revenir à la version antérieure

Message par guy » mer. 15 mai, 2019 11:40

Bonjour la team, bonjour à tous!
Je reviens vers vous après plusieurs années d'absence tout en restant fidèle à votre bébé que j'utilisais régulièrement pour de petits travaux d'encodage après avoir franchi les étapes de prises en main en 2013 & 14 !
Et puis, je vais peut être vous choqué, j'ai eu l'idée saugrenue -...pour moi bien entendu - de passer à la version 5, et, depuis malgré tous mes efforts et mes recherches...je ne peux plus rien faire :grrr:
:spo: ma 1ère question "pouvez me mettre à dispo cette version": 27 janvier 2014 : Setup complet - m4ng™ v4 4.0.2200.434 , qui m'allait comme un gant car je n'ai nul besoin de tous les autre outils
En désespoir de cause dans un 2ème temps je vous expliciterai quelques sont mes pb actuels, malgré toutes mes tentatives pour m'en sortir
Merci d'avance pour votre réponse et surtout votre aide
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8517
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Re: Peut on revenir à la version antérieure

Message par Subbat » mer. 15 mai, 2019 15:26

Salut à toi,

Pour ce qui est de la version 4, je ne saurais te répondre. Il faut attendre le passage de pepsi pour ça...

En attendant dit nous quels sont les soucis que tu rencontres avec la version 5. (colle ici au passage la configuration multimédia qui apparait à gauche dans la fenêtre de m4ng à l'ouverture)
Image
Image Image
guy
Messages : 29
Enregistré le : jeu. 21 nov., 2013 11:59
Localisation : gironde

Re: Peut on revenir à la version antérieure

Message par guy » mer. 15 mai, 2019 18:00

Merci de ton concours Subbat,
voici ma config
m4ng Video Analyser [ 5.1.0.2 ]

(ChainLess: OFF)

[ Video ]
DivX : - [ INTROUVABLE ]
Xvid : OK [ Xvid Video Codec ]
X264 (cli) : OK [ x264 0.155.2901 7d0ff22 ]
X264 (vfw) : OK
X265 (cli) : OK [ 2.8.0.10 ]
Ffmpeg : OK [ ffmpeg version N-91690-g844ff49469 Copyright (c) 2000-2018 the FFmpeg developers ]
DivX 3.11 : - [ INTROUVABLE ]
Quicktime Alternative : - [ INTROUVABLE ]
Quicktime Lite : - [ INTROUVABLE ]
CoreAVC : - [ INTROUVABLE ]
Real Alternative : OK [ 2.0.2 ]
Real Video 10 : OK (Alternative)
LAVFilters : - [ INTROUVABLE ]
ffdshow : OK [ ffdshow v1.3.4533 [2014-09-29] ]
----------------------------------------------------
[ Audio ]
CORE - AAC Codec : OK [ 1.2.0.575 ]
CORE - VORBIS Codec : - [ INTROUVABLE ]
LAME - MP3 Codec : OK [ 0.9.1.0 ]
AC3 Filter : OK [ 1.63b ]
Oggcodecs : - [ INTROUVABLE ]
OggDs : - [ INTROUVABLE ]
----------------------------------------------------
[ Miscs ]
Windows : Windows 7 Home Premium [Windows 7 Home Premium]
UAC : User Account Control OFF
Temp : C:\Users\guy\AppData\Roaming\m4ng\
Matroska Splitter : OK [ 1.10.262.12 ]
DGindex : OK [ 1.5.0.0 ]
m4ng Codec Pack : OK [ v 2.0 ]
DVDFab : - [ INTROUVABLE ]
Web Browser : C:\Program Files (x86)\Google\Chrome\Application\chrome.exe
----------------------------------------------------
[ Avisynth ]
AVIsynth.dll OK [ 2.6.0.6 ]
C:\Program Files (x86)\AviSynth 2.5\plugins\*.*
- colors_rgb.avsi OK
- DirectShowSource.dll OK
- TCPDeliver.dll OK
----------------------------------------------------
[ Matroska (MKV) ]
MKVExtractGui by DP : OK [ 1.6.5.300 ]
MKVtoolnix : OK [ v4.4.0.0 ]
MUX MKV : C:\Program Files (x86)\MKVtoolnix\mkvmerge.exe OK
DEMUX MKV : C:\Program Files (x86)\MKVtoolnix\mkvextract.exe OK
----------------------------------------------------
Drives :
C:\ D:\ E:\ F:\

C: - DRIVE_FIXED
D: - DRIVE_CDROM
E: - DRIVE_FIXED
F: - DRIVE_FIXED

** END OF FILE - 01826 bytes

Mes soucis
1) le codec Xvid , la derniére version téléchargée, n'apparait pas, j'ai remis la version du pack d'origine. Faut il le placer dans un dossier spécifique?

2) chaque fois que j'encode un MKV ou réencode un AVI j'ai ce message d'erreur

Avisynth open failure
Script error : There is no function named 'Decimate'
c:\users\guy\AppData\roaming\m4ng\Am4ng.avs line 40

le ficher en cause (ci aprés)

# **** m4ng & AVIsynth 2.5x script **** pass 2+

LoadPlugin("C:\PROGRA~2\m4ng_v5\system\undot.dll")
LoadPlugin("C:\PROGRA~2\m4ng_v5\system\FluxSmooth.dll")
LoadPlugin("C:\PROGRA~2\m4ng_v5\system\Convolution3D.dll")
LoadPlugin("C:\PROGRA~2\m4ng_v5\system\MaskTools.dll")
LoadPlugin("C:\PROGRA~2\m4ng_v5\system\MVTools.dll")
LoadPlugin("C:\PROGRA~2\m4ng_v5\system\Asharp.dll")
LoadPlugin("C:\PROGRA~2\m4ng_v5\system\MSharpen.dll")
LoadPlugin("C:\PROGRA~2\m4ng_v5\system\TDeint.dll")
LoadPlugin("C:\PROGRA~2\m4ng_v5\system\VSFilter.dll") #1
LoadPlugin("C:\PROGRA~2\m4ng_v5\system\Cnr2.dll")

Source="F:\AT4D57~1\LINTER~1\LINTER~1.MKV"
Largeur=720
Hauteur=304
ratio =2.368421
vratio =2.368421
real_l=720
real_l4=720
Crop_g=0
Crop_d=0
Crop_h=0
Crop_b=0
Borders_g=0
Borders_d=0
Borders_h=0
Borders_b=0
Bit_Rate=0.000000
Indice=0.228436

LoadPlugin("C:\PROGRA~2\m4ng_v5\system\ffms2.dll")

LoadPlugin("C:\PROGRA~2\m4ng_v5\system\soxfilter.dll")
Import("C:\PROGRA~2\m4ng_v5\system\FFMS2.avsi")
FFIndex( Source, indexmask=-1, dumpmask=0, errorhandling=3, overwrite=false)
Video=FFVideoSource( Source, track=-1, cache=true )
Audio=FFAudioSource( Source, track=-1, cache=true ).DelayAudio(-0.042000)
Video=Audiodub(Video, Audio)
Video=Decimate(Video, cycle=6, quality=3)

Video=ConvertToYV12(Video)
LoadPlugin("C:\PROGRA~2\m4ng_v5\system\decomb.dll")
Video=Decimate(Video, cycle=5, quality=3)

#0 RESIZE
Video=BilinearResize(Video, Largeur, Hauteur)
# SHARPEN
LoadPlugin("C:\PROGRA~2\m4ng_v5\system\MSharpen.dll")
Video=MSharpen (Video)
# CNR2
#Video=Cnr2(Video, "xxx", 4, 5, 255) #soft
Video=Cnr2(Video, "oxx", 4, 5, 255) #strong

Return(AssumeFrameBased(Video))

Du fait que les codecs du pack sont désormais caducs j'ai mis à jour les versions de ffdshow et avisynth
J'ai cherché du fait de mon absence prolongée de voir parmi les posts publiés si je pouvais obtenir une réponse à ma galère...nada!

Enfin, peux tu me dire où dois-je chercher le panneau de l'utilisateur je voudrais changer mon password
merci à toi pour ton aide
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8517
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Re: Peut on revenir à la version antérieure

Message par Subbat » jeu. 16 mai, 2019 7:48

Pour ce qui est d'avisynth, il faut laisser la version qu'installe m4ng, d'autant que si je ne me trompe pas, m4ng utilises la version avisynth+ maintenant...

La fonction decimate dans ton scritp me semble être du au fait que tu utilises ffmpegsource comme décodeur avisynth, c'est un souhait délibéré ?
Et ton script ne me dit rien du tout, il est bouré d'appel à des plugin...

Je serais toi je commencerais par supprimer le dossier de travail de m4ng (%appdata% dans la barre explorer de windows,et tu supprimes le dossier m4ng)... ensuite, je supprimes dans programfiles les dossier avisynth (quel que soit le numéro de version...) et enfin je relance une installation de m4ng...

Pour ce qui est de xvid, ne t'embarasse pas à mon sens... s'il n'est pas installé, m4ng utilise la librairie xvid de ffmpeg... c'est exactement la même chose...

Par contre, pour ce qui est des mkvtoolnix, il serait bon que tu penses à mettre à jour... elle est franchement vieillote ta version...
Et je vois que tu n'as pas lavfilter d'installer... ce serait mieux de le faire... regarde ce post ici sur les codecs dans m4ng : viewtopic.php?f=56&t=7498

Enfin pour ce qui est du panneau utilisateur... dans la barre de menu en haut à droite, tu cliques sur le petit bonhomme... ;)

@+
Image
Image Image
guy
Messages : 29
Enregistré le : jeu. 21 nov., 2013 11:59
Localisation : gironde

Re: Peut on revenir à la version antérieure

Message par guy » jeu. 16 mai, 2019 11:29

Je te remercie Subbat te préoccuper de mes soucis. Je vais me lancer à me conformer à tes conseils et recommandations et je te tiendrai au courant bien entendu.
Pour répondre à ta question concernant l'utilisation de ffmpegsource ce n'est pas du tout volontaire, je pense que c'est peut être le fait que je n'ai pas retiré le dossier de travail lors du changement de version, et qu'il subsistait une info dans ce sens.
Toutefois, je reste toujours désireux d'obtenir la version 4 dans le cas où mes galères persistent ou non ....à mon âge (+70) on n'est peu emballé à se mettre constamment les mains dans le cambouis lol!
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8517
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Re: Peut on revenir à la version antérieure

Message par Subbat » jeu. 16 mai, 2019 12:15

Je ne suis pas sur que la version 4 règle ton problème...

Et si tu fais des encodages assez simple et que tu ne veux pas avoir à mettre les mains dans le cambouis, je te conseilles de mettre m4ng en mode autonome... Il n'utilise pas avisynth ni aucun autre outil tiers... c'est un encodeur interne à m4ng (ffmpeg) qui décode la source et la ré-encode en ce que tu veux... ce mode autonome fait tout ce que le mode normal utilisant avisynth fait à 1 ou 2 exception près je crois pour lesquels avisynth est un peu mieux (mais c'est pour des filtres bien spécifiques...)
Image
Image Image
guy
Messages : 29
Enregistré le : jeu. 21 nov., 2013 11:59
Localisation : gironde

Re: Peut on revenir à la version antérieure

Message par guy » ven. 17 mai, 2019 18:04

Bonjour à tous , bonjour à toi Subbat,
Merci de tes conseils que j'ai mis en pratique :cart: , j'ai commencé à faire des essais d'encodage qui s'avèrent ...presque entièrement satisfaisants pour moi, à l'exception d'un pb sur l'AC3 en sortie qui passe parfaitement sur mon micro mais non sur ma platine de salon qui ne lit que l'AC3 et qui est je l'avoue ancienne génération.
Mais je l'aborderai plus tard, si tu veux bien, dans l'immédiat je fais des tests sur le mode autonome en comparant les résultats et reviendrai vers toi
Pour le fun, la dernière version de Xvid est bien reconnu par mg4ng dans la fenêtre ad'hoc
J'ai bien changé mon mot de passe et merci aussi pour çà
En attendant bonne soirée à tous
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8517
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Re: Peut on revenir à la version antérieure

Message par Subbat » ven. 17 mai, 2019 20:33

;)
Image
Image Image
guy
Messages : 29
Enregistré le : jeu. 21 nov., 2013 11:59
Localisation : gironde

Re: Peut on revenir à la version antérieure

Message par guy » lun. 20 mai, 2019 18:14

Bonjour à tous et bonjour Subbat,
Comme annoncé je reviens vers vous après avoir tenté de convertir un grand nombre de MKV (y compris un .AVI équipé d'un codec MP4v) .
tout d'abord dans le mode avancé
Le traitement des vidéos se fait parfaitement celui de l'audio semble correct pas de message d'erreur , par contre le MUX ( fichier de sortie: out_nomfichier.avi ) est lu, au niveau audio, par mon micro mais pas par ma platine de salon -comme je l'ai déjà dit- mais si je fais le MUX avec l'outil externe (clé à molette) le fichier de sortie : nomfichier_mux.avi le son passe alors sur cette platine mais....avec un gros décalage!!!
en mode autonome
j'ai le même résultat sur le fichier de sortie ; out_nomfichier.avi sur ma platine (pas de son) et si j'intègre des sous-titres, les sous- titres srt se font mais là pas de son du tout, micro + platine! :beuh:
J'ai tenté à plusieurs reprises en mode autonome de convertir ce fichier .AVI codec MPEG 4 'MP4v) résultat le fichier double de capacité et le son passe mais....avec un gros décalage.
Je ne sais pas si je suis clair, mais moi je me perds dans tout çà, je suppose qu'il va vous falloir des éléments autres pour m'apporter une réponse, en attendant voici ma config modifiée depuis mon entretien avec Subbat

4ng Video Analyser [ 5.1.0.2 ]

(ChainLess: OFF)

[ Video ]
DivX : - [ INTROUVABLE ]
Xvid : OK [ Xvid Video Codec ]
X264 (cli) : OK [ x264 0.155.2901 7d0ff22 ]
X264 (vfw) : OK
X265 (cli) : OK [ 2.8.0.10 ]
Ffmpeg : OK [ ffmpeg version N-91690-g844ff49469 Copyright (c) 2000-2018 the FFmpeg developers ]
DivX 3.11 : - [ INTROUVABLE ]
Quicktime Alternative : - [ INTROUVABLE ]
Quicktime Lite : - [ INTROUVABLE ]
CoreAVC : - [ INTROUVABLE ]
Real Alternative : OK [ 2.0.2 ]
Real Video 10 : OK (Alternative)
LAVFilters : OK [ 0.74.1 ]
ffdshow : OK [ ffdshow v1.3.4533 [2014-09-29] ]
----------------------------------------------------
[ Audio ]
CORE - AAC Codec : OK [ 1.2.0.575 ]
CORE - VORBIS Codec : - [ INTROUVABLE ]
LAME - MP3 Codec : OK [ 0.9.1.0 ]
AC3 Filter : OK [ 1.63b ]
Oggcodecs : - [ INTROUVABLE ]
OggDs : - [ INTROUVABLE ]
----------------------------------------------------
[ Miscs ]
Windows : Windows 7 Home Premium [Windows 7 Home Premium]
UAC : User Account Control OFF
Temp : C:\Users\guy\AppData\Roaming\m4ng\
Matroska Splitter : OK [ 1.10.262.12 ]
DGindex : OK [ 1.5.0.0 ]
m4ng Codec Pack : OK [ v 2.0 ]
DVDFab : - [ INTROUVABLE ]
Web Browser : C:\Program Files (x86)\Google\Chrome\Application\chrome.exe
----------------------------------------------------
[ Avisynth ]
AVIsynth.dll OK [ 0.1.0.0 ]
C:\Program Files (x86)\AviSynth+\plugins\*.*
----------------------------------------------------
[ Matroska (MKV) ]
MKVExtractGui by DP : OK [ 1.6.5.300 ]
MKVtoolnix : OK [ v33.1.0.0 ]
MUX MKV : C:\Program Files\MKVToolNix\mkvmerge.exe OK
DEMUX MKV : C:\Program Files\MKVToolNix\mkvextract.exe OK
----------------------------------------------------
Drives :
C:\ D:\ E:\ F:\ H:\

C: - DRIVE_FIXED
D: - DRIVE_CDROM

merci de votre réponse
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8517
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Re: Peut on revenir à la version antérieure

Message par Subbat » mar. 21 mai, 2019 16:54

A mon avis c'est que ton fichier source est merdique au vu de ce que tu dis... un coup ça marche pas complètement, un coup ça marche mais avec décalage... Et si le mode autonome se casse les dents dessus, c'est que vraiment la source a un soucis...
Si en mode autonome tu n'as ce problème qu'avec cette vidéo, ne cherche pas, c'est là source qui est complètement foireuse... et on ne pourra pas y faire grand chose... d'autant que tu parles de mp4v... ce dont moi je n'ai jamais entendu parlé...
Image
Image Image
guy
Messages : 29
Enregistré le : jeu. 21 nov., 2013 11:59
Localisation : gironde

Re: Peut on revenir à la version antérieure

Message par guy » mer. 22 mai, 2019 10:47

Merci Subbat mais ce qui se passe avec ce fichier source est anecdotique d'autant qu'effectivement en mode avancé, je viens de le constater, il n'est pas reconnu par m4ng...on oublie !!

Non, ce qui m’intéresse c'est le pb de fond avec toutes les tentatives d'encodage, sur plusieurs MKV, en mode avancé et pour lesquels ma platine ne peut pas lire l'audio des fichiers MUX en sortie( OUT_*******.AVI ) alors qu"ils sont lus parfaitement (vidéo+audio) par mon micro. Jusqu'au mois de mars 2019 (date d'installation de la version 5.1) çà se passait bien y compris avec la version 5.0, les fichiers en sortie étaient bien lus sur les 2 supports! Mais de mémoire je faisais le MUX avec l'outil externe ( nomdefichier_mux.avi) (clé à molette) puisque j'avais un message d'erreur quand j'utilisais le MUX intégré out_nomdefichier.avi.
C'est ce qui me préoccupe actuellement , par avance merci
Avatar du membre
Ducke
Administrateur
Administrateur
Messages : 8597
Enregistré le : jeu. 08 févr., 2007 18:02

Re: Peut on revenir à la version antérieure

Message par Ducke » mer. 22 mai, 2019 17:02

Ton problème de lecture sur ta platine, c'est quand tu encodes avec le mode normal ou avec le mode autonome de m4ng? on s'y perd dans tes affaires :mad:
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Répondre