A nouveau plus de prévisualisation avec la dernière version

Pour les retours sur la v5 uniquement ...
phyllox
Messages : 269
Enregistré le : lun. 02 févr., 2009 19:19

A nouveau plus de prévisualisation avec la dernière version

Message par phyllox » mer. 19 déc., 2018 13:24

Hello, bonjour à tous
Je suis marqué par le destin !

J'avais eu des soucis de prévisualisation avec la version installée il y a quelques mois, soucis qui s'étaient mystérieusement réglés tous seuls en cochant la case démarrage automatique de la prévisualisation.

Je viens d'installer la version 5.1, et j'ai à nouveau le problème de prévisualisation.
Comme j'ai installé cette 5.1 par dessus la précédente sans la désinstaller, tous les réglages ont été conservés. En particulier les réglages vidéo (c'est lav filter qui décode tout), et la fameuse case est toujours cochée.

Dans GraphStudio, j'ai bien comme avant : Film.mp4 ---> LAV Video decoder ---> Video renderer

Quand je clique sur la nouvelle flèche à côté de la résolution, la prévisualisation démarre, mais affiche une fenêtre noire et qui le reste même si je démarre la lecture ou me déplace dans la vidéo.
.
Je peux faire un crop manuel (mais inutilisable pour mon besoin car j'ai besoin de voir les sous titres incrustés), je peux également lancer l'autocrop sans pouvoir visualiser son résultat.

J'ai ensuite désinstallé M4ng, puis AVISynth, renommé le répertoire M4ng dans Appdata\roaming. Puis tout réinstallé.
Même chose, prévisualisation impossible.

Je me rappelle que vous m'aviez demandé d'utiliser un logiciel dans graphstudio pour vérifier, mais je ne parviens pas à retrouver lequel.

Alors c'est reparti, j'ai à nouveau besoin de votre aide.
Merci d'avance. Bonne journée
phyllox
Messages : 269
Enregistré le : lun. 02 févr., 2009 19:19

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par phyllox » mer. 19 déc., 2018 14:33

Rebonjour
J'ai fini par retrouver le programme à glisser dans Graphstudio pour vérifier qu'il accepte AviSynth.
Contrairement à la derbière fois, ça ne fonctionne pas.

Avec Am4ng.avs, la fenêtre Graphstudio n'affiche pas de vidéo, seulement l'audio :

AviSynthVideo n'a pas de liaison
AviSynthAudio (Am4ng.avs a une liaison avec le default Directsound device

Si je clique sur les détails de Am4ng.avs, j'ai :
File Version : 6.2.17134.1
Product version : 10.0.17134.1

dans l'onglet aviSynth Video :
IsConnected : False

Il y a plein d autres informations, mais comme on ne peut pas faire de copier/coller... Et je ne sais pas lesquelles pourraient être utiles.
Merci d'avance
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8754
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par Subbat » jeu. 20 déc., 2018 18:40

Le plus simple pour éviter de chercher pendant des heures ce qui merde encore chez windows sur ton pc... c'est d'installer ffdshow... à l'installation tu lui demande de ne rien décoder... A chaque lancement de m4ng, m4ng ira lui dire de décoder pour la previsualisation et ça devrait être bon...
phyllox
Messages : 269
Enregistré le : lun. 02 févr., 2009 19:19

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par phyllox » jeu. 20 déc., 2018 20:18

Bonsoir Subbat (et bonsoir tout le monde)

Merci pour la réponse. Dans le post de septembre, j'avais demandé s'il fallait ffdshow... Je n'avais pas eu de répnse, mais vu que ça fonctionnait sans au final...

Bref, j'ai installé ffdshow x86 et x64 (je ne sais pas s'il faut les deux ou pas), et effectivement, j'ai retrouvé une image en prévisualisation.

Toutefois, il y a quelque chose de bizarre et pas facile à expliquer. L'image affichée est légèrement déformée en largeur, pour laisser de la place de chaque côté de l'image à une bande verticale pas très large, difficile de juger de la largeur (7 mm sur mon écran 24 pouces), bandes dans lesquelles s'affichent le contenu de la partie de la fenêtre ou du bureau qu'elles recouvrent.

Ces bandes réduisent d'autant la largeur de l'image affichée et l'écrasent.

Si je passe en crop manuel, l'image s'affiche normalement. Si je fais un autocrop, les bandes latérales sont considérées comme de l'image, mais après le réencodage (j'ai testé sur un petit bout de vidéo), elles ne sont plus là, et l'image a la résolution prévue.

Si je déplace la fenêtre, les colonnes avec leur contenu se déplacent avec, comme une image capturée.

C''est assez gênant parce qu'on ne peut pas juger si le format est bon, et c'est en plus très déroutant.

Une idée ? J'utilise une version pas très récente de ffdshow qui traînait sur une bécane (rev 4532 de mai 2016)

Merci d'avance. Bonne soirée
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8754
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par Subbat » sam. 22 déc., 2018 13:38

La ça me dépasse. Ce dont tu parles relève sans doute plus de Windows... et pas de ffdshow...
A la limite va voir dans les paramètres de m4ng. Il y a une option de démarrage auto de la prévisualisation. Essaie avec et sans voir si ça change quelque chose...
Sinon je ne vois pas...
phyllox
Messages : 269
Enregistré le : lun. 02 févr., 2009 19:19

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par phyllox » sam. 22 déc., 2018 16:24

Hello
Effectivement j'ai toujours le bug d'affichage des colonnes qui écrasent l'image après réinstall de la v5. On peut donc penser que c'est Windows.

Mais comme je ne l'avais pas avant d'installer la 5.1 et que Windows n'a pas été MAJ entre le moment où ça fonctionnait, et celui de l'install de la 5.1....
Je referai des essais quand tout le monde sera plus dispo, en attendant je fais avec mon bug, au moins avec la 5.0 les encodages ne plantent pas et la sortie est propre.

Bonnes fêtes de fin d'année à tout le monde.
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8754
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par Subbat » sam. 22 déc., 2018 18:47

Tu as essayé ça ?
Subbat a écrit : A la limite va voir dans les paramètres de m4ng. Il y a une option de démarrage auto de la prévisualisation. Essaie avec et sans voir si ça change quelque chose...
Sinon je ne vois pas...
phyllox
Messages : 269
Enregistré le : lun. 02 févr., 2009 19:19

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par phyllox » dim. 23 déc., 2018 23:29

Bonsoir

Oui, depuis septembre dernier j'ai cette option activée car sinon, je n'avais plus de prévisualisation avec la version précédente depuis la réinstallation de mon poste. J'avais fait un post à ce sujet. Je l'ai indiqué dans mon message initial cette fois ci. J'ai toujours les bandes déformantes.

Il me semble que M4ng fait une copie d'écran à un moment donné dans le processus, je ne sais plus pourquoi, je ne sais même pas si je l'ai jamais su. Est-ce que ça ne pourrait pas venir de là, puisque je retrouve dans les dites colonnes le contenu de la fenêtre qui a été recouverte par celle de m4ng ?

Enfin au moins la sortie est correcte, ce qui est le principal.
Qu'est ce que la nouvelle version installe qui est nouveau par rapport à la précédente, et qui ne serait pas désinstallé en remettant la version précédente ?

Merci, bonne soirée
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8754
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par Subbat » lun. 24 déc., 2018 18:54

Bah écoute, je crois que rien n'a changé côté prévisualisation...
m4ng 5.1 a surtout consisté en une refonte de l'interface et l'ajout du codec AV1
phyllox
Messages : 269
Enregistré le : lun. 02 févr., 2009 19:19

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par phyllox » mer. 26 déc., 2018 18:34

Bonsoir tout le monde
J'espère que vous avez tous passé un excellent Noël.

Subbat, j'ai bien compris que rien n'avait changé côté M4ng dans la prévisualisation. Mais toujours est-il que, partant d'une prévisualisation qui fonctionnait bien, une install d ela V5.1 a conduit a une prévisualisation que ne fonctionnait pus sans ffdshow, et avec des anomalies d'affichage. Et ces problème n'ont pas été corrigés par une désinstallation complète (avisynth et m4ng) et une réinstallation des dits en v5.0

Entre temps, je n'ai rein fait sur mon poste et Windows ne s'est pas mis à jour. (il l'a fait depuis, mais pas entre les deux opérations).

Je comprends aussi que c'est sans doute quelque chose sur mon poste qui fait que, mais ce quelque chose a été réveillé par l'install de la 5.1, et comme je ne sais pas comment M4ng fonctionne ni comment déboguer, je reste avec mon problème qui est gênant dès que l'autocrop ne fonctionne pas comme il le faudrait ce qui se produit assez souvent.

FFDshow ne devrait pas être nécessaire, c'était juste un palliatif, mais c'est un palliatif imparfait qui comme la plupartd es médicaments provoque des effets secondaires.
Ce qui serait intéressant (pour moi), c'est de comprendre pourquoi je n'ai ps de prévisualisation sans ffdshow.

Merci d'avance
Bonne soirée
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23228
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par pepsilite » sam. 29 déc., 2018 16:59

tu peux nous faire une capture écran de ta prévisualisation pour voir à quoi ressemble ton image déformée ?
06/01/2020 m4ng v6 est disponible au téléchargement en version finale : m4ng v6
phyllox
Messages : 269
Enregistré le : lun. 02 févr., 2009 19:19

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par phyllox » sam. 29 déc., 2018 17:49

Bonsoir Pepsi

Voici des captures pour 2 vidéos différentes.

Les deux premières images sont pour la même vidéo avant et après autocrop.

https://drive.google.com/file/d/1Dlh3z_ ... j8SuG/view
https://drive.google.com/file/d/1KPlcIO ... _Gi6s/view




Les 3 images suivantes sont pour un film en 4/3 avant et après autocrop (pour ce format, ça donne la même chose) avec une image supplémentaire avec le crop manuel qui donne le bon format.

https://drive.google.com/file/d/1m4nt6h ... RFAEj/view
https://drive.google.com/file/d/1CbuR26 ... s1DMl/view
https://drive.google.com/file/d/1pv6pGn ... eEDCQ/view






J'espère que ça va aider à comprendre car je n'ai pas de souci pour ces deux exemples en lecture, avant ou après encodage.

Merci d'avance.
Modifié en dernier par Ducke le sam. 29 déc., 2018 17:49, modifié 5 fois.
Raison : Ajout des bonnes url des images mises en lightbox... et suppression du message suivant qui fait doublon du coup...
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8754
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par Subbat » sam. 29 déc., 2018 18:50

J'ai supprimé ton dernier message (cf commentaire d'édition du message de ton message ci-dessus).

Tu devais néanmoins utiliser la version 5.1 de m4ng... Ca me l'a fait à un moment ça... et je ne sais plus de quoi ça venait... ton image n'est pas écrasée, mais tronquée sur les côtés... Pepsi se souviendra peut-être d'où venait ce bug d'affichage de la fenêtre de prévisualisation...
phyllox
Messages : 269
Enregistré le : lun. 02 févr., 2009 19:19

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par phyllox » sam. 29 déc., 2018 23:36

Hello Subbat

Avec la 5.1, j'ai en plus des soucis avec des batch qui ne s'exécutaient pas, sans que j'arrive à déterminer ce qui les différenciait des autres... Et qui se sont exécutés correctement une fois refaits en 5.0. Mais j'ai dit que je réessayerais... Je ne voulais pas mélanger les problèmes et accumuler les questions. Un problème après l'autre. En plus, j'espérais retrouver ma prévisualisation telle que je l'avais avant d'installer la 5.1.

J'espère que Pepsi aura souvenir du problème. S'il pouvait aussi avoir une idée sur le pourquoi ça ne fonctionne pas du tout sans ffdshow...

Bonne soirée
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23228
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par pepsilite » dim. 30 déc., 2018 16:04

Euh, t'es gentil Sub, mais elles sont où les images de notre ami maintenant ?
06/01/2020 m4ng v6 est disponible au téléchargement en version finale : m4ng v6
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23228
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par pepsilite » dim. 30 déc., 2018 16:06

phyllox a écrit :Hello Subbat

Avec la 5.1, j'ai en plus des soucis avec des batch qui ne s'exécutaient pas, sans que j'arrive à déterminer ce qui les différenciait des autres... Et qui se sont exécutés correctement une fois refaits en 5.0. Mais j'ai dit que je réessayerais... Je ne voulais pas mélanger les problèmes et accumuler les questions. Un problème après l'autre. En plus, j'espérais retrouver ma prévisualisation telle que je l'avais avant d'installer la 5.1.

J'espère que Pepsi aura souvenir du problème. S'il pouvait aussi avoir une idée sur le pourquoi ça ne fonctionne pas du tout sans ffdshow...

Bonne soirée
Les batchs et les profils utilisateurs ne sont plus compatibles avec la version 5.0, il faut les refaire pour la 5.1 ...
06/01/2020 m4ng v6 est disponible au téléchargement en version finale : m4ng v6
Avatar du membre
Ducke
Administrateur
Administrateur
Messages : 8628
Enregistré le : jeu. 08 févr., 2007 18:02

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par Ducke » dim. 30 déc., 2018 16:21

J'ai remis les images, je les avait dans mon historique de navigation, par contre je ne suis pas sur que ça fonctionne longtemps comme c'est hébergé sur GG drive avec des droits d'accès.

@phyllox peux-tu contrôler que les images sont dans le bon ordre, comme tu avais posté au départ.
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8754
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par Subbat » dim. 30 déc., 2018 17:20

Ducke a écrit :J'ai remis les images, je les avait dans mon historique de navigation, par contre je ne suis pas sur que ça fonctionne longtemps comme c'est hébergé sur GG drive avec des droits d'accès.

@phyllox peux-tu contrôler que les images sont dans le bon ordre, comme tu avais posté au départ.
Effectivement elles n'y sont déjà plus...
Avatar du membre
Ducke
Administrateur
Administrateur
Messages : 8628
Enregistré le : jeu. 08 févr., 2007 18:02

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par Ducke » dim. 30 déc., 2018 17:35

Subbat a écrit : Effectivement elles n'y sont déjà plus...
je viens de les héberger ailleurs, elles devraient rester
Image Image
Avant de poster votre problème, venez faire un tour dans la FAQ voir si la solution ne s'y trouve pas
INFOS UTILES
Image
Avatar du membre
Subbat
Administrateur
Administrateur
Messages : 8754
Enregistré le : jeu. 11 déc., 2008 20:12
Localisation : Quelque part... dans le centre de la France...

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par Subbat » dim. 30 déc., 2018 18:16

Ducke a écrit :
Subbat a écrit : Effectivement elles n'y sont déjà plus...
je viens de les héberger ailleurs, elles devraient rester
:boss:
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23228
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par pepsilite » dim. 30 déc., 2018 18:40

Subbat a écrit :... Ca me l'a fait à un moment ça... et je ne sais plus de quoi ça venait... ton image n'est pas écrasée, mais tronquée sur les côtés... Pepsi se souviendra peut-être d'où venait ce bug d'affichage de la fenêtre de prévisualisation...
J'avoue que non, ça ne me dit rien... Mais même si c'est étrange, il faut simplement se dire que les bords "transparents" sont en fait un bout de l'image et pas un manque, c'est juste que ces parties là ne s'affichent pas.
06/01/2020 m4ng v6 est disponible au téléchargement en version finale : m4ng v6
phyllox
Messages : 269
Enregistré le : lun. 02 févr., 2009 19:19

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par phyllox » lun. 31 déc., 2018 13:27

Hello bonjour tout le monde
Oui les images sont dans le bon ordre.

De toutes façons ce ne sont pas les exemples qui me manquent, je peux en remettre si besoin.
A noter que pour une image plus étalée horizontalement, un format 2:35 par exemple, l'image ets aussi "rapetissée", toujours avec ses colonnes. Déformée ou pas, elle est difficile à tailler, surtout quand il faut couper avec des sous titres incrustés.

Pepsi, j'ai bien vu qu'avec la 5.1, il fallait refaire profils et batchs, et c'est ce que j'avais fait. Mais c'est avec des batchs nouvellement créés que j'avais eu des soucis. Mais comme je vois que vous n'êtes pas tous accaparés par les fêtes, je vais retenter le coup et réinstaller la 5.1 pour faire de nouveaux essais.

Bonne journée
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23228
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par pepsilite » mar. 01 janv., 2019 12:16

Tu dis que les batchs ne s'exécutaient plus, cad ?
Il semblerait que ce soit l'autocrop qui engendre le pb, je ne peux pas le recréer chez moi vu que (merci windows 10 encore une fois) je n'ai plus à nouveau de prévisualisation du tout dans m4ng !
En fait, j'ai la prévisualisation là encore en lançant 2 sessions de m4ng en parallèle, ça commence à être pénible, mais en tout cas, l'autocrop ne génère pas ces bandes de "vides" chez moi.
06/01/2020 m4ng v6 est disponible au téléchargement en version finale : m4ng v6
phyllox
Messages : 269
Enregistré le : lun. 02 févr., 2009 19:19

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par phyllox » mar. 01 janv., 2019 23:57

Bonsoir Pepsi
Je vais réinstaller la 5.1 demain et faire de nouveaux tests en espérant avoir rêvé.
Je ne sais plus si j'avais fait les tests avec ou sans prévisualisation, il me semble que j'en avais fait un sans faire de crop, mais je peux me tromper.

Comme je l'ai dit, je ne voulais pas multiplier les problèmes. Je t'en dis plus demain
Bonne soirée
Avatar du membre
pepsilite
The Grinch
The Grinch
Messages : 23228
Enregistré le : sam. 03 févr., 2007 19:13
Localisation : Chez moi le plus possible ...

Re: A nouveau plus de prévisualisation avec la dernière vers

Message par pepsilite » mer. 02 janv., 2019 14:46

Je ne pense pas que tu aies rêvé malheureusement, tu as un pb chez toi, mais qui est plus à cause de windows que de m4ng, ce qui est encore moins simpe à résoudre.
06/01/2020 m4ng v6 est disponible au téléchargement en version finale : m4ng v6
Répondre